Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002588Zandronum[All Projects] Bugpublic2016-01-23 18:132018-09-30 22:12
ReporterFascistCat 
Assigned ToTorr Samaho 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002588: Client crash when pressing PageDown on Compatibility Options menu
DescriptionIn a multiplayer game, with you connected as a client, when you access this menu and then try to navigate the options using PgDwn and PgUp keys the client will crash. However, using the mousescroll doesn't make the client crash. Also if you first scroll with your mouse then use the keys it won't crash. It seems to cause problems only when you are at the top of the options list.
Steps To Reproduce1. Create a server.
2. Join the server.
3. Access the Compatibility Options menu.
4. Press PgDwn key.
Additional InformationUsing ZandroDev3.0-151228-1140 exe.
Attached Files

- Relationships
child of 0001091closedTorr Samaho Introduction of MENUDEF LUMP 

-  Notes
User avatar (0014164)
Dusk (developer)
2016-01-23 19:52

While the circumstances are Zandronum-specific, the root cause of the crash lies in ZDoom:http://forum.zdoom.org/viewtopic.php?f=2&t=50555 [^]
User avatar (0014166)
Dusk (developer)
2016-01-23 20:27

ZDoom fixed this.
User avatar (0014173)
Torr Samaho (administrator)
2016-01-24 13:04

I'll backport the fix once it's in GZDoom's master branch so that I can transplant it from our zdoom-sync branch.
User avatar (0014242)
Torr Samaho (administrator)
2016-01-30 14:10

I backported the ZDoom fix.
User avatar (0014246)
cobalt (updater)
2016-01-30 14:20

Issue addressed by commit 0829a706600a: - added some range checks to PgUp(PgDown code for option menus.
Committed by Christoph Oelckers on Wednesday 31 December 1969 23:59:57

Changes in files:

 src/menu/optionmenu.cpp | 18 ++++++++++++++++--
 1 files changed, 16 insertions(+), 2 deletions(-)

User avatar (0014268)
Ru5tK1ng (updater)
2016-01-31 21:42

This bug didn't happen with 160131-2023 no matter how many times I pressed pgup/down.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-01-23 18:13 FascistCat New Issue
2016-01-23 19:52 Dusk Note Added: 0014164
2016-01-23 19:52 Dusk Priority low => normal
2016-01-23 19:52 Dusk Severity minor => crash
2016-01-23 19:52 Dusk Status new => acknowledged
2016-01-23 19:52 Dusk Resolution open => waiting for zdoom
2016-01-23 20:26 Dusk Assigned To => Torr Samaho
2016-01-23 20:26 Dusk Status acknowledged => assigned
2016-01-23 20:27 Dusk Note Added: 0014166
2016-01-23 20:28 Dusk Resolution waiting for zdoom => open
2016-01-24 13:04 Torr Samaho Note Added: 0014173
2016-01-24 13:21 Dusk Relationship added child of 0001091
2016-01-24 13:21 Dusk Target Version => 3.0
2016-01-30 14:10 Torr Samaho Note Added: 0014242
2016-01-30 14:20 cobalt Status assigned => needs testing
2016-01-30 14:20 cobalt Steps to Reproduce Updated View Revisions
2016-01-30 14:20 cobalt Note Added: 0014246
2016-01-31 21:42 Ru5tK1ng Note Added: 0014268
2016-01-31 22:50 Dusk Status needs testing => resolved
2016-01-31 22:50 Dusk Fixed in Version => 3.0
2016-01-31 22:50 Dusk Resolution open => fixed
2018-09-30 22:12 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker