Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002472Zandronum[All Projects] Bugpublic2015-09-26 20:542015-10-10 15:22
ReporterAlienOverlord 
Assigned ToTorr Samaho 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
Platformx86_64OSWindowsOS Version7 Pro
Product Version3.0-beta 
Target VersionFixed in Version 
Summary0002472: Zandronum 3.0 150831-1814 crashes on ACS execution
DescriptionWell, basically.
I have a conversation system that reliably works on GZDoom g2.1.pre-930-gbaa775b.
I tried to run it on Zandronum 3.0 and got a nice client crash.
Happens in offline mode too.

PK3 attached. Press the switch on map01 in order to crash.
Additional InformationBefore introducing script 2 in the map (i.e. if I called Conversation_Init in script 1 serverside) the server would crash instead.
Attached Files? file icon zzconv.pk3 [^] (8,215 bytes) 2015-09-26 20:54

- Relationships

-  Notes
User avatar (0013557)
AlienOverlord (reporter)
2015-09-26 20:56

Oh and by the way, source code to the library, as well as source code to the map, are in the archive. But separately you can look at them here

http://pastebin.com/9fVXuwus [^] (lib)
http://pastebin.com/gTJaEqXF [^] (map)
User avatar (0013558)
Edward-san (developer)
2015-09-27 00:36

Can you reproduce this with GZDoom 1.8.6?
User avatar (0013562)
AlienOverlord (reporter)
2015-09-27 11:31

Yes. Well, that's bad. I really hoped this is a backporting issue. :(
User avatar (0013563)
Edward-san (developer)
2015-09-27 11:48

The crash is similar to the one I saw in zdoom, reported here. In fact, before crashing, zandronum reports "Unknown P-Code 365 in script 2", then it crashes.

Porting the zdoom fix won't help with the underlying issue: you're trying to use script/function arrays, which are not supported in gzdoom 1.8.6, hence in zandronum 3.0.
User avatar (0013565)
AlienOverlord (reporter)
2015-09-27 15:00

Right. Thanks for clarifying, I just made these temporary arrays global and it works now.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2015-09-26 20:54 AlienOverlord New Issue
2015-09-26 20:54 AlienOverlord File Added: zzconv.pk3
2015-09-26 20:56 AlienOverlord Note Added: 0013557
2015-09-27 00:36 Edward-san Note Added: 0013558
2015-09-27 00:36 Edward-san Assigned To => Edward-san
2015-09-27 00:36 Edward-san Status new => feedback
2015-09-27 11:31 AlienOverlord Note Added: 0013562
2015-09-27 11:31 AlienOverlord Status feedback => assigned
2015-09-27 11:48 Edward-san Note Added: 0013563
2015-09-27 11:48 Edward-san Assigned To Edward-san =>
2015-09-27 11:48 Edward-san Status assigned => new
2015-09-27 15:00 AlienOverlord Note Added: 0013565
2015-10-04 12:57 Torr Samaho Assigned To => Torr Samaho
2015-10-04 12:57 Torr Samaho Status new => acknowledged
2015-10-04 12:57 Torr Samaho Resolution open => backport later
2015-10-10 15:22 Torr Samaho Status acknowledged => closed
2015-10-10 15:22 Torr Samaho Resolution backport later => no change required






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker