Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002412Zandronum[All Projects] Bugpublic2015-08-23 16:422018-09-30 21:57
ReporterZalewa 
Assigned ToTorr Samaho 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002412: GZDoom related OpenGL crash in zdcmp2.
DescriptionThis Zandronum build is based off GZdoom 1.8.2:
https://zandronum.com/downloads/testing/3.0/ZandroDev3.0-150819-2351windows.zip [^]

This GZDoom build has a crash:
http://youtu.be/gzbwv7eMYO0 [^]
http://forum.zdoom.org/viewtopic.php?f=7&t=37519 [^]

Supposedly, GZdoom 2.0.02 fixes this crash.
Steps To ReproduceDownload ZDCMP2 here:
http://www.realm667.com/index.php/en/downloads/doom-wads/894-zdoom-community-map-project-2-take-2/file [^]
Additional InformationCrash occurs only on all video cards with max. OpenGL 3.3. Game won't crash on cards that support greater OpenGL.
Attached Files

- Relationships

-  Notes
User avatar (0013295)
Torr Samaho (administrator)
2015-08-27 17:50

https://zandronum.com/downloads/testing/3.0/ZandroDev3.0-150819-2351windows.zip [^] is based on GZDoom 1.8.6 and already has the crash fix fromhttp://forum.zdoom.org/viewtopic.php?f=7&t=37519 [^]

I assume GZDoom 1.8.6 also crashes, right? Then we'll need to figure out when GZDoom fixed the crash. How are the newer GZDoom 1.8.x versions, i.e. 1.8.7+?
User avatar (0013311)
Zalewa (developer)
2015-08-29 16:35

GZDoom 2.0.02 fixes the crash.
User avatar (0013312)
Torr Samaho (administrator)
2015-08-29 18:41

From what I heard GZDoom 1.8.10 does not fix the issue, even though it is newer than 2.0.02. Unfortunately, GZDoom 2.x uses a different rendering approach that requires OpenGL 3.x (and thus prevents many people from using the OpenGL renderer that could use them till now), so it's not certain that whatever fixed the crash in 2.x can be backported to 1.8.x.

Can somebody with the affected hardware confirm that GZDoom 1.8.10 still crashes and, if it does, report this at the GZDoom forum?
User avatar (0013322)
Torr Samaho (administrator)
2015-08-30 09:26
edited on: 2015-08-30 09:56

I can reproduce the problem on a Geforce GT 330M in GZDoom 1.8.6, GZDoom 1.8.7 and 1.8.10. So it looks like the 1.8.x never fixed this.

User avatar (0013323)
Torr Samaho (administrator)
2015-08-30 11:14

I think I figured out what the problem is: The voxel vertex buffer seems to be causing these issues.
User avatar (0013326)
Zalewa (developer)
2015-08-30 14:31

Great. Can it be backported without breaking compatibility with older OpenGL cards then?
User avatar (0013329)
Torr Samaho (administrator)
2015-08-30 15:30

I don't think that backporting the voxel vertex buffer from GZDoom 2.x is feasible (according to the logs it requires OGL 4.x anyway), but I could simply disable the buffer. This will bring a performance penalty on cards where the buffer worked, but should fix the problems you experience.
User avatar (0013330)
Torr Samaho (administrator)
2015-08-30 16:17

I turned off the buffer for non OGL 4 cards. This should fix the issues on the affected cards without a performance penalty on the cards where the buffer works.
User avatar (0013332)
cobalt (updater)
2015-08-30 16:58

Issue addressed by commit dcd42f3f50d0: Turned off the voxel vertex buffer for non-OGL 4 cards since its GZDoom 1.8.6 version wreaks havoc there (fixes 2412).
Committed by Benjamin Berkels [Torr Samaho] on Sunday 30 August 2015 17:55:58

Changes in files:

 src/gl/models/gl_voxels.cpp | 6 ++++--
 src/gl/system/gl_interface.cpp | 2 ++
 src/gl/system/gl_interface.h | 1 +
 3 files changed, 7 insertions(+), 2 deletions(-)

User avatar (0014719)
Zalewa (developer)
2016-04-15 18:18

I officially state that this is fixed.
Tested with Zandronum 3.0-alpha-r160131-2023.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2015-08-23 16:42 Zalewa New Issue
2015-08-23 17:01 Zalewa Description Updated View Revisions
2015-08-23 17:02 Zalewa Description Updated View Revisions
2015-08-27 17:50 Torr Samaho Note Added: 0013295
2015-08-29 16:35 Zalewa Note Added: 0013311
2015-08-29 18:41 Torr Samaho Note Added: 0013312
2015-08-30 09:26 Torr Samaho Note Added: 0013322
2015-08-30 09:43 Torr Samaho Note Edited: 0013322
2015-08-30 09:56 Torr Samaho Note Edited: 0013322 View Revisions
2015-08-30 09:56 Torr Samaho Note Revision Dropped: 13322: 0007973
2015-08-30 09:56 Torr Samaho Note Revision Dropped: 13322: 0007974
2015-08-30 11:14 Torr Samaho Note Added: 0013323
2015-08-30 12:06 Torr Samaho Assigned To => Torr Samaho
2015-08-30 12:06 Torr Samaho Status new => assigned
2015-08-30 14:31 Zalewa Note Added: 0013326
2015-08-30 15:30 Torr Samaho Note Added: 0013329
2015-08-30 16:17 Torr Samaho Note Added: 0013330
2015-08-30 16:58 cobalt Status assigned => needs testing
2015-08-30 16:58 cobalt Target Version => 3.0
2015-08-30 16:58 cobalt Description Updated View Revisions
2015-08-30 16:58 cobalt Steps to Reproduce Updated View Revisions
2015-08-30 16:58 cobalt Note Added: 0013332
2016-04-15 18:18 Zalewa Note Added: 0014719
2016-04-15 21:09 Ru5tK1ng Status needs testing => resolved
2016-04-15 21:09 Ru5tK1ng Resolution open => fixed
2016-04-15 21:09 Ru5tK1ng Fixed in Version => 3.0
2016-04-15 21:09 Ru5tK1ng Description Updated View Revisions
2016-04-15 21:09 Ru5tK1ng Steps to Reproduce Updated View Revisions
2016-11-20 21:33 Edward-san Product Version 3.0 => 3.0-beta
2018-09-30 21:57 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker