Zandronum Chat on our Discord Server Get the latest version: 3.1
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001813Zandronum[All Projects] Bugpublic2014-06-04 04:402024-07-08 13:44
ReporterJKist3 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001813: Original Sound Curve - Compatibility Options - Bug
DescriptionThis flag no longer works. When turned on, the sound curve should be the original shorter range sound curve from doom2.exe and when turned off the sound curve should be the longer range sound curve found in zdoom 1.22/1.23. Currently the shorter original sound curve is the only sound curve used regardless of this flag's setting.

ZDoom eventually changed back to use only the original sound curve and when updating to use a newer version of zdoom this sound curve flag was broken.

I talked to Dusk about this and he's looked into it a bit but hasn't been able to fix it so far (reintroduce the older zdoom sound curve as an option for this flag)
Attached Files? file icon orig_sndcurve_01.wad [^] (26,244 bytes) 2024-06-28 05:36
? file icon oldzdoom_soundcurve.wad [^] (10,316 bytes) 2024-07-05 19:57
? file icon oldzdoom_soundcurve_plasmafix.wad [^] (10,605 bytes) 2024-07-08 13:42

- Relationships

-  Notes
User avatar (0008843)
Dusk (developer)
2014-06-04 07:33

ZDoom 1.23 beta 33 seems to use the Hexen sound curve, the sndcurve.lmp included md5sum-matches with that of Hexen. Odamex also includes the same lump. Though just adding the sound curve lump to zandronum.pk3 with a different name and toggling it with a compatibility option doesn't seem to do what's desired: the sound curve becomes drastic and doesn't have the rolloff-laxing effect that the aforementioned ports feature.
User avatar (0008877)
Watermelon (developer)
2014-06-07 18:41

I'm assuming Randy decided to re-do the sound engine?

If so, I wonder if it's worth finding the distance things would roll off and then adding compat for that? Unless it's not inconvenient to add in whatever was changed. I know that 'reverse-porting' in an old set of sound instructions could possibly be down-right hair-removing.
User avatar (0008900)
JKist3 (reporter)
2014-06-08 01:55

What happens when hexen is played with Zandronum? does it use the hexen sound curve then?
User avatar (0008935)
Dusk (developer)
2014-06-08 20:08

Closing:
- introducing the accurate sound curve is with the current sound code not feasible
- the extended rolloff desired can be modded with an SNDINFO lump
User avatar (0008936)
Watermelon (developer)
2014-06-08 20:23
edited on: 2014-06-08 20:23

ADDON (even though this ticket is closed):

To JKist:
This means that you can create your sound with the SNDINFO lump and include it with your wads.

User avatar (0023770)
unknownna (updater)
2024-06-28 05:35

I decided to look into this recently, and figured out from testing that the old ZDoom/Hexen sound curve fades out sounds after 1900 map units, compared to Doom's 1200. After figuring this out, I can see why this would be very important to you in PvP modes, since the longer fade-out distance allows you to hear sounds from a much longer range and also matches the older, familiar ZDoom behavior.

I created a wad for you to test and enable this oldschool behavior back with. The only difference I noticed with the wad is that the most distant sounds from the player are sometimes slightly louder in Zandronum compared to old ZDoom, but that's about it. The distances are the same however. It might just be some sound engine EQ differences.
In MAP01 of the wad, you can see the different distances at which the sounds fade out.
I couldn't make the extended fade-out work for the player body sounds yet, as using $rolloff doesn't seem to affect them for some reason, therefore I don't consider the example wad complete and suitable for real play yet.

The sound system in ZDoom 1.23b33 didn't work anymore on my laptop after some newer Windows updates, so I confirmed the issue with ZDaemon instead, which still works.

Quote from JKist3
What happens when hexen is played with Zandronum? does it use the hexen sound curve then?


Yes, it does. The basic sounds seem to fade out at 1900 map units after testing.
Knowing this, wouldn't this allow us to easily fix this by renaming compat_originalsoundcurve to compat_oldzdoomsoundcurve, and simply extend the sound fade-out distance to 1900 map units from the default of 1200? S_CLIPPING_DIST+700? It should be good enough for Doom PvP purposes. The compatflag is completely useless right now anyway since the original Doom sound curve is in use again. It would be much better to fix this and finally make everybody happy.
User avatar (0023781)
unknownna (updater)
2024-07-05 19:58
edited on: 2024-07-08 13:44

Ok, I was finally able to make the rolloff work on player body sounds thanks to Kate's explanation on the ZDoom forums here:
'https://forum.zdoom.org/viewtopic.php?p=537177 [^]'

After testing this some more, the main difference between the older ZDoom behavior and the newer one is that the sound clipping behavior for projectiles changed in later versions. In modern ZDoom, sounds travel alongside projectiles a lot more intensely than in older ZDoom.
In old ZDoom in comparison, the clipping distances of projectiles are only at their longest the closer you are to them.

I also fixed the plasmarifle sounds to make them match the older version where the sounds cut each other off properly and aren't as loud.
So the wad is now fully suitable as a replacement for the broken compatflag to emulate ZDoom 1.23b33 until it's fixed. Enjoy. Better late than never.

Edit:
I fine-tuned the plasma sounds to almost exactly match the older behavior. I found out the explosion sound was too loud compared to old ZDoom, and made both sounds even more quiet after comparing both closely side by side. It's hard to emulate it 100% due to the modern sound engine having more bass EQ and lots of feedback distortion on multiple overlapping sounds. And the sounds are also pitched lower. But it should be a lot more comfortable now.


Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: unknownna
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2014-06-04 04:40 JKist3 New Issue
2014-06-04 07:33 Dusk Note Added: 0008843
2014-06-07 18:41 Watermelon Note Added: 0008877
2014-06-08 01:55 JKist3 Note Added: 0008900
2014-06-08 20:08 Dusk Note Added: 0008935
2014-06-08 20:08 Dusk Status new => closed
2014-06-08 20:08 Dusk Resolution open => not fixable
2014-06-08 20:23 Watermelon Note Added: 0008936
2014-06-08 20:23 Watermelon Note Edited: 0008936 View Revisions
2024-06-28 05:35 unknownna Note Added: 0023770
2024-06-28 05:35 unknownna Status closed => feedback
2024-06-28 05:35 unknownna Resolution not fixable => reopened
2024-06-28 05:36 unknownna File Added: orig_sndcurve_01.wad
2024-07-05 19:57 unknownna File Added: oldzdoom_soundcurve.wad
2024-07-05 19:58 unknownna Note Added: 0023781
2024-07-08 13:42 unknownna File Added: oldzdoom_soundcurve_plasmafix.wad
2024-07-08 13:44 unknownna Note Edited: 0023781 View Revisions






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2024 MantisBT Team
Powered by Mantis Bugtracker