Zandronum Chat on our Discord Server Get the latest version: 3.1
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001737Doomseeker[All Projects] Suggestionpublic2014-03-09 15:412018-09-29 14:46
ReporterAbsolute Zero 
Assigned ToBlzut3 
PrioritylowSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.12 BetaFixed in Version0.12 Beta 
Summary0001737: Players should join games using ZDS links
DescriptionPlayers should join games by clicking a ZDS link in Doomseeker IRC. The current standard format is the following (for zandronum):

'zds://<IP>:<port>/za [^]'

Once the user clicks on it, a dialog showing the server name, IWAD and PWADs used (maybe more info if you wish, like the source-port, depending on how you will implement this) should appear for the user, along with a "join" and "close" buttons.

A different "protocol"/method may be considered if you want to, the whole idea consists on the user clicking on a link and joining the server.
Additional InformationAccording to bond, IDE only supports the URI scheme within the integrated IRC client. It has also been updated to use /za as an alias of /st.

Odamex is'zds://.../od. [^]'
Attached Files

- Relationships

-  Notes
User avatar (0008368)
Blzut3 (administrator)
2014-03-09 16:49

For what it's worth: Doomseeker already supports URIs in the format of'sourceport://ip:port. [^]' The Zandronum installer doesn't register it and we don't do anything in Doomseeker to try to register it, but you just need to pass the URI to Doomseeker's --connect argument.
User avatar (0008387)
Blzut3 (administrator)
2014-03-12 13:01

Got more complete information about the URI scheme from bond. It looks like I can implement compatibility without any trouble.
User avatar (0008409)
Blzut3 (administrator)
2014-03-15 21:59

'https://bitbucket.org/Blzut3/doomseeker/commits/cbba291a3241407f094415aa662f002db1f7bf9a [^]'
User avatar (0008443)
Zalewa (developer)
2014-03-22 15:46

Update available on beta update channel. Please test.
User avatar (0008447)
Absolute Zero (reporter)
2014-03-23 03:13

Working as intended, tested in configured and yet-to-be-configured ports. Thank you!

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: ZzZombo
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2014-03-09 15:41 Absolute Zero New Issue
2014-03-09 16:49 Blzut3 Note Added: 0008368
2014-03-12 12:10 Blzut3 Description Updated View Revisions
2014-03-12 12:10 Blzut3 Additional Information Updated View Revisions
2014-03-12 13:01 Blzut3 Note Added: 0008387
2014-03-12 13:01 Blzut3 Additional Information Updated View Revisions
2014-03-12 13:02 Blzut3 Assigned To => Blzut3
2014-03-12 13:02 Blzut3 Status new => assigned
2014-03-15 21:59 Blzut3 Note Added: 0008409
2014-03-15 21:59 Blzut3 Status assigned => needs review
2014-03-22 15:46 Zalewa Note Added: 0008443
2014-03-22 15:46 Zalewa Status needs review => needs testing
2014-03-22 15:46 Zalewa Target Version => 0.12 Beta
2014-03-23 03:13 Absolute Zero Note Added: 0008447
2014-04-01 19:32 Blzut3 Status needs testing => resolved
2014-04-01 19:32 Blzut3 Fixed in Version => 0.12 Beta
2014-04-01 19:32 Blzut3 Resolution open => fixed
2018-09-29 14:46 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2024 MantisBT Team
Powered by Mantis Bugtracker