Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001512Doomseeker[All Projects] Suggestionpublic2013-09-18 14:542018-09-29 14:42
ReporterZalewa 
Assigned ToZalewa 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.10 Beta 
Target VersionFixed in Version1.0 
Summary0001512: Support "Wad Archive" in Wadseeker
DescriptionAdd support for this site:
http://www.wad-archive.com/ [^]

The current "%WADNAME% in URL" trick doesn't work as Wadseeker treats the generated URL as a direct link to the file and stores a HTML page instead of the proper WAD.
Attached Files

- Relationships

-  Notes
User avatar (0007441)
underscore (reporter)
2013-10-20 09:57

Nice to see my site being noticed. I do have an API to get WADs which might be a better way to add it to Wadseeker

http://www.wad-archive.com/doc/api [^]
User avatar (0011025)
DevilHunter (reporter)
2014-12-02 03:03

Wasn't there a ticket that was showing some sort of JSON Support for wad-archive?? for some reason, I cannot find it now. But yea, would be nice to have it work on Doomseeker
User avatar (0011062)
Zalewa (developer)
2014-12-15 17:39

Excerpts from e-mails I've exchanged with WAD-archive's webmaster:

Quote

I have set uphttp://www.wad-archive.com/wadseeker/<filename>. [^] I have made it so that it only searches the filenames in the database. If <filename> ends in pk3 or wad then it will search for both 'filename.wad' and 'filename.zip'. If the <filename> ends in .zip then the extensions zip, wad and pk3 will be searched for. The searches are case insensitive.

http://www.wad-archive.com/wadseeker/dwango5.wad [^]
http://www.wad-archive.com/wadseeker/dwango5.zip [^]
http://www.wad-archive.com/wadseeker/DWANGO5.WAD [^]
http://www.wad-archive.com/wadseeker/doom1.wad [^]

Optionally it can be filtered to an IWAD or source port using the URL parameters 'port' and 'iwad'. The valid values for 'port' are (more may be added in the future):

DOOM
DOOM2
ZDOOM
HERETIC
HEXEN
BOOM
GZDOOM
STRIFE
LEGACY
ETERNITY
BETA
DOOMSDAY
UNKNOWN
EDGE
MAC
SKULLTAG
ZANDRONUM

(SKULLTAG and ZANDRONUM are treated as the same value. However the API will only return the value SKULLTAG for both)

For 'iwad' the valid values are:

DOOM
DOOM2
HERETIC
HEXEN
STRIFE
BETA
UNKNOWN
TNT
PLUTONIA

If 'port' or 'iwad' is used then it will filter to that value and 'UNKNOWN' because the database isn't 100% complete for these values. I can remove this part if you wish.

http://www.wad-archive.com/wadseeker/dwango5.wad?port=DOOM2 [^]
http://www.wad-archive.com/wadseeker/dwango5.wad?iwad=DOOM2 [^]

The values for type are 'PWAD', 'IWAD', 'UNKNOWN' or 'PK3', however most pk3 files have 'UNKNOWN' as their type . Any commercial IWAD has been filtered and won't be returned.

Bad URLs can be reported withhttp://www.wad-archive.com/wadseeker/missing/<base64 [^] encoded URL>

http://www.wad-archive.com/wadseeker/missing/aHR0cDovL3d3dy5nb29nbGUuY29t [^]


Quote

I do have one request if you do go ahead with including the API in wadseeker, is that if wadseeker grabs a download link that 404s (or fails in general) that it could report that back? This way it can help clean up the dead links in the archive.
User avatar (0011066)
Blzut3 (administrator)
2014-12-16 02:21

Quote
I do have one request if you do go ahead with including the API in wadseeker, is that if wadseeker grabs a download link that 404s (or fails in general) that it could report that back? This way it can help clean up the dead links in the archive.

This is an odd request. Set up a server side script 404 handler that does whatever you want to report. If you just want to report when Wadseeker hits the 404 page you can look at the user agent which should be "Wadseeker/<version>" before doing the reporting.
User avatar (0011070)
underscore (reporter)
2014-12-17 02:49
edited on: 2014-12-17 02:49

The reporting isn't for a 404 for a page hosted on wad-archive.com, but for a download link (wad-archive doesn't host any of the wads).

eg
if one of the links provided byhttp://www.wad-archive.com/wadseeker/dwango5.wad [^] gives a 404, then report that link such ashttp://85.214.205.224/wads/dwango5.zip [^] (download link does work at this point in time)

User avatar (0011475)
Zalewa (developer)
2015-01-21 16:22
edited on: 2015-01-21 16:24

Build with Wad Archive support can now be downloaded from "Beta" update channel.

Wad Archive is enabled by default, but can be disabled from configuration box. Wadseeker will query Wad Archive simultaneously to Idgames and normal sites. At the moment, it will use the first result returned by the API and extract all links from that result, passing them over to the WAD retriever. If retriever detects an URL that errors somehow, this URL will get reported back to Wad Archive as requested.

While testing this I have noticed that if you try to download dwango5 from this URL:http://doom.com.hr/public/doom2/maps/dwango5.zip [^] , it will forward you to a 404 page but respond with 302 and 200 HTTP codes respectively.

Relevant commits:
-https://bitbucket.org/Blzut3/doomseeker/commits/d2e0705c9569cb82572a8bea80a415444723cf0d [^]
-https://bitbucket.org/Blzut3/doomseeker/commits/16fec4d5ff8caa61d9688dd1abe2af1f2572c868 [^]
-https://bitbucket.org/Blzut3/doomseeker/commits/744039943ffcbf3eb3ceb90b74cec16efeb14bab [^]


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: DevilHunter Absolute Zero ZzZombo
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2013-09-18 14:54 Zalewa New Issue
2013-10-20 09:57 underscore Note Added: 0007441
2014-12-02 03:03 DevilHunter Note Added: 0011025
2014-12-15 17:39 Zalewa Note Added: 0011062
2014-12-16 02:21 Blzut3 Note Added: 0011066
2014-12-17 02:49 underscore Note Added: 0011070
2014-12-17 02:49 underscore Note Edited: 0011070 View Revisions
2014-12-17 19:37 Zalewa Assigned To => Zalewa
2014-12-17 19:37 Zalewa Status new => assigned
2015-01-21 16:22 Zalewa Note Added: 0011475
2015-01-21 16:22 Zalewa Status assigned => needs testing
2015-01-21 16:24 Zalewa Note Edited: 0011475 View Revisions
2015-03-22 20:07 Zalewa Status needs testing => resolved
2015-03-22 20:07 Zalewa Fixed in Version => 1.0
2015-03-22 20:07 Zalewa Resolution open => fixed
2018-09-29 14:42 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker