Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001175Zandronum[All Projects] Bugpublic2012-11-07 19:052018-08-10 17:40
Reporterdeathisnear 
Assigned ToTorr Samaho 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version1.0 
Target VersionFixed in Version 
Summary0001175: Attack (both mouse 1 and 2) getting "stuck" on newer mice.
DescriptionThere is a problem with newer mice in where the fire and alt-fire get stuck when moving the mouse around a lot then firing. This is reported on a thread here with a video on it,http://zandronum.com/forum/showthread.php?tid=311, [^] but does not seem to be on the tracker. I am currently using a Logitech g700 Gaming mouse, someone on the thread is using a Sentinel Advance Twin Laser Gaming Mouse. This ONLY seems to happen when playing online
Steps To ReproduceYou MUST have a newer gaming mouse for this to happen it seems.
1. Connect to server.
2. Move the mouse around a lot then fire, like trying a moving rocket jump where you jerk the mouse down really fast.
3. It SHOULD be stuck now if you are using a mouse that suffers from this problem.
Attached Files

- Relationships
has duplicate 0001750closed Using new mice with extra buttons in Zandronum causes them to get "stuck" sometimes. 
related to 0001527closed Possible raise MAXEVENTS 

-  Notes
User avatar (0005329)
deathisnear (reporter)
2012-11-07 19:13
edited on: 2012-11-07 19:17

Changing the polling rate does not help the issue with my mouse, unfortunately. This problem makes the game quite frustrating at times, but is still a minor problem since very few people have mice that suffer from it.

User avatar (0005333)
Torr Samaho (administrator)
2012-11-08 06:24

IIRC this also happens in ZDoom, doesn't it?
User avatar (0005335)
deathisnear (reporter)
2012-11-08 14:43

Not sure how to test it since it still doesn't work offline. Not sure how to make a multiplayer match on Zdoom and join it.
User avatar (0005336)
Watermelon (developer)
2012-11-08 15:06

Basically tell is how it works:

1) On Zandronum online
2) On Zandronum offline
3) On G/ZDoom offline
User avatar (0005337)
Edward-san (developer)
2012-11-08 15:34

Quote
Not sure how to test it since it still doesn't work offline. Not sure how to make a multiplayer match on Zdoom and join it.


In a command line window, cd to your zdoom folder, then execute:

zdoom.exe -iwad doom2.wad -host 1 -warp 01 -skill 4

this will create a new game which emulates a new multiplayer game with just one player in doom2.wad map01 with skill Ultra Violence.
User avatar (0005338)
one_Two (reporter)
2012-11-08 16:22

I had a similar problem where mouse 1 and 2 seem to jam. The solution on the most part seems to be to use a polling rate of 500hz or less, but a lot of newer mouses don't work well with less than 1000hz. My mouse was a Roccat Kova+.
User avatar (0005339)
deathisnear (reporter)
2012-11-08 19:13

1) Happens on Zandronum Online
2) Does NOT happen offline
3) Does NOT happen in G/Zdoom online/offline
User avatar (0005348)
Torr Samaho (administrator)
2012-11-11 08:31

Quote from deathisnear

Not sure how to test it since it still doesn't work offline.

Quote from deathisnear

2) Does NOT happen offline
3) Does NOT happen in G/Zdoom online/offline

These two statements contradict. Do you mean "it works properly offline." with "it still doesn't work offline."?
User avatar (0005362)
deathisnear (reporter)
2012-11-11 16:32
edited on: 2012-11-11 18:59

I was doing what Watermelon said, just to make sure it doesn't work offline/online in other ports.

User avatar (0006365)
Mynameislol (reporter)
2013-06-06 20:17
edited on: 2013-06-06 20:18

This bug is REALLY annoying, i'm playing with a friend and almost every time i play, i blow myself up with a rocket launcher and the map restarts because i died!

I'm trying to play a geniune co-op game, and if someone dies, the map restarts.
It's not fun having infinite respawn, then we would have completed all doom games by now!

Not everyone has an old gaming rig, and not everyone owns 5$ worth of computer gear, i'd like more support for more recent computer gear.

Forgot to add, the mouse feels a bit unresponsive compared to Gzdoom, i have a polling rate of 1000, and it feels like a polling rate of 125.

It would be nice to have direct-input.

User avatar (0006432)
Adelsrattan (reporter)
2013-06-13 20:00

Although i do not suffer from the same problem as Mynameisalol(as i fire/altfire with ctrl and rightshift), i CAN rellate to this sole bug due to the fact that i use the mouse to dodge.

the bug you are discussing never does relate to any keybindings, but SOLELY to the left/right mouse buttons.

one solution would be to bind a key to the mouse buttons, but this is not possible in my friend/gamerbud Mynameislols case as his mouse-software does not
support windows 8 due to some mices non-support in software, which is because microsoft are SILLY BASTARDS who won't allow your mouse to work with win 8
if they are not signed by them.
first this, then the xbox one.

Get your shit together, Microsoft.
User avatar (0006433)
Torr Samaho (administrator)
2013-06-15 11:33

Going through the information collected so far it sounds to me as if there are two separate problems:

1. Buttons get stuck. This only happens in Zandronum online. It doesn't happen in Zandronum offline or in GZDoom (no matter if online or offline).

2. Mouse input in Zandronum feels less responsive than GZDoom.

Can somebody confirm this? Furthermore, does the reduced responsiveness in Zandronum compared to GZDoom happen only online or also offline?
User avatar (0006434)
Mynameislol (reporter)
2013-06-15 15:06

The reduced responsiveness happens in both offline and online in Zandronum, and there is no reduced responsiveness in GZDoom, not in offline nor online. I have also tested this in ZDoom 2.7.0, and it works just as great as GZDoom.
User avatar (0006435)
Torr Samaho (administrator)
2013-06-15 16:39

Can you check whether GZDoom 323 is as unresponsive as Zandronum?
User avatar (0006436)
Mynameislol (reporter)
2013-06-15 18:05

Nope, GZDoom 323 works great.
User avatar (0006437)
Torr Samaho (administrator)
2013-06-15 18:17
edited on: 2013-06-15 18:26

That's strange. GZDoom 323 and Zandronum have the same mouse code and thus should behave similarly.

EDIT: Did you possibly set some special options in your mouse driver when zandronum.exe and/or gzdoom.exe is used?

And is there anybody else for whom GZDoom 323 works better than Zandronum?

User avatar (0006438)
Mynameislol (reporter)
2013-06-15 20:25

No, i did not set any special options for my mouse driver when zandronum or gzdoom is ued.
User avatar (0006439)
deathisnear (reporter)
2013-06-15 20:47

I've noticed so far that the problem with the firing getting stuck never seems to happen anymore in Zandro online. I still get a problem with the fire responsiveness being a little laggy at time, especially when turning the mouse at a high rate of speed. My polling rate for my mouse is 125 btw. I don't get the issue in GZDoom at all. It may have something to due with the network side and not the actual mouse coding, but that is just my guess.
User avatar (0006445)
Torr Samaho (administrator)
2013-06-16 08:37

Quote from Mynameislol
No, i did not set any special options for my mouse driver when zandronum or gzdoom is ued.

Can you test this again with clean ini files for both, GZDoom and Zandronum, and also rename zandronum.exe and gzdoom.exe to something else like test.exe? The latter makes it less likely that your mouse driver silently treats the two ports differently.

Quote from deathisnear
I still get a problem with the fire responsiveness being a little laggy at time, especially when turning the mouse at a high rate of speed.

Do you have this fire responsiveness problem only online? Then it could be a network latency issue.
User avatar (0006455)
Mynameislol (reporter)
2013-06-16 18:45

I don't think it's a network latency issue, as i'm running the server locally, and the mouse feels unresponsive in both Zandronum Online and Offline.

I also did what you tell me to do, and there's no difference.
User avatar (0006456)
Torr Samaho (administrator)
2013-06-16 19:47

Quote from Mynameislol
I don't think it's a network latency issue, as i'm running the server locally, and the mouse feels unresponsive in both Zandronum Online and Offline.
I was only referring to the fire responsiveness problem deathisnear mentioned.
User avatar (0006457)
deathisnear (reporter)
2013-06-16 20:10

I only have the issue online in Zandro. It could be a latency issue but it still happens on server like Best-ever where I have 30 ping. It happens very rarely but I can still tell it happens.
User avatar (0006458)
lollipop (reporter)
2013-06-17 09:16

I wish to add that some new mice do not have this odd problem, I have a roccat kone+ and it did not behave differently when I used it, though I got rid of it for some obvious mouse scroll reasons...
User avatar (0006459)
Mynameislol (reporter)
2013-06-17 15:21

Are you sure you configured the mouse settings to 1000hz polling rate?
User avatar (0006460)
Konar6 (reporter)
2013-06-17 20:07

A side note - Windows 7 apparently does not allow changing mouse polling rate (not for mine anyway). You can use this tool to check your actual polling rate ->http://www.softpedia.com/get/System/System-Miscellaneous/Mouse-Rate-Checker.shtml [^]
User avatar (0006537)
Mynameislol (reporter)
2013-07-01 13:56
edited on: 2013-07-01 16:17

Any Progress? Also, i got my mouse drivers working, so i got a temporary solution, i bind the mouse buttons to pgup and pgdn.

User avatar (0006539)
Torr Samaho (administrator)
2013-07-01 17:43

No. I have no idea why GZDoom 323 and Zandronum behave differently. As I said before, they should behave the same. And since I can't reproduce the problem with my mice, I can't debug the problem.
User avatar (0006540)
Mynameislol (reporter)
2013-07-01 18:40

Why not just buy a cheap gaming mouse? A Logitech G500 shouldn't be very costy, or if you perfer the IntelliMouse Explorer ergonomics, a deathadder.
User avatar (0006541)
Torr Samaho (administrator)
2013-07-01 18:44

I'm happy with the performance of my mice, so I don't see any need to replace them. And I'm not paying for a new mouse just to debug this issue.
User avatar (0006542)
Konar6 (reporter)
2013-07-01 19:03

Does typing "vid_vsync 0" into the console change the mouse behavior for you?
User avatar (0006543)
Mynameislol (reporter)
2013-07-01 19:13
edited on: 2013-07-01 19:17

That sucks. I guess this means zandronum is not supported for newer gaming mice then? There must be a developer that has this problem. Also, vid_vsync 0 did not change the mouse behaviour.

User avatar (0006573)
Torr Samaho (administrator)
2013-07-04 20:38

There is a small chance that this has to do with the G15 support. This binary has the G15 stuff removed. Please check if it behaves differently.
User avatar (0006574)
Mynameislol (reporter)
2013-07-04 22:19

YES! Works flawlessly!
User avatar (0006575)
Torr Samaho (administrator)
2013-07-05 05:51

I'm very happy to hear that! I'll disable the G15 code in 1.1 then, but will need your feedback to confirm that your mouse works as expected when I have finalized the code.

If somebody actually needs G15 support, we can still provide a separate binary with G15 code.
User avatar (0006577)
Mynameislol (reporter)
2013-07-05 10:00

Okay, sure! Just a FYI, i've already finished all doom games, including the master levels, so i was wondering if you could recommend me a good faithful map-pack?
User avatar (0006591)
Mynameislol (reporter)
2013-07-07 16:57

Update, I've been playing a bit of multiplayer on another computer with another mouse, and the problem is still there. However, it happens less frequently, and the mouse lag is completely gone, but the mouse buttons still get stuck sometimes.
User avatar (0006597)
Mynameislol (reporter)
2013-07-08 13:45
edited on: 2013-07-08 13:45

Another update, it seems that the mouse lag is still there, just less of it, GZDoom is still superior here. However, the mouse lag is less than it was before on zandronum. Also, the mouse lag gets worse on software mode, so it's possible that it might be a combination of things that interfere with the mouse settings?

User avatar (0006599)
Torr Samaho (administrator)
2013-07-08 19:52

Sounds like this is much harder to test than expected. Are you actually 100% sure that GZDoom 323 and the latest GZDoom version behave the same?
User avatar (0006602)
Watermelon (developer)
2013-07-08 21:56

Do your buttons still get stuck? If so I have some things you can do.
User avatar (0006603)
Mynameislol (reporter)
2013-07-08 23:16

I've gone through this extra carefully this time, and it seems that the newest GZDoom is better than version 323.
User avatar (0006605)
Dusk (developer)
2013-07-09 00:36

Is GZDoom 323 still better than Zandronum without the G15 code though?
User avatar (0006606)
Mynameislol (reporter)
2013-07-09 08:10
edited on: 2013-07-15 19:18

Yes, GZDoom 323 is still better than Zandronum without the G15 code. However, without it, i feel it's more responsive than before, as the mouse doesn't glitch as much on multiplayer. Another update, it seems that with the test zandronum i got, this bug now also happens in single player as well.

User avatar (0006655)
Torr Samaho (administrator)
2013-07-15 19:21

This builds disables the G15 code in the way planned to be used with the final version of 1.1. Please check if it works as good as the other build I posted before.

Regarding the discrepancies to GZDoom 323: The testing results sound highly subjective and the differences only seem to be minor since it took you extra effort to notice that Zandronum without the G15 code is actually different from GZDoom. Is it possible that Zandronum is just a little slower than GZDoom and thus the mouse input feels responsive? The latest GZDoom version on the other hand is more optimized than GZDoom 323 and thus should be a bit faster which could explain why it feels more responsive to you.
User avatar (0006662)
Mynameislol (reporter)
2013-07-15 22:08

Well, i do have this problem with Zandronum, i can't run Zandronum in 66hz, but in the newest GZDoom, i can. The mouse feels alot more responsive in 66hz, so i'm uncertain if there is a difference between GZDoom 323 and the latest version, but i know for certain that there is a difference between GZDoom 323 and Zandronum, because GZDoom 323 can't run in 66hz either. Zandronum has been a bit strange lately, resetting the settings now and then, brightness resets too, it might just be so that Zandronum is very unstable? That might be the issue with the mouse settings and such.
User avatar (0006788)
Watermelon (developer)
2013-07-24 21:44

A few of my friends with newer gaming mice are complaining about this issue as well in 1.1.1, so I think the issue has not been solved.


Is this caused by newer drivers? Is there any way to create a debuggable exe that prints out if the button is down, while maybe some external program records mouse output?
User avatar (0006792)
Torr Samaho (administrator)
2013-07-25 18:28

Water, are you referring to the "buttons get stuck" problem?

A first step to analyze this issue could be with client side demos. The demo should contain the buttons presses as they are registered by the client. This way we could check if the client actually thinks the player is still pressing the button or if it's a problem on the server.
User avatar (0006823)
Tiger (reporter)
2013-07-28 00:29
edited on: 2013-07-28 00:33

I've also been having this issue with Zandronum since the first stable release. However, I don't fully remember having this issue on SkullTag. I could take some time to test with the ancient SkullTag builds, would this help at all?

My mouse: Logitech G500; using official drivers from Logitech.

User avatar (0006825)
Torr Samaho (administrator)
2013-07-28 07:44

Knowing whether the problem already happened in Skulltag would certainly be helpful.

BTW: Can somebody record a client side demo of the problem with 1.1.1 as I suggested above?
User avatar (0006826)
Watermelon (developer)
2013-07-28 15:55
edited on: 2013-07-28 15:55

Ok so the following will be happening

I am working with Reck on the mouse issue, this is what we will be doing:

[X] Play on 1.1.1
[X] Play on 1.0
[ ] Play on ZDoom r24... w/e revision we forked off of
[ ] Play on GZDoom 323(?)
[ ] Play on Skulltag 98d
[ ] Play on Zdoom latest
[ ] Play on GZdoom latest

Notes so far:
- 1.1.1 has it way worse somehow, buttons get stuck for him more frequently
- 1.0 is better, but buttons only fail to be sent every 10 seconds or so (might not be a constant wave but approximate failure rate); note there is NO sticking in 1.0 for him
- One of my friends on ZD said he had this problem on both ports and turned down the polling rate, but this drastically damages the mouse playing ability if it's cranked all the way down

User avatar (0006827)
deathisnear (reporter)
2013-07-28 18:43

I still have the issue of the firing not working in 1.1.1 when doing a quick motion, usually spinning at a high rate of speed. It may be due to too much mouse input signals causing it not to work. Then again that is my guess. It really hurts when you have to do a quick turn to get that archvile or cyberdemon behind you and the firing refuses to work until you click the mouse button again. The issue of the firing getting stuck seems to be gone as I have not had it for a long time now.
User avatar (0006828)
Tiger (reporter)
2013-07-28 20:18
edited on: 2013-07-28 20:44

The testing did not go as well as I was hoping for...

96f:
    Could not successfully test
        Could not create a stable gameserver; consistently unresponsive
97b:
    Could not successfully test
        Could not create a stable gameserver; consistently unresponsive
97c3:
    Could not successfully test
        Could not create a stable gameserver; consistently unresponsive
97d5:
    Successful test
        The reported mouse issues is also reproducible on this version.


In addition, here's a CLD - but I don't know if this is really helpful. There are times to where I press the mouse keys (for me: attack and jump) - but nothing happens.
Required PWADS: skulltag_actors_1-1-1pk3; skulltag_data_126pk3; d2dm1_126fix.pk3
Requested Demo

*I miss DRDTeam Fileshare :(

User avatar (0006829)
Watermelon (developer)
2013-07-29 03:03

Further tests indicate it is fine for Zdoom 2.x series, but broken on 1.23 and earlier series.

Apparently changing the polling rate from 1000 Hz down to 125 Hz makes the problem go away.


So how is the input handled anyways? Wondering if it's a buffer overflow?

Will find out how 250 and 500 Hz do tomorrow from my friend.
User avatar (0006830)
Torr Samaho (administrator)
2013-07-29 07:00

Zandronum should behave like ZDoom 2.0.x, so possibly non-code related differences play a role here too. We should definitely check if the VC++ version, the Windows SDK and the DirectX SDK version used make any difference.
User avatar (0006832)
Watermelon (developer)
2013-07-29 15:09

500 Hz = working perfectly for him (no more sticking/locking up/anything)
1000 Hz = broken


So I guess the polling rate is responsible. I wish there was a 750 mouse to see if it's a notorious buffer like 512 or something similar.
User avatar (0006834)
Torr Samaho (administrator)
2013-07-29 19:35

This binary is built with VC++ 2010. Please check if it behaves differently from the VC++ 2005 binaries.
User avatar (0006837)
Tiger (reporter)
2013-07-29 21:01
edited on: 2013-07-29 21:04

Torr Samaho, I am still able to reproduce the issue on that build. The behaviour seems to be exactly the same as from the VC++ 2005 builds.

Watermelon, I've noticed that on 500Hz it is much better, but yet I can still reproduce the 'sticky' buttons just only rarely.

Demo File
Required Files: VC++2010 build (Torr's post above this one), and greenwar.wad
I've used the polling rate of 500Hz in that demo, but test 1000Hz (my default setting) somewhere in MAP02.

User avatar (0006838)
Torr Samaho (administrator)
2013-07-29 21:13

Thanks for checking! Can you tell me where (preferably with the corresponding demo_skiptics parameter) in the demo I can see which kind of problems?
User avatar (0006839)
Tiger (reporter)
2013-07-29 21:16

Sure, I'll get back to this tomorrow.
User avatar (0006850)
Tiger (reporter)
2013-07-30 18:36

Using only the 'Skip_DemoTics' CCMD, the value is 0001541:0011830 tics. Thus,
Skip_DemoTics 11830
is where I toggled 500Hz to 1000Hz setting. After a short pause (you'll notice it on the demo), I've then reverted back to 500Hz. Hopefully this helps?
User avatar (0006852)
Torr Samaho (administrator)
2013-07-30 18:44

I noticed the pause, but I still don't know what I should look for.

Please elaborate what is supposed to happen in this demo when the mouse would be working properly and what happens instead.
User avatar (0006853)
Tiger (reporter)
2013-07-30 19:07
edited on: 2013-07-30 19:07

The most notable and how I can easily reproduce the main issue; when I spin the view point ridiculously, I am also trying to either +jump (mouse button 2) or +attack (mouse button 1) during the process. If I remember correctly, I could not be able to get Button1 (+attack) to work but I was able to get Button2 (+jump) - which stuck. A simplified version, you will notice that after spinning the view point around, I then begin to +jump several times when I only meant to +jump once. Hopefully this makes sense?

A much more better demonstration would probably be this video.

User avatar (0006858)
deathisnear (reporter)
2013-07-31 00:19
edited on: 2013-07-31 00:20

I could have sworn I linked that video before. But ya, that is basically the issue. I no longer get the stuck firing but I do get the first part where he moves the mouse fast and it doesn't fire.

EDIT: Ah yes, it was in the original post @http://zandronum.com/forum/showthread.php?tid=311&pid=3756#pid3756 [^]

User avatar (0006926)
Watermelon (developer)
2013-08-07 18:35

This may be related:

Input detection appears to respond slower in uncapped. There is a noticeable delay (maybe 150-250 milliseconds) before the mouse movement is actually processed.
User avatar (0006927)
Torr Samaho (administrator)
2013-08-07 18:43

I don't notice any difference in delay between capped and uncapped input on my machine, so this may depend on the mouse.
User avatar (0006928)
Konar6 (reporter)
2013-08-07 18:50

Watermelon: "vid_vsync 0" fixes that for me.
User avatar (0006930)
Watermelon (developer)
2013-08-07 18:59

Awesome TY Konar, worked perfectly.


I just tested on odamex and it appears to do the same thing. Is this enabled by default? Or maybe some residual thing left on in my console. I noticed a few other people in the community have it on and probably have never turned vsync on manually.
User avatar (0006932)
Edward-san (developer)
2013-08-07 21:08

Does this happen in (g)zdoom with the 'vsync' discovery? Does this happen also with other OSes like in linux or macos?
User avatar (0006993)
Mynameislol (reporter)
2013-08-11 09:29

vid_vsync 0 does nothing for me.
User avatar (0007101)
haxmurderer (reporter)
2013-09-03 21:23

I can confirm this is still an issue with Zandronum 1.2 on Windows 8. I use a Logitech G500, and this has been a problem with every Zandronum release so far.
User avatar (0007202)
Watermelon (developer)
2013-09-17 19:05

Appears to be fixed in the latest revision from backporting gzdoom features. Needs testing.
User avatar (0007206)
Tiger (reporter)
2013-09-17 20:57

If someone is willing to build: Linux [32bit](server-host) and Windows [default], I'll be willing to test the proposed build(s).
User avatar (0007310)
StrikerMan780 (reporter)
2013-10-01 16:19

I get issues with my Razer Naga Hex mouse, if I set my polling rate to 1000hz or higher. If the polling rate is 400hz or less, it's fine.
User avatar (0007562)
fuleco (reporter)
2013-11-16 13:32

My tracker was closed (http://zandronum.com/tracker/view.php?id=1527). But all my mouse problems was solved when i enabled cap framrate. *cool*. So for everyone polling rate 500 Hz and enabled cap framrate make mouse similar to odamex or zd. *cool*
User avatar (0008293)
Mynameislol (reporter)
2014-02-28 16:43

Needs testing? What's there to test? Could i get some clear instructions of what i need to test? I've tried Vsyncing, i've fried capping framerate, i've tried uncapping framerate, none of these work.
User avatar (0008294)
Qent (updater)
2014-02-28 18:01

For tickets marked "Needs Testing," please test if the latest beta build fromhttp://zandronum.com/download#betas [^] solves the issue.
User avatar (0008295)
Mynameislol (reporter)
2014-02-28 18:41

I can't test on multiplayer

Connect (v2.0-alpha): 127.0.0.1:10667
Incorrect version.
User avatar (0008298)
Konar6 (reporter)
2014-03-01 08:40

You must use the beta executable when hosting the server, too. If you are hosting in IDE, select the right executable in Options -> Directories -> Programs. Or use the command line (zandronum.exe -host). You can also find a beta testing server online.
User avatar (0008299)
Mynameislol (reporter)
2014-03-01 13:10

I believe i can confirm this is fixed! A bit of input lag with vsync on, though.
User avatar (0019316)
unknownna (updater)
2018-08-10 14:43

I've recently aquired a Logitech G102 Prodigy mouse, and noticed this issue myself and decided to do some testing.

I found out that the issue is present in all ZDoom versions prior to 2.4.0, meaning that 2.3.1 was the last public version where the same issue was present.

When decreasing the polling rate from 1000hz to 500hz, the issue seemingly goes away.

It's still present in the latest 3.1 alpha build (3.1-alpha-180520-0650).

To be honest, it's really bad, as it can potentially happen all the time when moving your mouse swiftly (SSG swingshots etc.). I'm able to reproduce it very constistently by simply moving the mouse very swiftly while pressing one of the mouse buttons.
User avatar (0019317)
Edward-san (developer)
2018-08-10 15:49

Can you reproduce this with GZDoom 3.5 (both modern and vintage builds)? If yes, then please make a bug report in the zdoom forum.
User avatar (0019318)
unknownna (updater)
2018-08-10 16:41

Hi, Edward-san. Good to see you.

No, I can't reproduce it in newer GZDoom versions. It was fixed already in ZDoom 2.4.0, however, Zandronum seems to be using 2.3.1's mouse behavior where it's bugged.

ZDoom 2.3.1 and earlier = Broken, buttons get stuck with 1000hz polling rate.
ZDoom 2.4.0 and later = Fixed, buttons no longer get stuck with 1000hz polling rate.
User avatar (0019319)
Edward-san (developer)
2018-08-10 17:13

Hi unknownna, sorry for not saying hi before. ':D

This requires some testing on the changes between 2.3.1 and 2.4. I don't know if there are still the svn builds at drdteam, because otherwise we may need to proceed bisecting and rebuilding them, but since the build system has been modernized in the last years, it requires someone who still uses the old system for doing this.
User avatar (0019320)
Edward-san (developer)
2018-08-10 17:32

By the way, can you confirm these comments:

0001175:0006436 (gzdoom r323)

0001175:0006574 (zandronum w/o g15 support)

?
User avatar (0019321)
unknownna (updater)
2018-08-10 17:40

Both builds are broken.

ZDoom 2.3.1 (19 March 2009)
ZDoom 2.4.0 (31 December 2009)

https://github.com/coelckers/gzdoom/search?o=desc&p=6&q=mouse&s=committer-date&type=Commits [^]

There are several mouse-related commits between the releases. I'd assume that those are the ones responsible for fixing the issue here.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: Mynameislol Adelsrattan lollipop Tiger WaTaKiD unknownna mifu
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2012-11-07 19:05 deathisnear New Issue
2012-11-07 19:13 deathisnear Note Added: 0005329
2012-11-07 19:17 deathisnear Note Edited: 0005329 View Revisions
2012-11-07 19:17 deathisnear Note Edited: 0005329 View Revisions
2012-11-08 06:24 Torr Samaho Note Added: 0005333
2012-11-08 14:43 deathisnear Note Added: 0005335
2012-11-08 15:06 Watermelon Note Added: 0005336
2012-11-08 15:34 Edward-san Note Added: 0005337
2012-11-08 16:22 one_Two Note Added: 0005338
2012-11-08 19:13 deathisnear Note Added: 0005339
2012-11-11 08:31 Torr Samaho Note Added: 0005348
2012-11-11 16:32 deathisnear Note Added: 0005362
2012-11-11 18:59 deathisnear Note Edited: 0005362 View Revisions
2013-06-06 20:17 Mynameislol Note Added: 0006365
2013-06-06 20:18 Mynameislol Note Edited: 0006365 View Revisions
2013-06-13 20:00 Adelsrattan Note Added: 0006432
2013-06-15 11:33 Torr Samaho Note Added: 0006433
2013-06-15 15:06 Mynameislol Note Added: 0006434
2013-06-15 16:39 Torr Samaho Note Added: 0006435
2013-06-15 18:05 Mynameislol Note Added: 0006436
2013-06-15 18:17 Torr Samaho Note Added: 0006437
2013-06-15 18:26 Torr Samaho Note Edited: 0006437 View Revisions
2013-06-15 20:25 Mynameislol Note Added: 0006438
2013-06-15 20:47 deathisnear Note Added: 0006439
2013-06-16 08:37 Torr Samaho Note Added: 0006445
2013-06-16 18:45 Mynameislol Note Added: 0006455
2013-06-16 19:47 Torr Samaho Note Added: 0006456
2013-06-16 20:10 deathisnear Note Added: 0006457
2013-06-17 09:16 lollipop Note Added: 0006458
2013-06-17 15:21 Mynameislol Note Added: 0006459
2013-06-17 20:07 Konar6 Note Added: 0006460
2013-07-01 13:56 Mynameislol Note Added: 0006537
2013-07-01 16:17 Mynameislol Note Edited: 0006537 View Revisions
2013-07-01 17:43 Torr Samaho Note Added: 0006539
2013-07-01 18:40 Mynameislol Note Added: 0006540
2013-07-01 18:44 Torr Samaho Note Added: 0006541
2013-07-01 19:03 Konar6 Note Added: 0006542
2013-07-01 19:13 Mynameislol Note Added: 0006543
2013-07-01 19:17 Mynameislol Note Edited: 0006543 View Revisions
2013-07-04 20:38 Torr Samaho Note Added: 0006573
2013-07-04 21:33 Dusk Status new => feedback
2013-07-04 22:19 Mynameislol Note Added: 0006574
2013-07-05 05:51 Torr Samaho Note Added: 0006575
2013-07-05 10:00 Mynameislol Note Added: 0006577
2013-07-07 16:57 Mynameislol Note Added: 0006591
2013-07-08 13:45 Mynameislol Note Added: 0006597
2013-07-08 13:45 Mynameislol Note Edited: 0006597 View Revisions
2013-07-08 19:52 Torr Samaho Note Added: 0006599
2013-07-08 21:56 Watermelon Note Added: 0006602
2013-07-08 23:16 Mynameislol Note Added: 0006603
2013-07-09 00:36 Dusk Note Added: 0006605
2013-07-09 08:10 Mynameislol Note Added: 0006606
2013-07-15 19:18 Mynameislol Note Edited: 0006606 View Revisions
2013-07-15 19:21 Torr Samaho Note Added: 0006655
2013-07-15 22:08 Mynameislol Note Added: 0006662
2013-07-24 21:44 Watermelon Note Added: 0006788
2013-07-25 18:28 Torr Samaho Note Added: 0006792
2013-07-28 00:29 Tiger Note Added: 0006823
2013-07-28 00:31 Tiger Note Edited: 0006823 View Revisions
2013-07-28 00:32 Tiger Note Edited: 0006823 View Revisions
2013-07-28 00:33 Tiger Note Edited: 0006823 View Revisions
2013-07-28 07:44 Torr Samaho Note Added: 0006825
2013-07-28 15:55 Watermelon Note Added: 0006826
2013-07-28 15:55 Watermelon Note Edited: 0006826 View Revisions
2013-07-28 18:43 deathisnear Note Added: 0006827
2013-07-28 18:43 deathisnear Status feedback => new
2013-07-28 20:18 Tiger Note Added: 0006828
2013-07-28 20:44 Tiger Note Edited: 0006828 View Revisions
2013-07-29 03:03 Watermelon Note Added: 0006829
2013-07-29 07:00 Torr Samaho Note Added: 0006830
2013-07-29 15:09 Watermelon Note Added: 0006832
2013-07-29 19:35 Torr Samaho Note Added: 0006834
2013-07-29 21:01 Tiger Note Added: 0006837
2013-07-29 21:04 Tiger Note Edited: 0006837 View Revisions
2013-07-29 21:13 Torr Samaho Note Added: 0006838
2013-07-29 21:16 Tiger Note Added: 0006839
2013-07-30 18:36 Tiger Note Added: 0006850
2013-07-30 18:44 Torr Samaho Note Added: 0006852
2013-07-30 19:07 Tiger Note Added: 0006853
2013-07-30 19:07 Tiger Note Edited: 0006853 View Revisions
2013-07-31 00:19 deathisnear Note Added: 0006858
2013-07-31 00:20 deathisnear Note Edited: 0006858 View Revisions
2013-08-07 18:35 Watermelon Note Added: 0006926
2013-08-07 18:43 Torr Samaho Note Added: 0006927
2013-08-07 18:50 Konar6 Note Added: 0006928
2013-08-07 18:59 Watermelon Note Added: 0006930
2013-08-07 21:08 Edward-san Note Added: 0006932
2013-08-11 09:29 Mynameislol Note Added: 0006993
2013-09-03 21:23 haxmurderer Note Added: 0007101
2013-09-17 19:05 Watermelon Note Added: 0007202
2013-09-17 19:05 Watermelon Status new => needs testing
2013-09-17 20:57 Tiger Note Added: 0007206
2013-09-30 17:36 Dusk Relationship added related to 0001527
2013-10-01 16:19 StrikerMan780 Note Added: 0007310
2013-11-16 13:32 fuleco Note Added: 0007562
2014-02-28 16:43 Mynameislol Note Added: 0008293
2014-02-28 18:01 Qent Note Added: 0008294
2014-02-28 18:41 Mynameislol Note Added: 0008295
2014-03-01 08:40 Konar6 Note Added: 0008298
2014-03-01 13:10 Mynameislol Note Added: 0008299
2014-03-15 01:32 Blzut3 Relationship added has duplicate 0001750
2014-06-03 17:36 Dusk Status needs testing => resolved
2014-06-03 17:36 Dusk Resolution open => fixed
2014-06-03 17:36 Dusk Assigned To => Torr Samaho
2018-08-10 14:43 unknownna Note Added: 0019316
2018-08-10 14:43 unknownna Status resolved => feedback
2018-08-10 14:43 unknownna Resolution fixed => reopened
2018-08-10 15:49 Edward-san Note Added: 0019317
2018-08-10 16:41 unknownna Note Added: 0019318
2018-08-10 17:13 Edward-san Note Added: 0019319
2018-08-10 17:32 Edward-san Note Added: 0019320
2018-08-10 17:40 unknownna Note Added: 0019321






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker