Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001378Zandronum[All Projects] Suggestionpublic2013-06-24 14:552014-06-05 15:33
ReporterBalrog 
Assigned ToTorr Samaho 
PriorityhighSeverityfeatureReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.2 
Target Version1.3Fixed in Version1.3 
Summary0001378: sv_forcerandom: Force the use of a random player class
DescriptionSince there's apparently a demand for it, why not add a CVAR to force the use of a random player class regardless of user settings.
Additional InformationThis is currently only possible by changing the user's settings with ConsoleCommand.
Attached Files

- Relationships
child of 0001070assignedDusk Phasing out the dangerous ConsoleCommand for various additional/improved ACS commands 

-  Notes
User avatar (0008621)
Frits (reporter)
2014-04-20 19:51

I could really use this function for the zandronum version of prophunt.
Some classes like health vials are more op than for example a big tree.

Hypnotoad implemented a hacky way via acs that uses console command but it's crude and causes kicks.
?
Can this be a thing for 2.0/1.3?
User avatar (0008624)
Hypnotoad (reporter)
2014-04-21 12:05

Indeed, such a feature would be extremely useful for us. Prop hunt is much more fun when you're forced into a random class.
User avatar (0008660)
Torr Samaho (administrator)
2014-05-01 15:45
edited on: 2014-05-01 17:21

I had a brief look at this and implemented the cvar with pretty much no testing. Please test if this build works as expected.

EDIT: I noticed that there is a serious problem with this build: sv_forcerandom may not be true while a map is loaded. I'll look into this.

EDIT3: This should work better.

User avatar (0008664)
Frits (reporter)
2014-05-01 20:57

Works fine on my end :)
User avatar (0008669)
ZzZombo (reporter)
2014-05-02 15:27

What about generalizing stuff? Add instead sv_forceclass "<class name>", and "random" for random class unless there is a class defined and named that way?
User avatar (0008670)
Torr Samaho (administrator)
2014-05-02 17:53

I don't see any reasonable use for sv_forceclass "<class name>" (except if the class name is random). If you want every single player on every team to use the very same class, you probably shouldn't be running a mod that offers different classes.
User avatar (0008677)
Torr Samaho (administrator)
2014-05-03 08:47

I added sv_forcerandom to 1.3, but begin to think we should rename it to make its purpose more clear, e.g. sv_forcerandomclass.
User avatar (0008847)
Arco (updater)
2014-06-04 20:20

Works as intended in v1.3 r140413-2324M.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: ZzZombo Esum Leonard Hypnotoad Frits Combinebobnt tyler12112 WaTaKiD
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2013-06-24 14:55 Balrog New Issue
2013-06-24 19:41 Dusk Relationship added related to 0001070
2013-06-24 19:42 Dusk Relationship deleted related to 0001070
2013-06-24 19:42 Dusk Relationship added child of 0001070
2014-04-20 19:51 Frits Note Added: 0008621
2014-04-21 12:05 Hypnotoad Note Added: 0008624
2014-04-27 19:01 Torr Samaho Status new => acknowledged
2014-05-01 15:45 Torr Samaho Note Added: 0008660
2014-05-01 15:45 Torr Samaho Assigned To => Torr Samaho
2014-05-01 15:45 Torr Samaho Status acknowledged => needs testing
2014-05-01 16:23 Torr Samaho Note Edited: 0008660 View Revisions
2014-05-01 16:36 Torr Samaho Note Edited: 0008660 View Revisions
2014-05-01 17:21 Torr Samaho Note Edited: 0008660 View Revisions
2014-05-01 20:57 Frits Note Added: 0008664
2014-05-02 15:27 ZzZombo Note Added: 0008669
2014-05-02 17:53 Torr Samaho Note Added: 0008670
2014-05-03 08:47 Torr Samaho Note Added: 0008677
2014-05-03 08:49 Torr Samaho Product Version => 1.2
2014-05-03 08:49 Torr Samaho Target Version => 1.3
2014-06-04 20:20 Arco Note Added: 0008847
2014-06-04 20:20 Arco Status needs testing => resolved
2014-06-04 20:20 Arco Fixed in Version => 1.3
2014-06-04 20:20 Arco Resolution open => fixed
2014-06-04 22:28 Arco Status resolved => feedback
2014-06-04 22:28 Arco Resolution fixed => reopened
2014-06-04 22:28 Arco Status feedback => resolved
2014-06-04 22:28 Arco Resolution reopened => fixed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker