Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003650Doomseeker[All Projects] Suggestionpublic2019-05-16 15:382019-07-30 10:13
ReporterPol M 
Assigned ToPol M 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSArchOS Versionx86-64
Product Version1.3 
Target Version1.3Fixed in Version1.3 
Summary0003650: Missing support for Universal Doom Map Format on the "add from loaded maps" create server menu
DescriptionWhile casually browsing the WAD specifications and testing some WAD parsers, I've discovered the UDMF specification, which we do not support, and since it seems to be a clear improvement on the Hexen format, we should. The change should be trivial.
Steps To Reproduce- Create a UDMF WAD, or convert an old one to the UDMF format.
- Create a server with this wad.
- Try to add the maps from the WAD in the Map list with the "add from loaded maps" button.
- Notice that those won't show up.
Additional Informationfreedoom converted and attached for testing:https://bitbucket.org/Pol_M/doomseeker/downloads/freedoomUDMF.wad [^]
Attached Files

- Relationships
child of 0003599closedPol M Allow Adding Maps En Masse To Playlist 

-  Notes
User avatar (0020662)
Pol M (developer)
2019-05-16 17:02
edited on: 2019-05-20 14:00

PR
EDIT: Zalewa's suggestions implemented.

User avatar (0020685)
WubTheCaptain (developer)
2019-05-22 00:10

(Summarized the ticket's issue.)
User avatar (0020699)
Zalewa (developer)
2019-05-27 16:52

Squashed and merged the PR ashttps://bitbucket.org/Doomseeker/doomseeker/commits/a734c70e0aab53b4026882946719df6132577fbd [^]

Thanks for your ongoing contributions Pol :)
User avatar (0020895)
Pol M (developer)
2019-07-20 01:12

I'm marking this as resolved. Did a quick extra test today, and it still worked as intended. If someone wants to test this, a unit test was added, you can check that things indeed work there :)

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-05-16 15:38 Pol M New Issue
2019-05-16 15:38 Pol M Status new => assigned
2019-05-16 15:38 Pol M Assigned To => Pol M
2019-05-16 15:43 Pol M Additional Information Updated View Revisions
2019-05-16 17:02 Pol M Note Added: 0020662
2019-05-16 17:02 Pol M Status assigned => needs review
2019-05-20 14:00 Pol M Note Edited: 0020662 View Revisions
2019-05-20 14:14 Pol M Relationship added child of 0003599
2019-05-22 00:10 WubTheCaptain Note Added: 0020685
2019-05-22 00:10 WubTheCaptain Severity tweak => feature
2019-05-22 00:10 WubTheCaptain Summary Add support for Universal Doom Map Format on the "add from loaded maps" create server menu. => No support for Universal Doom Map Format on the "add from loaded maps" create server menu
2019-05-22 00:30 WubTheCaptain Summary No support for Universal Doom Map Format on the "add from loaded maps" create server menu => Missing support for Universal Doom Map Format on the "add from loaded maps" create server menu
2019-05-27 16:52 Zalewa Note Added: 0020699
2019-05-27 16:52 Zalewa Status needs review => needs testing
2019-07-20 01:12 Pol M Note Added: 0020895
2019-07-20 01:12 Pol M Status needs testing => resolved
2019-07-20 01:12 Pol M Fixed in Version => 1.3
2019-07-20 01:12 Pol M Resolution open => fixed
2019-07-30 10:13 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker