Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003607Site[All Projects] Bugpublic2019-02-07 15:542019-02-08 02:12
ReporterWubTheCaptain 
Assigned ToBlzut3 
PrioritynoneSeverityfeatureReproducibilityalways
StatusresolvedResolutionwon't fix 
PlatformOSOS Version
Summary0003607: No native dists for Debian on debian.drdteam.org
DescriptionDebian users using DRD Team Debian Package Repository currently rely on using binary packages from Ubuntu stable multiverse dist provided by the same repository.

Very few times the packages from have not worked on Debian, such as Zandronum package being (previously) broken to missing libcrypto.so.1.0.0 dependency from OpenSSL (Debian had a more up-to-date one from Debian's repositories, causing an ABI incompatibility). The fix to this was a "hack" (assumably because it was less effort than a proper dist setup), making zandronum package depend on zandronum-ssl package (OpenSSL 1.0.2g with 1.0.0 ABI) unconditionally. (The latest one is OpenSSL 1.0.2q, so there may also be unpatched security bugs in that library?)

Some have simply refused to install in the past, due to missing or improper dependency names. My consideration: Does "one size fit for all" in the end? E.g. skulltag-client is only available for Ubuntu 14.04 LTS.
Steps To Reproducehttp://debian.drdteam.org/dists/ [^]

$ sudo apt install skulltag-client # Who would ever want to do this?!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skulltag-client : Depends: libflac++6 (>= 1.2.1-1.2) but it is not installable
E: Unable to correct problems, you have held broken packages.
Additional InformationWould be probably nice to have stretch, wheezy (?), jessie, testing, sid, oldstable (?), buster directories there.

Package: zandronum-ssl
Version: 1.0.2
Architecture: amd64
Depends: libc6, libssl1.1 | libssl1.0.2 | libssl0.9.8
Installed-Size: 9940
Maintainer: Zandronum Team <admin@maniacsvault.net>
Priority: optional
Section: games
Filename: pool/multiverse/z/zandronum-ssl/zandronum-ssl_1.0.2_amd64.deb
Size: 2248150
SHA256: 145475a9f571500f4ca0134d49e0cb6e073ec84780f007bfe5a2af294ac322e8
SHA1: c0ac3be3df3cb8f6ef40e07ba3229d972519db26
MD5sum: cd378f86336736ea6a1e3da092950c2b
Description: OpenSSL libraries for Zandronum for use with old distributions.
 This package contains OpenSSL 1.0.2g from Ubuntu which uses the 1.0.0 ABI.
Attached Files

- Relationships

-  Notes
User avatar (0020352)
Blzut3 (administrator)
2019-02-08 02:09

Quote from WubTheCaptain
a more up-to-date one from Debian's repositories

Ubuntu's OpenSSL was just as up to date, they just chose to keep the ABI. Which may have required disabling a feature or something like that. Like with the kernel, I wish distro vendors would take as hard of a "we don't break user space" mentality as possible.
Quote from WubTheCaptain
My consideration: Does "one size fit for all" in the end?

If it doesn't, complain to your distro for breaking ABI. :P

But seriously, the site is named after the packaging format not the distro. I state pretty clearly they're built for Ubuntu but will probably work since Debian is generally compatible (especially since I support Ubuntu releases for the full 5 years). I do what I can (static link, provide alternative packages) to support Debian where reasonable. But I'm not rebuilding binaries for each dist for the same reason I don't build rpms: I'm providing the binaries for the distro I personally use.

Obviously the Skulltag package isn't going to get updated and I'll probably remove it from the dist in April when 14.04 goes EOL.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-02-07 15:54 WubTheCaptain New Issue
2019-02-08 02:09 Blzut3 Note Added: 0020352
2019-02-08 02:12 Blzut3 Status new => resolved
2019-02-08 02:12 Blzut3 Resolution open => won't fix
2019-02-08 02:12 Blzut3 Assigned To => Blzut3






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker