Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003561Site[All Projects] Bugpublic2018-10-27 22:122018-10-28 00:51
ReporterWubTheCaptain 
Assigned ToBlzut3 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Summary0003561: debian.drdteam.org: Broken Doomseeker 1.2 package (missing libwadseeker 1.2 dependency)
DescriptionDRD Team's apt repository for Debian seems to not depend on a new version of libwadseeker yet. Upgarding from Doomseeker 1.1 to Doomseeker 1.2 also removes the libwadseeker package.

With Doomseeker 1.2 installed fromhttp://debian.drdteam.org/ [^] and executing doomseeker:

Steps To ReproduceInstall Doomseeker 1.2 fromhttp://debian.drdteam.org/ [^] using apt:

$ cat /etc/apt/sources.list.d/drdteam.list
debhttps://debian.drdteam.org/ [^] stable multiverse
# deb-srchttps://debian.drdteam.org/ [^] stable multiverse
$ apt update && apt full-upgrade # or `apt install doomseeker`
[...]
$ doomseeker
doomseeker: error while loading shared libraries: libwadseeker.so.1: cannot open shared object file: 
No such file or directory
Additional Information/var/log/apt/history.log:

Start-Date: 2018-10-27  21:47:45
Commandline: apt full-upgrade
Requested-By: wub (1000)
Install: libcrypt2:amd64 (1:4.1.1-1, automatic)
Upgrade: whois:amd64 (5.3.2, 5.4.0), libbrotli1:amd64 (1.0.6-1, 1.0.7-1), libg15render1:amd64 (1.3.0~svn316-2.3, 
1.3.0~svn316-2.4), doomseeker:amd64 (1.1, 1.2), libsnmp-base:amd64 (5.7.3+dfsg-3, 5.7.3+dfsg-4), libwmf0.2-7:amd64 
(0.2.8.4-12, 0.2.8.4-13), gcc-6-base:amd64 (6.4.0-23, 6.5.0-1), libapparmor1:amd64 (2.13.1-1, 2.13.1-2), 
libsnmp30:amd64 (5.7.3+dfsg-3, 5.7.3+dfsg-4), libclone-perl:amd64 (0.39-1, 0.41-1), libgdbm6:amd64 (1.18-2, 
1.18.1-1), libpcre2-8-0:amd64 (10.31-3, 10.32-1), apparmor:amd64 (2.13.1-1, 2.13.1-2), libgdbm-compat4:amd64 
(1.18-2, 1.18.1-1), libwmf-bin:amd64 (0.2.8.4-12, 0.2.8.4-13), libpcre2-16-0:amd64 (10.31-3, 10.32-1), 
doomseeker-zandronum:amd64 (35, 39), libevdev2:amd64 (1.5.9+dfsg-2, 1.6.0+dfsg-1)
Remove: libwadseeker:amd64 (1.1)
End-Date: 2018-10-27  21:47:58
Attached Files

- Relationships
related to 0003483resolvedBlzut3 Doomseeker Doomseeker 1.2 release 

-  Notes
User avatar (0020158)
Blzut3 (administrator)
2018-10-27 22:15

Hmm... not sure how it installed for me. I see the issue though.
User avatar (0020159)
WubTheCaptain (reporter)
2018-10-27 22:20

Blzut3: Probably because apt upgrade does not remove packages, full-upgrade (legacy "apt-get dist-upgrade") does?
User avatar (0020160)
Blzut3 (administrator)
2018-10-27 22:24

I always use apt full-upgrade. It definitely removed libwadseeker and installed libwadseeker1. Maybe some residual from development, but yeah I just need to regen the packages with libwadseeker1 installed and it'll be good.
User avatar (0020161)
WubTheCaptain (reporter)
2018-10-27 22:26

$ sudo apt install libwadseeker
[sudo] password for wub:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwadseeker : Depends: libwadseeker1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt install libwadseeker1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  giblib1 libqt5qml5 libqt5quick5 qml-module-qtgraphicaleffects qml-module-qtquick-controls qml-module-qtquick-layouts 
qml-module-qtquick-window2 qml-module-qtquick2
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libwadseeker1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 168 kB of archives.
After this operation, 1117 kB of additional disk space will be used.
Get:1https://debian.drdteam.org [^] stable/multiverse amd64 libwadseeker1 amd64 1.2 [168 kB]
Fetched 168 kB in 1s (196 kB/s)
Selecting previously unselected package libwadseeker1.
(Reading database ... 138329 files and directories currently installed.)
Preparing to unpack .../libwadseeker1_1.2_amd64.deb ...
Unpacking libwadseeker1 (1.2) ...
Setting up libwadseeker1 (1.2) ...
Processing triggers for libc-bin (2.27-6) ...
$ doomseeker
[22:26:09] Starting Doomseeker. Hello World! :)
# ...
User avatar (0020162)
Blzut3 (administrator)
2018-10-27 22:35

Should be fine now.
User avatar (0020163)
WubTheCaptain (reporter)
2018-10-27 22:50

Although there is no Debian-like version numbering 1.2-1 and 1.2-2 for each package revision, it did work.
User avatar (0020165)
Blzut3 (administrator)
2018-10-28 00:51

Changing that would require a code change where as all I did was regen the packages. So considering this resolved.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-10-27 22:12 WubTheCaptain New Issue
2018-10-27 22:12 WubTheCaptain Relationship added related to 0003483
2018-10-27 22:15 Blzut3 Note Added: 0020158
2018-10-27 22:16 Blzut3 Assigned To => Blzut3
2018-10-27 22:16 Blzut3 Status new => assigned
2018-10-27 22:20 WubTheCaptain Note Added: 0020159
2018-10-27 22:24 Blzut3 Note Added: 0020160
2018-10-27 22:26 WubTheCaptain Note Added: 0020161
2018-10-27 22:35 Blzut3 Note Added: 0020162
2018-10-27 22:35 Blzut3 Status assigned => needs testing
2018-10-27 22:50 WubTheCaptain Note Added: 0020163
2018-10-28 00:51 Blzut3 Note Added: 0020165
2018-10-28 00:51 Blzut3 Status needs testing => resolved
2018-10-28 00:51 Blzut3 Resolution open => fixed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker