Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003541Doomseeker[All Projects] Bugpublic2018-10-06 14:392018-10-27 22:57
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritylowSeveritytweakReproducibilityN/A
StatusclosedResolutiondenied 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003541: IP2C Update feature "has become unnecessary"
Description0003538:0019945:

Quote from Zalewa
In regards to the "IP2C Update" feature I'm however beginning to agree with you that this feature has become unnecessary - or rather, since Linux is covered by package managers and Mac & Windows are covered by Mendeley's Updater we can remove the separate "IP2C Update" feature altogether and rely on the aforementioned methods of update.
Steps To ReproduceTo locate the feature from Doomseeker interface: File → Update IP2C.
Attached Files

- Relationships

-  Notes
User avatar (0019950)
WubTheCaptain (developer)
2018-10-06 14:43
edited on: 2018-10-06 14:43

Do we deprecate this feature? If so, I can make a changelog notification of deprecation akin to SemVer (although we don't follow SemVer).

User avatar (0019954)
Zalewa (developer)
2018-10-06 16:56
edited on: 2018-10-06 16:58

I think we can safely remove it outright. (EDIT: we will have to keep the service on our server for some time, tho, at least for a few months after 1.2 release)

One thing to keep in mind is that "Auto Updates" page in the config box will now become empty on Linux and we will need to hide it. (that's actually a good thing, BTW, because this page had just one checkbox on Linux and it just looked silly)

Blzut, do you agree with the removal?

User avatar (0019971)
Blzut3 (administrator)
2018-10-06 21:37

The Mac autoupdater is being disabled due to Apple policies getting in the way of what we're currently doing. So relying on Mendeley is not an option.
User avatar (0019974)
Blzut3 (administrator)
2018-10-07 00:56

Thought of another reason to keep IP2C on a separate updater: Is this really something that needs super user privileges to be able to update?
User avatar (0019975)
Zalewa (developer)
2018-10-07 05:54

Quote from Blzut3
Thought of another reason to keep IP2C on a separate updater: Is this really something that needs super user privileges to be able to update?

Well, it would anyway if we were to go with the original request to rely on the readily-available geolite package from the Linux package manager.

Still...
Quote from Blzut3
The Mac autoupdater is being disabled due to Apple policies getting in the way of what we're currently doing. So relying on Mendeley is not an option.

... this pretty much disqualifies the removal anyway. The matter is concluded for me: "IP2C Update" stays. Let's return the focus on how to satisfy the licensing requirements.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: WubTheCaptain
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-10-06 14:39 WubTheCaptain New Issue
2018-10-06 14:43 WubTheCaptain Note Added: 0019950
2018-10-06 14:43 WubTheCaptain Assigned To => WubTheCaptain
2018-10-06 14:43 WubTheCaptain Status new => feedback
2018-10-06 14:43 WubTheCaptain Note Edited: 0019950 View Revisions
2018-10-06 14:43 WubTheCaptain Note Edited: 0019950 View Revisions
2018-10-06 14:54 WubTheCaptain Assigned To WubTheCaptain =>
2018-10-06 16:56 Zalewa Note Added: 0019954
2018-10-06 16:57 Zalewa Note Edited: 0019954 View Revisions
2018-10-06 16:58 Zalewa Note Edited: 0019954 View Revisions
2018-10-06 21:37 Blzut3 Note Added: 0019971
2018-10-07 00:56 Blzut3 Note Added: 0019974
2018-10-07 05:54 Zalewa Note Added: 0019975
2018-10-07 05:54 Zalewa Status feedback => resolved
2018-10-07 05:54 Zalewa Fixed in Version => 1.2
2018-10-07 05:54 Zalewa Resolution open => denied
2018-10-07 05:54 Zalewa Assigned To => Zalewa
2018-10-07 07:06 WubTheCaptain Fixed in Version 1.2 =>
2018-10-27 22:57 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker