Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003516Doomseeker[All Projects] Suggestionpublic2018-09-23 15:112018-10-27 22:53
ReporterZalewa 
Assigned ToPol M 
PrioritynormalSeveritytweakReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.10 Beta 
Target Version1.2Fixed in Version1.2 
Summary0003516: Add "translation contributors" section to the About dialog.
DescriptionTranslating a program is not a fun thing to do and there are lots of strings in Doomseeker. Anyone who is willing to provide a translation should receive a special recognition place in the program. Let's add such place somewhere in the about dialog and mention each contributor.
Additional InformationSupport for translations and a Polish translation was added for 0.10 Beta with commit 643dd47d329139f30b3dff5c24b4108b9cae3a46.

Spanish translation was added for Doomseeker 1.2 with merge commit 16a6f23a4546df5926c1fd19220f5094d460f558 and subsequent commits.
Attached Files

- Relationships

-  Notes
User avatar (0020013)
WubTheCaptain (developer)
2018-10-08 11:14
edited on: 2018-10-08 11:16

Can this be targeting 1.3 due to "time" constraints? No offense to any major translation contributors.

User avatar (0020018)
Pol M (developer)
2018-10-08 20:13

Well, if we really are in a hurry, we can add a "- translations provided by Zalewa and Pol Marcet Sardà" just *after* the line "- Hyper_Eye, Nece228, Linda "WubTheCaptain" Lapinlampi, Pol Marcet Sardà". This would take me 2 minutes 😊
Sine right now there aren't too many translations, this would do the job.

I think that this solution is "okay enough".
If Zalewa tells me what he had in mind, I could try to do so.
User avatar (0020023)
Zalewa (developer)
2018-10-08 20:39

I didn't have anything concrete in mind yet. I took several looks at the About dialog and tried to figure out how to fit this into the current layout or how could the layout be changed to avoid expanding the size of the dialog box. We have that scrolling box there that can accept as much text as we want, so I thought maybe it can be put there somewhere.

For now I think I can agree with Pol's suggestions that it will be sufficient to add a single line below the "Additional contributions" statement. I feel, however, that it should be clearly stated who is responsible for which translation.
User avatar (0020025)
Pol M (developer)
2018-10-08 20:48
edited on: 2018-10-08 20:49

Yeah, that's mainly why I think this solution is "okay enough"
I can simply state the translation between "()" just after every name.
"- translations provided by Zalewa (Polish) and Pol Marcet Sardà (Spanish)"
But pretty much with only one more translation, this would get too big to be handled by a label.

If we put it in the textbox, it could be added after "This program is distributed under the terms of the LGPL v2.1 or later."
and could get a more organized structure:

Translations:
- Polish: Zalewa
- Spanish: Pol Marcet Sardà
- [TRANSLATION]: [TRANSLATOR(S)]

(since it is possible that one translation is done by more than one person, I think this structure is the most adequate)

User avatar (0020030)
Zalewa (developer)
2018-10-08 20:55
edited on: 2018-10-08 20:55

Quote from Pol M

If we put it in the textbox, it could be added after "This program is distributed under the terms of the LGPL v2.1 or later."
and could get a more organized structure:

Translations:
- Polish: Zalewa
- Spanish: Pol Marcet Sardà
- [TRANSLATION]: [TRANSLATOR(S)]

I like it.

User avatar (0020033)
Pol M (developer)
2018-10-08 20:58

I'll comply
User avatar (0020037)
Pol M (developer)
2018-10-08 21:13

pull request
User avatar (0020038)
Zalewa (developer)
2018-10-08 21:25

Merged as:https://bitbucket.org/Doomseeker/doomseeker/commits/2114cea673d92346ae3465bf707705679a3bf2bf [^]
Changelog updated in:https://bitbucket.org/Doomseeker/doomseeker/commits/df8beff4d4065d7ceb4268c106583a4aed4677a7 [^]
User avatar (0020040)
WubTheCaptain (developer)
2018-10-08 21:48

Sorry, I'm taking this issue back from resolved for review.

Quote from Zalewa
I like it.


I don't like it.

Right now it's just one translatable tr(). I imagine what happens if someone adds another contributor there, the whole thing gets untranslated instead of three seperate lines. Compare to icons attribution, for example.

This edit also seems quite out of place, and repeats some author names already listed in the about dialog. Hence I also personally oppose making any change at all; though I'd also like a mention in an AUTHORS file in the source distribution.

I'm saying: The approach to resolution here seems incorrect or rushed.
User avatar (0020047)
Zalewa (developer)
2018-10-09 05:14

Then we'll fix it when it needs to be fixed.
User avatar (0020054)
WubTheCaptain (developer)
2018-10-09 11:11

Qt4 UTF-8 bug again.

Quote
- Spanish: Pol Marcet SardÃ
User avatar (0020059)
Pol M (developer)
2018-10-09 13:29

Ok, I'll fix it.
User avatar (0020063)
Pol M (developer)
2018-10-09 15:20

pull request
User avatar (0020064)
Pol M (developer)
2018-10-09 17:44
edited on: 2018-10-09 17:45

commit
thank you for reviewing, Linda!

User avatar (0020065)
WubTheCaptain (developer)
2018-10-09 19:22

That translation string is going to look very odd out of context, but alright.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Pol M
Opponents: WubTheCaptain

- Issue History
Date Modified Username Field Change
2018-09-23 15:11 Zalewa New Issue
2018-09-23 15:11 Zalewa Status new => assigned
2018-09-23 15:11 Zalewa Assigned To => Zalewa
2018-10-08 11:14 WubTheCaptain Note Added: 0020013
2018-10-08 11:16 WubTheCaptain Note Edited: 0020013 View Revisions
2018-10-08 20:13 Pol M Note Added: 0020018
2018-10-08 20:39 Zalewa Note Added: 0020023
2018-10-08 20:48 Pol M Note Added: 0020025
2018-10-08 20:49 Pol M Note Edited: 0020025 View Revisions
2018-10-08 20:55 Zalewa Note Added: 0020030
2018-10-08 20:55 Zalewa Note Edited: 0020030 View Revisions
2018-10-08 20:58 Pol M Note Added: 0020033
2018-10-08 20:58 Pol M Assigned To Zalewa => Pol M
2018-10-08 21:13 Pol M Note Added: 0020037
2018-10-08 21:13 Pol M Status assigned => needs review
2018-10-08 21:25 Zalewa Note Added: 0020038
2018-10-08 21:25 Zalewa Status needs review => resolved
2018-10-08 21:25 Zalewa Fixed in Version => 1.2
2018-10-08 21:25 Zalewa Resolution open => fixed
2018-10-08 21:48 WubTheCaptain Note Added: 0020040
2018-10-08 21:48 WubTheCaptain Status resolved => needs review
2018-10-08 21:48 WubTheCaptain Resolution fixed => reopened
2018-10-09 05:14 Zalewa Note Added: 0020047
2018-10-09 05:14 Zalewa Status needs review => resolved
2018-10-09 05:14 Zalewa Resolution reopened => fixed
2018-10-09 11:11 WubTheCaptain Note Added: 0020054
2018-10-09 11:11 WubTheCaptain Status resolved => assigned
2018-10-09 11:11 WubTheCaptain Resolution fixed => reopened
2018-10-09 12:02 WubTheCaptain Product Version => 0.10 Beta
2018-10-09 12:06 WubTheCaptain Additional Information Updated View Revisions
2018-10-09 13:29 Pol M Note Added: 0020059
2018-10-09 15:20 Pol M Note Added: 0020063
2018-10-09 15:20 Pol M Status assigned => needs review
2018-10-09 17:44 Pol M Note Added: 0020064
2018-10-09 17:45 Pol M Note Edited: 0020064 View Revisions
2018-10-09 17:45 Pol M Status needs review => needs testing
2018-10-09 19:22 WubTheCaptain Note Added: 0020065
2018-10-09 19:22 WubTheCaptain Status needs testing => resolved
2018-10-09 19:22 WubTheCaptain Resolution reopened => fixed
2018-10-27 22:53 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker