Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003447Zandronum[All Projects] Bugpublic2018-08-19 02:502018-08-19 02:50
ReporterRipperoni 
Assigned To 
PriorityhighSeverityfeatureReproducibilityalways
StatusnewResolutionopen 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0 
Target VersionFixed in Version 
Summary0003447: Brightmaps broken for textures - fixed in GZDoom, fix can be backported.
DescriptionI reported this bug on the ZDoom forums as seen here:

https://forum.zdoom.org/viewtopic.php?f=2&t=58444 [^]

It has since been fixed on GZDoom but it's still broken on Zandronum. Considering the only way to circumvent this problem is using a modified Doom2.wad, this is less than ideal. As far as I can see the fix was merely one line for code so backporting this fix should be trivial.
Steps To ReproduceIf you have a texture replacement for an original Doom 2 texture, it will automatically disable the brightmaps. This appears to be akin to using the "iwad" command in the definition as seen here:https://zdoom.org/wiki/GLDEFS#Brightmaps, [^] however it appears to be mistakenly enabled by default.
Additional InformationLike I said, this was fixed in GZDoom as seenhttps://github.com/coelckers/gzdoom/commit/c2b4efbea03cc70887e6493d66b816d89d998919 [^] here, so backporting the fix should hopefully be trivial.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: Michaelis
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-08-19 02:50 Ripperoni New Issue






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker