Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003381Doomseeker[All Projects] Bugpublic2018-02-21 21:522018-10-06 18:19
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritynormalSeveritymajorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.2 
Target Version1.2Fixed in Version1.2 
Summary0003381: tools: Missing a full copy of the license in source distribution (GPLv2+)
DescriptionZalewa has various tools under GPLv2+ in the tools directory of the source distribution, but no GPLv2 license text is provided in the root of the directory.

This current issue may (or may not) complicate source code tarball distribution.
Steps To Reproduce
  • tools/fix_excessive_whitespace.py
  • tools/normalize_nl.py (since 1.2-beta~1bb8cf6)
  • tools/strip_trailing_whitespace.py
  • tools/fixindentation.sh
Additional Informationhttps://www.gnu.org/licenses/old-licenses/gpl-2.0.txt [^]
Attached Files

- Relationships
child of 0003237closedWubTheCaptain Non-free files and copyright issues in source archive 

-  Notes
User avatar (0019083)
WubTheCaptain (developer)
2018-02-21 22:01

Would Zalewa relicense these to LGPLv2.1+ or should a copy of the GPLv2 license text be provided instead?
User avatar (0019084)
Zalewa (developer)
2018-02-22 10:17

https://bitbucket.org/Doomseeker/doomseeker/commits/34583760c0683b8264ff700f1baf6be4df7a5331 [^]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-02-21 21:52 WubTheCaptain New Issue
2018-02-21 21:52 WubTheCaptain Relationship added child of 0003237
2018-02-21 22:01 WubTheCaptain Note Added: 0019083
2018-02-21 22:53 Zalewa Assigned To => Zalewa
2018-02-21 22:53 Zalewa Status new => assigned
2018-02-22 10:17 Zalewa Note Added: 0019084
2018-02-22 10:17 Zalewa Status assigned => needs review
2018-02-22 20:04 WubTheCaptain Status needs review => resolved
2018-02-22 20:04 WubTheCaptain Fixed in Version => 1.2
2018-02-22 20:04 WubTheCaptain Resolution open => fixed
2018-02-22 20:05 WubTheCaptain Target Version => 1.2
2018-02-22 20:09 WubTheCaptain Product Version => 1.2
2018-10-06 18:19 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker