Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003380Doomseeker[All Projects] Bugpublic2018-02-21 21:022018-10-27 22:55
ReporterWubTheCaptain 
Assigned ToBlzut3 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003380: CMake Warning (dev): Policy CMP0071 is not set
DescriptionCMake 3.10 and later have a new warning about policy CMP0071.

Quote from CMP0071
Let AUTOMOC and AUTOUIC process GENERATED files.

Since version 3.10, CMake processes regular and GENERATED source files in AUTOMOC and AUTOUIC. In earlier CMake versions, only regular source files were processed. GENERATED source files were ignored silently.
Steps To Reproduce

  1. Make sure you're on CMake version >3.10: cmake --version
  2. Clone the Doomseeker source code and extract it
  3. Follow the compile instructions per COMPILE.txt in the source archive, up until cmake has been executed
  4. Notice the CMake Warnings in the output of build generation
Additional InformationI've used cmake version 3.10.2. Happens in both 1.1 and 1.2-beta~b39b4c1.

https://cmake.org/cmake/help/latest/policy/CMP0071.html [^]
Attached Fileslog file icon cmake.log [^] (6,661 bytes) 2018-02-21 21:02

- Relationships

-  Notes
User avatar (0019087)
Blzut3 (administrator)
2018-02-26 04:21

Address inhttps://bitbucket.org/Doomseeker/doomseeker/commits/89723aa969177c7b2d0dd6123a97b2926dba42fc [^]

As stated in the commit message, CMake 3.11 in looking pretty good in regards to deb packaging by the way. Just changelog, copyright, extended description, and soname. Most of which already have tickets.
User avatar (0019092)
WubTheCaptain (developer)
2018-02-26 07:19

Works for me.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-02-21 21:02 WubTheCaptain New Issue
2018-02-21 21:02 WubTheCaptain File Added: cmake.log
2018-02-26 03:56 Blzut3 Assigned To => Blzut3
2018-02-26 03:56 Blzut3 Status new => assigned
2018-02-26 04:21 Blzut3 Note Added: 0019087
2018-02-26 04:21 Blzut3 Status assigned => needs testing
2018-02-26 04:22 Blzut3 Fixed in Version => 1.2
2018-02-26 04:22 Blzut3 Target Version => 1.2
2018-02-26 07:19 WubTheCaptain Note Added: 0019092
2018-02-26 07:19 WubTheCaptain Status needs testing => resolved
2018-02-26 07:19 WubTheCaptain Resolution open => fixed
2018-10-27 22:55 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker