Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003306Doomseeker[All Projects] Bugpublic2017-10-22 18:102018-10-27 22:55
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003306: Player slots style appearance is not updated until the configuration window is closed
DescriptionIf the player slots style option in Doomseeker's configuration is changed and settings applied, the changes are not immediately visible if the settings are applied until the configuration window is closed.

Ideally, the changes to player slots style should be immediately visible without closing the configuration window.
Steps To Reproduce

  1. (Have an Internet connection to get some servers listed in Doomseeker.)

  2. Start Doomseeker.

  3. Press the F5 key to open the configuration or find Options → Configuration from the top crate navigation.

  4. Navigate to "Appearance" settings.

  5. Under "Player slots style", select another (non-current) dropdown menu option.

  6. Hit the "Apply" button for settings.

  7. Notice how in the background Doomseeker's server list is not updated.

  8. Hit the "OK" or "Cancel" button for settings, or close the window.

  9. The player slots style will be updated, where it wasn't with "Apply" button.

Attached Files

- Relationships

-  Notes
User avatar (0018594)
Zalewa (developer)
2017-10-22 19:37

Quote
[All Projects] Bug

I wouldn't categorize it as such, given that this behavior was implemented with full intention. There's a piece of code that checks after the dialog box is closed if anything in the appearance section has changed and only then the changes are actually applied to the UI.

I will change it, though, because in fact there's no reason not to apply the UI changes immediately after pressing the "apply" button.
User avatar (0018595)
WubTheCaptain (developer)
2017-10-22 19:40

Okay, thanks. I agree it's more of a suggestion, with previous behavior being with full intent.
User avatar (0018596)
WubTheCaptain (developer)
2017-10-22 19:45

A little bit of extra: Could you please make the changes instant without having to hit "Apply"? I took an example from OBS Studio (uses the Qt framework too, I think), where the "Theme" setting is instant on choice but only permanent if the settings are applied.
User avatar (0019463)
Zalewa (developer)
2018-09-01 10:06

Dynamic application of visual styles should occur with this commit:https://bitbucket.org/Doomseeker/doomseeker/commits/cb9aa84a188e385afda8deab16768289ed426db0 [^]

I've added several more of the "Appearance" options than just the player slots to the mix. It's all described in the CHANGELOG.md.
User avatar (0019465)
WubTheCaptain (developer)
2018-09-01 10:43

Well, pinned servers (or custom servers in 1.1) aren't updated instantly (nor on press of "Apply"), but I certainly wasn't expecting the changes to slot styles to be immediate before pressing "apply". For server colors, it might be just okay to not seem disruptive (because you need to confirm the color choice action, anyway).

Language selection in appearance is not immediate and requires the press of "apply" button, which I could argue to be a good thing. This is consistent with Mumble, in example (another popular Qt4 software).

Technically this ticket is resolved, but would you like to make a small adjustment or another ticket for enhancement/tweak so that all changes (everywhere) are only updated once "Apply" is pressed, Zalewa?
User avatar (0019467)
Zalewa (developer)
2018-09-01 11:14

Quote from "WubTheCaptain"
Well, pinned servers (or custom servers in 1.1) aren't updated instantly (nor on press of "Apply")

I don't really think it's necessary to do that. That's not an "Appearance" setting and the user doesn't benefit from immediate feedback.

Quote from "WubTheCatapain"
I certainly wasn't expecting the changes to slot styles to be immediate before pressing "apply"

Here, on the other hand, immediate feedback is very welcome. User can adjust their settings and see how they look like in action without constantly navigating the mouse cursor to the "Apply" button, and if the settings become messed up, user can just go to the previous settings by cancelling the dialog box.

Quote from "WubTheCaptain"
Language selection in appearance is not immediate and requires the press of "apply" button

Dynamic language selection is unfortunately so wonky that I think it would actually be best if the program just said that "to apply the translation you need to restart Doomseeker" and don't even attempt any dynamic re-translation. Implementing dynamic re-translation is something that would require drastic changes to the codebase (if it's even possible at all) and I won't be attempting this for sure.
User avatar (0019470)
WubTheCaptain (developer)
2018-09-01 11:31

Quote from Zalewa
Dynamic language selection is unfortunately so wonky that I think it would actually be best if the program just said that "to apply the translation you need to restart Doomseeker" and don't even attempt any dynamic re-translation.


Coincidentally this is what I said in deleted note 0003260:0019466 before removing it. This is now ticket 0003482.

Anyway... Although I personally disagree with the solution's state changes, this ticket is resolved.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-10-22 18:10 WubTheCaptain New Issue
2017-10-22 18:21 Zalewa Status new => acknowledged
2017-10-22 19:37 Zalewa Note Added: 0018594
2017-10-22 19:40 WubTheCaptain Note Added: 0018595
2017-10-22 19:40 WubTheCaptain Assigned To => Zalewa
2017-10-22 19:40 WubTheCaptain Status acknowledged => confirmed
2017-10-22 19:45 WubTheCaptain Note Added: 0018596
2017-10-22 19:58 WubTheCaptain Status confirmed => feedback
2018-09-01 07:47 Zalewa Status feedback => assigned
2018-09-01 10:06 Zalewa Note Added: 0019463
2018-09-01 10:06 Zalewa Status assigned => needs testing
2018-09-01 10:30 WubTheCaptain Target Version => 1.2
2018-09-01 10:43 WubTheCaptain Note Added: 0019465
2018-09-01 10:43 WubTheCaptain Status needs testing => needs review
2018-09-01 10:44 WubTheCaptain Fixed in Version => 1.2
2018-09-01 11:14 Zalewa Note Added: 0019467
2018-09-01 11:31 WubTheCaptain Note Added: 0019470
2018-09-01 11:31 WubTheCaptain Status needs review => resolved
2018-09-01 11:31 WubTheCaptain Resolution open => fixed
2018-10-27 22:55 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker