Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003301Doomseeker[All Projects] Bugpublic2017-10-12 06:442018-10-27 22:53
ReporterWubTheCaptain 
Assigned To 
PrioritynormalSeverityblockReproducibilitysometimes
StatusclosedResolutionunable to reproduce 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003301: libwadseeker shared library dependency is not handled properly at runtime in Doomseeker after "sudo make install"
DescriptionDoomseeker has a shared library dependency to libwadseeker, which requires activating the ldconfig trigger. This needs to be done (but isn't yet done) to update the dynamic linker cache to find libwadseeker.so.

Failure to activate the ldconfig trigger means Doomseeker (from /usr/local prefix?) may fail to execute to missing libwadseeker.so shared library dependency post-install. This does not affect build-path executables (which still have RPATH for a good reason, but will be cleaned post-install from any RPATHs).

Lintian error: package-must-activate-ldconfig-trigger (Severity: serious, Certainty: certain)
Steps To ReproduceFound in COMPILE.txt of the source repository root:

Linux compilation instructions:

mkdir build
cd build
cmake ..
make
sudo make install


"sudo ldconfig" is a missing step as a workaround.

If activating ldconfig for testing this, rename or remove libwadseeker.so from LIBDIR and run ldconfig again to get a cache without libwadseeker to avoid "well, it works for me now".
Additional Information

  • https://www.debian.org/doc/debian-policy/#ldconfig

  • https://lintian.debian.org/tags/package-must-activate-ldconfig-trigger.html

Attached Files

- Relationships
related to 0003232closedBlzut3 Doomseeker installs architecture-dependent engine libraries to arch-independent directory (multi-arch support) 
child of 0003246confirmedWubTheCaptain Debian packaging 

-  Notes
User avatar (0018543)
WubTheCaptain (developer)
2017-10-12 06:48

Initially discussed in 0003232 notes. Child of 0003246 because of Lintian error affecting Debian packaging.

What is the correct resolution here? We could naively add the requirement to trigger ldconfig to COMPILE.txt instructions and force myself to activate ldconfig in Debian's trigger files in the package.

Perhaps a bigger problem is trying to understand why the library is not automatically discovered already (dh_makeshlibs).
User avatar (0019915)
WubTheCaptain (developer)
2018-10-05 07:29

I'm not sure what changed, but please test this with Doomseeker 1.2. Last time I tried, I didn't have this issue.
User avatar (0020011)
WubTheCaptain (developer)
2018-10-08 11:09

Tested again with a .deb package, but I had it installed to /usr/bin. Maybe this is not a big concern after all, or it was fixed sometime in 1.2.

Processing triggers for libc-bin (2.27-6) ...
User avatar (0020012)
WubTheCaptain (developer)
2018-10-08 11:11

Another theory: OP's issue was due to faulty Debian packaging, caused by a split between Doomseeker and Wadseeker packages. The tests I did with one .deb had both Doomseeker and Wadseeker included.

Reopening is always a possibility.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-10-12 06:44 WubTheCaptain New Issue
2017-10-12 06:45 WubTheCaptain Relationship added related to 0003232
2017-10-12 06:45 WubTheCaptain Relationship added child of 0003246
2017-10-12 06:48 WubTheCaptain Note Added: 0018543
2017-10-12 06:48 WubTheCaptain Status new => confirmed
2017-10-12 06:49 WubTheCaptain Category Suggestion => Bug
2018-10-05 07:29 WubTheCaptain Note Added: 0019915
2018-10-05 07:29 WubTheCaptain Severity crash => block
2018-10-05 07:29 WubTheCaptain Status confirmed => needs testing
2018-10-05 07:29 WubTheCaptain Target Version => 1.2
2018-10-08 11:09 WubTheCaptain Note Added: 0020011
2018-10-08 11:09 WubTheCaptain Status needs testing => resolved
2018-10-08 11:09 WubTheCaptain Fixed in Version => 1.2
2018-10-08 11:09 WubTheCaptain Resolution open => unable to reproduce
2018-10-08 11:09 WubTheCaptain Assigned To => WubTheCaptain
2018-10-08 11:11 WubTheCaptain Note Added: 0020012
2018-10-08 11:13 WubTheCaptain Assigned To WubTheCaptain =>
2018-10-27 22:53 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker