Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003178Zandronum[All Projects] Bugpublic2017-07-03 07:482017-08-06 23:24
ReporterGummywormz 
Assigned ToTorr Samaho 
PriorityhighSeveritymajorReproducibilityalways
Statusneeds testingResolutionopen 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target Version3.0Fixed in Version 
Summary0003178: Massive lag upon map change, forces reconnect
DescriptionI admit I can't be too helpful in trying to track this bug down, but there has been a major issue in the June 25th version of Zandronum. Everytime the map changes, the game lags severely. This seems to only happen with moderate / full servers (around 14+ players). Connecting for the first time / reconnecting seems to resolve the issue. After a map change / intermission, the game lags. Textures are slow to load in and eventually I'm forced to reconnect. When I do so, the game gives the "too many missed packets, cannot recover" message. I note that smaller maps load in fine, but medium and large size maps cause the issue. These aren't slaughter maps, but standard deathmatch maps. It also causes my entire internet to lag until I actually reconnect.
Additional InformationThis only happens with the June 25th version. Every other version has worked perfectly fine.
Attached Files

- Relationships

-  Notes
User avatar (0017978)
Torr Samaho (administrator)
2017-07-04 06:02

Which mods / map sets are affected? Does this happen also if no CVARINFO lump is used?
User avatar (0017979)
Gummywormz (reporter)
2017-07-06 02:59

Always happens in MM8BDM + classes-v8e-beta4. Removing the CVARINFO file from MM8BDM seems to fix it, but I would need to test it out more as I've been unable to play with the amount of players needed to trigger the forced reconnect. So far, it does seem to reduce load time upon map transition.
User avatar (0017982)
Gummywormz (reporter)
2017-07-07 00:03

I can confirm that deleting CVARINFO and starting with a fresh ini does not fix this issue.
User avatar (0017992)
Torr Samaho (administrator)
2017-07-09 19:07

Did you delete CVARINFO from clients and server? That would be the only way to properly test whether CVARINFO is causing this.
User avatar (0018053)
Ru5tK1ng (updater)
2017-07-16 23:34

A user reported the symptoms as described in the summary. He gave me this screen cap:

https://images.discordapp.net/attachments/160876376662999040/336249776930553856/Screenshot_Doom_20170715_173631.png [^]
User avatar (0018064)
Torr Samaho (administrator)
2017-07-18 18:42

"Userinfo is incomplete" definitely is a problem. I have an idea why this could be happening, although I don't see any link to performance problems. Is the userinfo error reproducible? Under which platform does it occur?
User avatar (0018068)
Cutman (reporter)
2017-07-20 17:54

It's only ever happened to be once and it seems to be pure random. Others seem to get it more often though. Sadly I haven't been able to get a hold of anyone who frequently gets the issue.
User avatar (0018069)
Gummywormz (reporter)
2017-07-21 02:58

I don't ever remember seeing "userinfo incomplete". It just lags out with the generic " too many missed packets" message. I haven't been able to test recently though
User avatar (0018070)
Kaminsky (reporter)
2017-07-21 03:57

I can say that this issue has happened to me at least once. Right before the server was changing maps, I tried to join the game from spectators, and I was kicked out with the "Userinfo is incomplete... the server rejected the userinfo" message.

I am wondering if this may happen when any server configurations (DMFlags, CompatFlags, etc.) are changed, because the only time I tried to join a game and got this error, the server's game flags were being changed. Furthermore, the screenshot above showed something similar; the client changed their player class while the server's DMFlags and CompatFlags were changed and was kicked with the same message.
User avatar (0018095)
Torr Samaho (administrator)
2017-07-24 18:32

Thanks! I added your patch.
User avatar (0018149)
Gummywormz (reporter)
2017-08-06 23:24

I can confirm that the "userinfo incomplete" bug is a separate issue.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: im1hpu0
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-07-03 07:48 Gummywormz New Issue
2017-07-04 06:02 Torr Samaho Note Added: 0017978
2017-07-04 06:02 Torr Samaho Status new => feedback
2017-07-06 02:59 Gummywormz Note Added: 0017979
2017-07-06 02:59 Gummywormz Status feedback => new
2017-07-07 00:03 Gummywormz Note Added: 0017982
2017-07-09 19:07 Torr Samaho Note Added: 0017992
2017-07-16 23:34 Ru5tK1ng Note Added: 0018053
2017-07-18 18:42 Torr Samaho Note Added: 0018064
2017-07-18 18:42 Torr Samaho Target Version => 3.0
2017-07-18 18:42 Torr Samaho Status new => feedback
2017-07-20 17:54 Cutman Note Added: 0018068
2017-07-21 02:58 Gummywormz Note Added: 0018069
2017-07-21 02:58 Gummywormz Status feedback => new
2017-07-21 03:57 Kaminsky Note Added: 0018070
2017-07-24 18:32 Torr Samaho Note Added: 0018095
2017-08-06 19:16 Dusk Assigned To => Torr Samaho
2017-08-06 19:16 Dusk Status new => needs testing
2017-08-06 23:24 Gummywormz Note Added: 0018149






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker