Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002960Zandronum[All Projects] Bugpublic2016-12-12 07:192018-09-30 21:51
ReporterZombie 
Assigned ToEdward-san 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04 x86-64
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002960: Strife Crashes when transitioning between two levels in multi-player games
DescriptionStrife Crashes when transitioning between two levels in multi-player games on Zandronum 3.x. It does not on 2.1.2. All you have to do is transition levels no less then three times.
Steps To ReproduceEnter and exit any level transition, say Map01 to Map02 and back again, on the third transition the server instance will crash with a segfault disconnecting all clients.
Additional InformationInitial investigations linked this to Wrath of Cronos. Wrath of Cronos has no impact on this bug at all. Te bug occurs with or without wrath of Cronos loaded.
Attached Files? file icon hub_voodoo.wad [^] (6,339 bytes) 2016-12-22 11:05

- Relationships
child of 0002885closedTorr Samaho deathmatch CVar doesn't take effect when used via command-line 

-  Notes
User avatar (0016474)
Edward-san (developer)
2016-12-12 12:50

Can you check older 3.0 builds and see if the crash still happens?
User avatar (0016475)
Zombie (reporter)
2016-12-12 12:53

I would try build 614, but there is no Linux build of that, I can post a log. I'm using TPSG Painkiller hosting to do this. Its not on my local system.
User avatar (0016476)
Zombie (reporter)
2016-12-12 13:03

3.0-alpha-r160814-2010 has no Linux build.
3.0-alpha-r160717-1138 also has no Linux Build.
User avatar (0016477)
Edward-san (developer)
2016-12-12 13:58

I can reproduce this and can see it's caused by the fix for ticket 0002885 .
User avatar (0016479)
Zombie (reporter)
2016-12-12 14:24

Can you produce the requested builds so I can do Regression testing?
User avatar (0016480)
AOSP (reporter)
2016-12-12 15:54

(Psst! If you ask nicely, I can make a build of Zandronum and slap it on TSPG for you...)
User avatar (0016481)
Zombie (reporter)
2016-12-12 16:03

That would be outstanding. Please do so!
User avatar (0016484)
Edward-san (developer)
2016-12-12 23:18

If I was not clear enough with 0002960:0016477, it's already tested (I did bisect the history). Only a fix is needed.
User avatar (0016485)
Zombie (reporter)
2016-12-12 23:41

Oh, I see. Thank you. AOSP, can you upload a patch to Painkiller?
User avatar (0016488)
AOSP (reporter)
2016-12-13 11:04

No, because it appears there isn't a fix for it yet.
User avatar (0016489)
Zombie (reporter)
2016-12-13 11:06

I understand and will wait for a fix to be released.
User avatar (0016532)
Zombie (reporter)
2016-12-18 21:48

Does this mean a patch I can issue to Painkiller is open?
User avatar (0016534)
AOSP (reporter)
2016-12-18 21:51

No. It means the bug will be fixed in time for the release of 3.0.
User avatar (0016538)
Edward-san (developer)
2016-12-22 11:10
edited on: 2016-12-22 11:11

The crash happens with any hub cluster containing a map with a voodoo doll. See the attached example wad which works with doom2 (very reduced, indeed...).

To reproduce:

server command line:

zandronum -iwad doom2.wad -file hub_voodoo.wad -host 1 -warp 01 -skill 4 -private


connect one client and enter the portal until the server crashes.

User avatar (0016539)
Torr Samaho (administrator)
2016-12-22 19:43

Thanks for the example wad! The crash does not occur under Windows, right? At least I couldn't reproduce it locally under Windows so far.
User avatar (0016544)
Edward-san (developer)
2016-12-24 09:14
edited on: 2016-12-24 09:15

Can you check if buildinghttps://bitbucket.org/zandronum/zandronum-sandbox/commits/38b6a000e0bd47ae4f18c3e17bec47e7a2ba444e [^] fixes the issue and doesn't cause regressions (also from windows)?

User avatar (0016569)
Zombie (reporter)
2016-12-29 21:18

Are you asking me?
User avatar (0016571)
Edward-san (developer)
2016-12-30 02:29

No, sorry, it was for Torr Samaho and anybody who can build it and check.
User avatar (0016572)
Zombie (reporter)
2016-12-30 02:32

I have a build issues due to the lack of an RPM Spec File for the RPM Build system.
User avatar (0016580)
Zombie (reporter)
2017-01-01 02:04

Can I get someone who works on Painkiller to upload a test build to TSPG?
User avatar (0016646)
Edward-san (developer)
2017-01-16 11:37

https://bitbucket.org/Torr_Samaho/zandronum/pull-requests/192/fixed-regression-with-vodoo-doll-players [^]
User avatar (0016652)
Edward-san (developer)
2017-01-18 12:48
edited on: 2017-01-18 12:48

Fix added in 3.0 upstream:https://bitbucket.org/Torr_Samaho/zandronum/commits/89cf3bfb98b1754f1fe2650b17a99e49855afb95 [^]

User avatar (0016685)
Ru5tK1ng (updater)
2017-01-25 03:08

I grabbed the latest changes and set up a server online with 2 clients. I could not reproduce the crash despite multiple level transitions.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-12-12 07:19 Zombie New Issue
2016-12-12 12:50 Edward-san Note Added: 0016474
2016-12-12 12:50 Edward-san Status new => feedback
2016-12-12 12:53 Zombie Note Added: 0016475
2016-12-12 12:53 Zombie Status feedback => new
2016-12-12 13:03 Zombie Note Added: 0016476
2016-12-12 13:58 Edward-san Note Added: 0016477
2016-12-12 13:58 Edward-san Status new => confirmed
2016-12-12 13:58 Edward-san Relationship added child of 0002885
2016-12-12 14:24 Zombie Note Added: 0016479
2016-12-12 15:54 AOSP Note Added: 0016480
2016-12-12 16:03 Zombie Note Added: 0016481
2016-12-12 23:18 Edward-san Note Added: 0016484
2016-12-12 23:41 Zombie Note Added: 0016485
2016-12-13 11:04 AOSP Note Added: 0016488
2016-12-13 11:06 Zombie Note Added: 0016489
2016-12-18 21:27 Torr Samaho Target Version => 3.0
2016-12-18 21:48 Zombie Note Added: 0016532
2016-12-18 21:51 AOSP Note Added: 0016534
2016-12-22 11:05 Edward-san File Added: hub_voodoo.wad
2016-12-22 11:10 Edward-san Note Added: 0016538
2016-12-22 11:10 Edward-san Assigned To => Torr Samaho
2016-12-22 11:10 Edward-san Status confirmed => assigned
2016-12-22 11:11 Edward-san Note Edited: 0016538 View Revisions
2016-12-22 19:43 Torr Samaho Note Added: 0016539
2016-12-24 09:14 Edward-san Note Added: 0016544
2016-12-24 09:14 Edward-san Assigned To Torr Samaho => Edward-san
2016-12-24 09:14 Edward-san Status assigned => feedback
2016-12-24 09:15 Edward-san Note Edited: 0016544 View Revisions
2016-12-29 21:18 Zombie Note Added: 0016569
2016-12-29 21:18 Zombie Status feedback => assigned
2016-12-30 02:29 Edward-san Note Added: 0016571
2016-12-30 02:29 Edward-san Status assigned => feedback
2016-12-30 02:32 Zombie Note Added: 0016572
2016-12-30 02:32 Zombie Status feedback => assigned
2017-01-01 02:04 Zombie Note Added: 0016580
2017-01-16 11:37 Edward-san Note Added: 0016646
2017-01-16 11:37 Edward-san Status assigned => needs review
2017-01-18 12:48 Edward-san Note Added: 0016652
2017-01-18 12:48 Edward-san Status needs review => needs testing
2017-01-18 12:48 Edward-san Note Edited: 0016652 View Revisions
2017-01-25 03:08 Ru5tK1ng Note Added: 0016685
2017-01-25 03:08 Ru5tK1ng Status needs testing => resolved
2017-01-25 03:08 Ru5tK1ng Resolution open => fixed
2017-01-25 03:08 Ru5tK1ng Fixed in Version => 3.0
2018-09-30 21:51 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker