Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002200Zandronum[All Projects] Bugpublic2015-04-19 21:442018-09-30 22:22
ReporterDusk 
Assigned ToDusk 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002200: [MENUDEF] Multiplayer options must be rebuilt
DescriptionNow that menus need to be rebuilt, we have an opportunity do something about the structure of the multiplayer menu.

Discussion with blzut3 and edward-san resulted in the possibility of moving the offline skirmish into new game, and everything else under a MULTIPLAYER OPTIONS inside the options menu (placed at the top so that it's easy to find)
Attached Files

- Relationships
parent of 0000855closedDusk Move the Multiplayer Menu from the Main Menu to the Options Menu 
child of 0002197closedDusk Rebuild Zandronum menus for MENUDEF 

-  Notes
User avatar (0012143)
Dusk (developer)
2015-04-19 22:39

I've got most of the flat items of the multiplayer menu migrated to a new Multiplayer Options menu. This menu now also contains the Network Options menu.
User avatar (0012145)
Dusk (developer)
2015-04-20 12:01
edited on: 2015-04-20 12:02

It had turned out the the menudef entirely lacked a text input field. I have written one now and "server password" and "server join password" can be edited now.

User avatar (0012146)
ibm5155 (reporter)
2015-04-20 15:44

Offline Multiplayer - Online Multiplayer aren't on the same area?
Indeed Network options should be into multiplayer area.
Well, and what about the login system over herehttp://zandronum.com/tracker/view.php?id=1984 [^]

I just don't get the new game with offline multiplayer option, will it be like
NEW GAME ->
ºSKILL 1
ºSKILL 2
ºSKILL 3
ºSKILL 4
ºOFFLINE MULTIPLAYER?

or

NEW GAME->
ºCAMPAING
ºOFFLINE MULTIPLAYER?
User avatar (0012147)
Dusk (developer)
2015-04-20 16:07

The login menu will be done into the new Multiplayer Options menu.

I was thinking about putting the skirmish into the episode list (thus making the episode list appear unconditionally), e.g.:
- KNEE-DEEP IN THE DEAD
- THE SHORES OF HELL
- INFERNO
- THY FLESH CONSUMED

- OFFLINE SKIRMISH
User avatar (0012148)
Blzut3 (administrator)
2015-04-20 16:50

Not sure I would advise adding it to the episode list since some vanilla mods took advantage of the episode list length being constant. (Multi-line text.) Might even be some that utilize the heading graphic to have a background, but I can't think of any off hand.
User avatar (0012149)
Dusk (developer)
2015-04-20 17:23
edited on: 2015-04-20 17:44

Damnit, that's right. That wouldn't solve anything..

I suppose a new menu is necessary then unless we want to put it into the class list..

EDIT: What if we put it under Multiplayer Options at the top of the options menu?

User avatar (0012150)
Blzut3 (administrator)
2015-04-21 01:19

Shouldn't be much of a problem with moving that, although perhaps consider putting it under player setup and then splitting those two into a group since atm we have a link from multiplayer into the player setup.
User avatar (0012228)
StrikerMan780 (reporter)
2015-05-10 10:29
edited on: 2015-05-18 01:02

I'd put it under new game still, but have it go like this:

New game -> Next Menu:
    Single Player*
    Offline Skirmish

* -> Next Menu:
    Episode 1, 2, 3, 4, etc. -> Skills

User avatar (0012333)
Dusk (developer)
2015-05-18 01:34

For now it's under Multiplayer options until we reach a conclusion where it really should go.
User avatar (0012334)
ZzZombo (reporter)
2015-05-18 10:00
edited on: 2015-05-18 10:24

http://zandronum.com/tracker/view.php?id=1649 [^] ?

User avatar (0012346)
StrikerMan780 (reporter)
2015-05-23 21:10
edited on: 2015-05-23 21:11

Changing the Skill and Botskill in the Skirmish menu changes the value of the skills, but it doesn't update in the menu. Ie. If botskill was initially at 1, and you click on it or hit the right arrow, the skill will change to 2 internally, but the value in the menu still says 1.

Also, adding bots doesn't work. You can select them, but once you start a match, they don't get added in.

User avatar (0013101)
Torr Samaho (administrator)
2015-08-08 16:07

The skill issues already seemed to be fixed and adding bots should work now (it already worked for game modes with teams).
User avatar (0013102)
cobalt (updater)
2015-08-08 16:19

Issue addressed by commit e5f51b75379c: Fixed: Bots selected in the offline skirmish menu for game modes without teams were not spawned (addresses 2200).
Committed by Benjamin Berkels [Torr Samaho] on Saturday 08 August 2015 18:04:59

Changes in files:

 src/menu/multiplayermenu.cpp | 4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

User avatar (0013314)
Ru5tK1ng (updater)
2015-08-29 20:18
edited on: 2015-08-29 20:20

I didn't have any issues with the bots joining or the skill levels with 3.0-alpha-150819-2351. Everything seemed to work fine.


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: ibm5155 mifu StrikerMan780
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2015-04-19 21:44 Dusk New Issue
2015-04-19 21:44 Dusk Status new => assigned
2015-04-19 21:44 Dusk Assigned To => Dusk
2015-04-19 21:44 Dusk Relationship added child of 0002197
2015-04-19 21:48 Blzut3 Relationship added parent of 0000855
2015-04-19 22:39 Dusk Note Added: 0012143
2015-04-20 12:01 Dusk Note Added: 0012145
2015-04-20 12:02 Dusk Note Edited: 0012145 View Revisions
2015-04-20 15:44 ibm5155 Note Added: 0012146
2015-04-20 16:07 Dusk Note Added: 0012147
2015-04-20 16:50 Blzut3 Note Added: 0012148
2015-04-20 17:23 Dusk Note Added: 0012149
2015-04-20 17:44 Dusk Note Edited: 0012149 View Revisions
2015-04-21 01:19 Blzut3 Note Added: 0012150
2015-04-21 14:36 Dusk Note Added: 0012151
2015-04-21 17:54 Dusk Note Edited: 0012151 View Revisions
2015-04-21 18:46 Dusk Note Deleted: 0012151
2015-05-10 10:29 StrikerMan780 Note Added: 0012228
2015-05-10 10:30 StrikerMan780 Note Edited: 0012228 View Revisions
2015-05-18 01:02 StrikerMan780 Note Edited: 0012228 View Revisions
2015-05-18 01:34 Dusk Note Added: 0012333
2015-05-18 10:00 ZzZombo Note Added: 0012334
2015-05-18 10:24 Edward-san Note Edited: 0012334 View Revisions
2015-05-23 21:10 StrikerMan780 Note Added: 0012346
2015-05-23 21:11 StrikerMan780 Note Edited: 0012346 View Revisions
2015-05-24 19:39 Dusk Product Version 3.0 => 3.0-beta
2015-08-08 16:07 Torr Samaho Note Added: 0013101
2015-08-08 16:07 Torr Samaho Status assigned => needs testing
2015-08-08 16:19 cobalt Note Added: 0013102
2015-08-29 20:18 Ru5tK1ng Note Added: 0013314
2015-08-29 20:20 Ru5tK1ng Note Edited: 0013314 View Revisions
2015-09-01 16:26 Dusk Status needs testing => resolved
2015-09-01 16:26 Dusk Fixed in Version => 3.0
2015-09-01 16:26 Dusk Resolution open => fixed
2018-09-30 22:22 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker