Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001459Zandronum[All Projects] Bugpublic2013-08-13 00:132018-09-30 22:11
ReporterMarcaek 
Assigned ToDusk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version 
Target Version3.0Fixed in Version3.0 
Summary0001459: "Spawn with shotgun" flag doesn't work outside of co-op
DescriptionI think this would be helpful for maps that don't have a weapon on spawn, and really there's no logical reason it shouldn't work outside of co-op regardless.
Attached Files

- Relationships

-  Notes
User avatar (0007005)
Watermelon (developer)
2013-08-13 02:46
edited on: 2013-08-13 02:47

Does it work in survival? Or only co-op? Wondering if its monster only wads or just specifically co-op.

User avatar (0007016)
Qent (updater)
2013-08-13 22:37
edited on: 2013-08-13 22:39

It works in Survival, too. And in Invasion, for that matter.

User avatar (0009318)
Watermelon (developer)
2014-06-14 17:39

Still the same in 2.0?
User avatar (0011839)
Marcaek (reporter)
2015-03-16 14:19

Still true for DM it seems.
User avatar (0011844)
Dusk (developer)
2015-03-16 17:38

IIRC this is intentional on Carn's behalf.
User avatar (0011858)
Marcaek (reporter)
2015-03-17 03:05

That's silly, and it's listen in Doomseeker as a Deathmatch setting.

I suppose if people care enough they can make a wad to work around such an irrational decision :/
User avatar (0011869)
Dark-Assassin (administrator)
2015-03-20 16:12

IMO If people want to use this flag in any game mode, they should be able to.
User avatar (0013685)
Marcaek (reporter)
2015-10-24 20:04

Absoultely, it's silly to have a flag like this tied to a certain gamemode.
User avatar (0013974)
Dusk (developer)
2015-12-13 02:50

https://bitbucket.org/Torr_Samaho/zandronum/pull-requests/44 [^]
User avatar (0013995)
Torr Samaho (administrator)
2015-12-20 11:15

I added your patch.
User avatar (0014038)
cobalt (updater)
2016-01-03 18:35

Issue addressed by commit ecc905e5d88b: sv_shotgunstart is now respected in non-cooperative gamemodes (fixes 1459)
Committed by Teemu Piippo [Dusk] on Sunday 13 December 2015 04:48:26

Changes in files:

 docs/zandronum-history.txt | 1 +
 src/p_user.cpp | 4 +---
 2 files changed, 2 insertions(+), 3 deletions(-)

User avatar (0014056)
Arco (updater)
2016-01-07 06:41
edited on: 2016-01-07 06:41

Without inputting any weapons for the (T)LMS flags, the shotgun doesn't appear to spawn with you. I'm not sure if this is intentional.

User avatar (0014309)
Marcaek (reporter)
2016-02-04 02:13

Confirmed working in latest offical 3.0. Also worked with Term's Harder mod which replaces stock shotgun.
User avatar (0014326)
Dusk (developer)
2016-02-06 01:19

Quote from "Arco"

Without inputting any weapons for the (T)LMS flags, the shotgun doesn't appear to spawn with you. I'm not sure if this is intentional.

LMS does not respect sv_shotgunstart because it uses its own inventory loadout logic, which is dependent on lmsallowedweapons.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Marcaek Combinebobnt Dark-Assassin StrikerMan780
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2013-08-13 00:13 Marcaek New Issue
2013-08-13 02:46 Watermelon Note Added: 0007005
2013-08-13 02:47 Watermelon Note Edited: 0007005 View Revisions
2013-08-13 22:37 Qent Note Added: 0007016
2013-08-13 22:39 Qent Note Edited: 0007016 View Revisions
2014-06-14 17:39 Watermelon Note Added: 0009318
2014-06-14 17:39 Watermelon Status new => feedback
2015-03-16 14:19 Marcaek Note Added: 0011839
2015-03-16 14:19 Marcaek Status feedback => new
2015-03-16 17:38 Dusk Note Added: 0011844
2015-03-17 03:05 Marcaek Note Added: 0011858
2015-03-20 16:12 Dark-Assassin Note Added: 0011869
2015-10-24 20:04 Marcaek Note Added: 0013685
2015-12-13 02:50 Dusk Note Added: 0013974
2015-12-13 02:50 Dusk Assigned To => Dusk
2015-12-13 02:50 Dusk Status new => needs review
2015-12-20 11:15 Torr Samaho Note Added: 0013995
2015-12-20 11:16 Torr Samaho Status needs review => needs testing
2016-01-03 18:35 cobalt Target Version => 3.0
2016-01-03 18:35 cobalt Note Added: 0014038
2016-01-07 06:41 Arco Note Added: 0014056
2016-01-07 06:41 Arco Status needs testing => feedback
2016-01-07 06:41 Arco Note Edited: 0014056 View Revisions
2016-02-04 02:13 Marcaek Note Added: 0014309
2016-02-04 02:13 Marcaek Status feedback => assigned
2016-02-06 01:19 Dusk Note Added: 0014326
2016-02-06 01:19 Dusk Status assigned => resolved
2016-02-06 01:19 Dusk Fixed in Version => 3.0
2016-02-06 01:19 Dusk Resolution open => fixed
2018-09-30 22:11 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker