Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001209Zandronum[All Projects] Bugpublic2012-12-09 16:452018-09-30 22:05
ReporterZzZombo 
Assigned ToDusk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.0 
Target Version3.0Fixed in Version3.0 
Summary0001209: Banning, kicking and muting by idx
DescriptionIf you invoke ban_idx. kick_idx. kickfromgame_idx, ignore_idx/unignore_idx with idx set to an invalid value the game will perform the given command on player with idx of 0. It can cause troubles if you, for example, ban an innocent because mistyped a single letter in the console.
Steps To ReproduceRun a server, connect a client, then issue some of commands above like "kick_idx q cheater" and see what client will leave the game.
Attached Files

- Relationships

-  Notes
User avatar (0014423)
Dusk (developer)
2016-02-11 17:20

Finally got around to doing this one as well:https://bitbucket.org/Torr_Samaho/zandronum/pull-requests/66 [^]
User avatar (0014439)
Torr Samaho (administrator)
2016-02-14 15:46

Please see my comments on bitbucket.
User avatar (0014502)
cobalt (updater)
2016-02-27 09:46

Issue addressed by commit 4da35534b410: Using a bad player index for the various index-based console commands such as ban_idx now raises an error instead of assuming player 0, fixes 1209
Committed by Teemu Piippo [Dusk] on Wednesday 31 December 1969 23:59:57

Changes in files:

 docs/zandronum-history.txt | 1 +
 src/c_dispatch.cpp | 22 ++++++++++++++++++++++
 src/c_dispatch.h | 3 +++
 src/chat.cpp | 20 ++++++++++++--------
 src/sv_ban.cpp | 18 +++++++++++-------
 src/sv_main.cpp | 16 ++++++++++------
 6 files changed, 59 insertions(+), 21 deletions(-)

User avatar (0014531)
Ru5tK1ng (updater)
2016-03-01 22:21

I tried kicking, banning, ignoring and forcespec by idx with an invalid index and no player was affected. I was given a proper error message in the console.

Seems to be fixed with the latest build.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Combinebobnt
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2012-12-09 16:45 ZzZombo New Issue
2012-12-09 18:58 Dusk Assigned To => Dusk
2012-12-09 18:58 Dusk Status new => assigned
2013-09-27 10:39 Dusk Status assigned => confirmed
2016-02-11 17:20 Dusk Note Added: 0014423
2016-02-11 17:20 Dusk Status confirmed => needs review
2016-02-14 15:46 Torr Samaho Note Added: 0014439
2016-02-14 15:46 Torr Samaho Status needs review => feedback
2016-02-22 19:06 Dusk Status feedback => needs review
2016-02-27 09:46 cobalt Status needs review => needs testing
2016-02-27 09:46 cobalt Target Version => 3.0
2016-02-27 09:46 cobalt Note Added: 0014502
2016-03-01 22:21 Ru5tK1ng Note Added: 0014531
2016-03-01 22:22 Ru5tK1ng Status needs testing => resolved
2016-03-01 22:22 Ru5tK1ng Resolution open => fixed
2016-03-01 22:22 Ru5tK1ng Fixed in Version => 3.0
2018-09-30 22:05 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker