Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003691Doomseeker[All Projects] Bugpublic2019-07-30 10:252019-07-31 04:26
ReporterWubTheCaptain 
Assigned ToBlzut3 
PriorityhighSeveritymajorReproducibilityalways
StatusconfirmedResolutionopen 
PlatformOSDebianOS Versionbullseye/sid
Product Version1.3 
Target VersionFixed in Version 
Summary0003691: DRD Team libwadseeker2 package tries to overwrite libwadseeker1 LICENSE.json
DescriptionAfter upgrading from Doomseeker 1.2 / libwadseeker 1.2 to Doomseeker 1.3 & libwadseeker 2.0 via DRD Team Debian Package Repository, upgrading to libwadseeker 2.0 fails.
Quote
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libwadseeker1
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libwadseeker2
The following NEW packages will be installed:
  libwadseeker2
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
16 not fully installed or removed.
Need to get 0 B/160 kB of archives.
After this operation, 1067 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 127492 files and directories currently installed.)
Preparing to unpack .../libwadseeker2_2.0_amd64.deb ...
Unpacking libwadseeker2 (2.0) ...
dpkg: error processing archive /var/cache/apt/archives/libwadseeker2_2.0_amd64.deb (--unpack):
 trying to overwrite '/usr/share/doc/wadseeker/LICENSE.json', which is also in package libwadseeker1 
1.2
Errors were encountered while processing:
 /var/cache/apt/archives/libwadseeker2_2.0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Assumably this is due to missing Conflicts:/Replaces: or whatever.
Attached Files

- Relationships
related to 0003682closedBlzut3 Doomseeker 1.3 Ubuntu packages need to be released 

-  Notes
User avatar (0020950)
WubTheCaptain (developer)
2019-07-30 16:55

up priority and severity, because it can make the package unusable.

Quote
$ doomseeker
doomseeker: error while loading shared libraries: libwadseeker.so.2: cannot open shared object file: 
No such file or directory


not a block severity, because it can be worked around.
User avatar (0020954)
Blzut3 (administrator)
2019-07-31 04:25

Reuploaded the libwadseeker2 debs with the docs directory fixed to not conflict. This ticket is still relevant as the CMakeLists should be changed as well, but upgrades should be unblocked now.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-07-30 10:25 WubTheCaptain New Issue
2019-07-30 10:25 WubTheCaptain Relationship added related to 0003663
2019-07-30 10:26 WubTheCaptain Relationship added related to 0003682
2019-07-30 10:26 WubTheCaptain Relationship deleted related to 0003663
2019-07-30 16:55 WubTheCaptain Note Added: 0020950
2019-07-30 16:55 WubTheCaptain Priority normal => high
2019-07-30 16:55 WubTheCaptain Severity minor => major
2019-07-31 04:25 Blzut3 Note Added: 0020954
2019-07-31 04:26 Blzut3 Assigned To => Blzut3
2019-07-31 04:26 Blzut3 Status new => confirmed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker