Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003661Doomseeker[All Projects] Bugpublic2019-06-12 01:052019-07-30 10:15
ReporterWubTheCaptain 
Assigned ToWubTheCaptain 
PrioritynormalSeveritytweakReproducibilityhave not tried
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version1.2 
Target Version1.3Fixed in Version 
Summary0003661: Updates to default Wadseeker sites in code are not migrated to existing (not new) configurations
DescriptionIf an user uses Doomseeker/Wadseeker 1.0 and updates to version 1.1 or 1.2, new WAD sites won't be added automatically to configuration (nor old ones will be removed).

I think this is what issue 0003657 was describing.
Additional InformationI leave it undefined what would happen if the user would downgrade software versions.
Attached Files

- Relationships
related to 0003657closedWubTheCaptain Doomseeker Wadseeker missing TSPG Painkiller wad path 

-  Notes
User avatar (0020750)
WubTheCaptain (developer)
2019-06-12 01:06

I'd just leave this as "won't fix", personally. Not a lot to gain from bloating the code base further and dealing with configuration merges (both upgrading and downgrading).

Anyone else want to comment on this?
User avatar (0020752)
WubTheCaptain (developer)
2019-06-12 01:08

What I'd rather do is document in some NEWS file about configuration changes that should be done by the user when upgrading.
User avatar (0020753)
WubTheCaptain (developer)
2019-06-12 01:17

NB:
Quote
have not tried
User avatar (0020758)
Zalewa (developer)
2019-06-13 15:03

There's a "Always use Wadseeker's default sites" checkbox in the "Wadseeker/Sites" config page. If it's checked, Wadseeker will always use the up-to-date hardcoded sites, no matter what's on the list in the config page. If the checkbox is unchecked, only the sites listed on the page are used.

The "Wadseeker/Sites" listing is deliberately left to total control of the user. It's only initialized with the default sites when the config file is first created and then it isn't touched anymore. This was done by design to allow people to control what sites are being contacted in case if some sites stop working and there's no new Wadseeker release to remove them from the list. This removes the necessity to do a new Wadseeker release whenever some page goes 404.

Config auto-migration would strip the control from the user and it'd be prone to causing mistakes or not working exactly correctly if user had modified the site's list by hand.

I think the current options are sufficient to let everyone manage Wadseeker's sites list however they want.

In short: I agree on "won't fix".
User avatar (0020760)
Pol M (developer)
2019-06-13 16:28

Based on Zalewa's comment, I completely agree on "won't fix"

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: WubTheCaptain

- Issue History
Date Modified Username Field Change
2019-06-12 01:05 WubTheCaptain New Issue
2019-06-12 01:05 WubTheCaptain Relationship added related to 0003657
2019-06-12 01:06 WubTheCaptain Note Added: 0020750
2019-06-12 01:08 WubTheCaptain Note Added: 0020752
2019-06-12 01:11 WubTheCaptain Reproducibility always => have not tried
2019-06-12 01:13 WubTheCaptain Summary Updates to default Wadseeker sites in code are not migrated to configuration => Updates to default Wadseeker sites in code are not migrated to existing (not new) configurations
2019-06-12 01:17 WubTheCaptain Note Added: 0020753
2019-06-13 15:03 Zalewa Note Added: 0020758
2019-06-13 16:28 Pol M Note Added: 0020760
2019-06-14 03:50 WubTheCaptain Status new => resolved
2019-06-14 03:50 WubTheCaptain Resolution open => won't fix
2019-06-14 03:50 WubTheCaptain Assigned To => WubTheCaptain
2019-06-14 03:50 WubTheCaptain Target Version => 1.3
2019-07-30 10:15 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker