Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003656Doomseeker[All Projects] Bugpublic2019-06-05 14:332019-06-20 00:19
ReporterPol M 
Assigned ToPol M 
PrioritylowSeverityminorReproducibilitysometimes
StatusresolvedResolutionno change required 
PlatformLinuxOSArchOS Versionx86-64
Product Version1.2 
Target Version1.3Fixed in Version 
Summary0003656: Srb2 player column is broken. They seem overflowed by players with empty names.
DescriptionZalewa once pointed that the srb2 servers were registering incorrect amounts of players, and today I checked that, indeed, they were brocken. The issue can be easily understood with a photo.

The server looks full and there are more players than the limit suggests. While hovering the mouse reveals the name of the connected players, the rest seem empty.
Steps To ReproduceOpen doomseeker, and enable srb2.
Notice that the srb2 player column has impossible amounts of players.
Additional InformationNot all servers are affected. Maybe there is a new release?
Attached Filespng file icon Screenshot_20190605_163131.png [^] (13,425 bytes) 2019-06-05 14:33


png file icon Screenshot_20190605_163514.png [^] (4,854 bytes) 2019-06-05 14:35

- Relationships
child of 0003662confirmed SRB2Kart engine is handled poorly by our SRB2 engine 

-  Notes
User avatar (0020732)
Pol M (developer)
2019-06-06 16:26

Okay, the issue is caused by a new fork of srb2: SRB2Kart.
Now, about what should be done, I'm not that sure. The empty players can be ruled out without problems due to these having absolutely all values set to 0, but I'd say that first we should notify the developers that they are not marking the players as non-existent (for reference, src/plugins/srb2/srb2server.cpp:275, the check is failing due to the node not being 0xff). Also, this is a fork, not the main engine, and leaving as is does not feel right: it requires its own program, and based on the fact that this ticket exists clearly the internet communications may change. Hoping to hear from you on whether we should rule them out, create a new plugin, or else.
User avatar (0020734)
Zalewa (developer)
2019-06-09 19:06

If they don't follow packet compatbility and yet report to the same master server they basically screwed themselves over.

Is there something in the packet that would allow us to recognize that it is from a different game and interpret the packet differently?
User avatar (0020737)
Pol M (developer)
2019-06-09 20:57

Quote from Zalewa

Is there something in the packet that would allow us to recognize that it is from a different game and interpret the packet differently?

Appart from the fact that the players are pretty much empty (score is 0, name is "", seconds in server is 0, etc...) nothing rellevant, the player structure is the same. Maybe they have done a change somewhere that is backwards-compatible? I think that the best idea is to ask. If you're okay with it, I'll contact them.
User avatar (0020759)
Zalewa (developer)
2019-06-13 15:04

Sure, go ahead and contact them :)
User avatar (0020763)
Pol M (developer)
2019-06-13 17:52
edited on: 2019-06-18 09:33

I posted on their bug report thread: post
Issue fixed by Sryder in this PR
I'll also ask if there is an easy way to distinguish both engines, and I'll create a ticket to discuss what should be done with this new engine.

User avatar (0020768)
WubTheCaptain (developer)
2019-06-18 23:47

Since we didn't do anything in Doomseeker code (in this reported issue) to resolve the issue with non-compat packets from pre-PR servers, I'm changing this to "no change required".

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-06-05 14:33 Pol M New Issue
2019-06-05 14:33 Pol M File Added: Screenshot_20190605_163131.png
2019-06-05 14:34 Pol M Description Updated View Revisions
2019-06-05 14:35 Pol M File Added: Screenshot_20190605_163514.png
2019-06-05 14:38 Pol M Additional Information Updated View Revisions
2019-06-05 14:38 Pol M Assigned To => Pol M
2019-06-05 14:38 Pol M Status new => acknowledged
2019-06-05 14:38 Pol M Assigned To Pol M =>
2019-06-05 14:57 Pol M Assigned To => Pol M
2019-06-05 14:57 Pol M Status acknowledged => assigned
2019-06-06 16:26 Pol M Note Added: 0020732
2019-06-09 19:06 Zalewa Note Added: 0020734
2019-06-09 20:57 Pol M Note Added: 0020737
2019-06-12 00:52 WubTheCaptain Reproducibility always => sometimes
2019-06-13 15:04 Zalewa Note Added: 0020759
2019-06-13 17:52 Pol M Note Added: 0020763
2019-06-16 14:07 Pol M Note Edited: 0020763 View Revisions
2019-06-18 09:33 Pol M Note Edited: 0020763 View Revisions
2019-06-18 09:33 Pol M Status assigned => resolved
2019-06-18 09:33 Pol M Fixed in Version => 1.3
2019-06-18 09:33 Pol M Resolution open => fixed
2019-06-18 23:47 WubTheCaptain Note Added: 0020768
2019-06-18 23:47 WubTheCaptain Resolution fixed => no change required
2019-06-18 23:47 WubTheCaptain Fixed in Version 1.3 =>
2019-06-18 23:53 WubTheCaptain Relationship added child of 0003662
2019-06-20 00:19 WubTheCaptain Product Version 1.3 => 1.2






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker