Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003634Zandronum[All Projects] Bugpublic2019-04-21 07:422019-06-05 16:51
ReporterFilystea 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003634: Capital letter or unexisting map - duno
DescriptionI have a map
SOMEMAP.WAD

for server I passed:
SOMEMAP.wad

Obviously there is no such file on my hdd.

The server starts. Master tells me it expects some wads i included but not this one. You know for example the list that doomseeker shows - list of wads you need to join the server. It does not list the SOMEMAP.wad.


BUT

when i join the server i get information I don't have proper wads.
It tells me I need for example 10 wads and I have 10 wads and shows hashes.
After checking all hashes are good. IT EXPECTS ME TO HAVE THAT MISSING WAD IT DOES NOT EVEN LOAD. It's a stupid bug that causes chaos on the client and server side.
Steps To Reproduceit's in description.
Additional InformationToday Jezus resurected.
Attached Files

- Relationships

-  Notes
User avatar (0020522)
WubTheCaptain (reporter)
2019-04-21 15:26

Duplicate of 0002718?
User avatar (0020526)
Filystea (reporter)
2019-04-21 17:06

No the issue is different.
User avatar (0020552)
Edward-san (developer)
2019-04-26 13:45

If I understand correctly, the problem is that the console error doesn't tell you you've loaded an excessive wad file. Is that correct?
User avatar (0020554)
Filystea (reporter)
2019-04-26 21:06

" If I understand correctly, the problem is that the console error doesn't tell you you've loaded an excessive wad file. Is that correct? "

No the problem is server owner made mistake and added to wad files not existing map. But the server never informs it expects it and it also after connection gives info about not passing the requrements. But what it shows is that you actualy pass them you have all maps and the hash is correct.
I could start an example of such server so you can see by your self.
User avatar (0020556)
Torr Samaho (administrator)
2019-04-28 19:23

With a Windows server I can't reproduce this. Is this a Linux only problem?
User avatar (0020717)
Dusk (developer)
2019-06-04 18:41

I cannot reproduce this on Linux either.
User avatar (0020727)
Filystea (reporter)
2019-06-05 16:51

On weekend I will reproduce it again and write down step by step how to do it.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: WubTheCaptain

- Issue History
Date Modified Username Field Change
2019-04-21 07:42 Filystea New Issue
2019-04-21 15:26 WubTheCaptain Note Added: 0020522
2019-04-21 17:06 Filystea Note Added: 0020526
2019-04-26 13:45 Edward-san Note Added: 0020552
2019-04-26 13:45 Edward-san Status new => feedback
2019-04-26 21:06 Filystea Note Added: 0020554
2019-04-26 21:06 Filystea Status feedback => new
2019-04-28 19:23 Torr Samaho Note Added: 0020556
2019-06-04 18:41 Dusk Note Added: 0020717
2019-06-04 20:15 Dusk Priority urgent => normal
2019-06-04 20:15 Dusk Severity block => minor
2019-06-04 20:15 Dusk Status new => feedback
2019-06-04 20:15 Dusk Category Epic => Bug
2019-06-05 16:51 Filystea Note Added: 0020727
2019-06-05 16:51 Filystea Status feedback => new






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker