Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003613Zandronum[All Projects] Bugpublic2019-02-16 19:192019-05-19 19:19
ReporterFilystea 
Assigned ToDusk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003613: Doomseeker shows ip in network byte order? ( big endian )
DescriptionJust as i say.
Just check what ip of your server it will show you.


Smells like doing some stupid hacks instead of using existing functions for it.
Steps To Reproduceuse doomseeker to brows your server - look at the server ip it passes.
Altho when you move mause on the server ip it tells it in correct order.

Attached Filespng file icon 2019-05-14-174911_1920x1080_scrot.png [^] (294,398 bytes) 2019-05-14 15:50

- Relationships

-  Notes
User avatar (0020654)
Pol M (reporter)
2019-05-13 21:39

Okay, first this should go to Doomseeker's project. That aside, are you sure? Looking at the "Address" column, the ips look ok, and hovering over them the ips are the same. If you copy them from the tooltip menu, the ip does not change. Could you please provide an image?
User avatar (0020657)
Filystea (reporter)
2019-05-14 15:50
edited on: 2019-05-14 15:51

Some servers show proper ip some not.

I uploaded pic.

User avatar (0020659)
Pol M (reporter)
2019-05-14 17:44
edited on: 2019-05-14 17:54

Thank you, I'll take a look. Hopefully someone can move this ticket to the doomseeker project.

EDIT: Actually, that is the correct ip, but the url has the ip on it and it is reversed there. If you were trying to point that out, then nothing needs to be done, since the url correctly points to the expected ip.

User avatar (0020660)
Filystea (reporter)
2019-05-14 21:19

Yeah. Did some play with dig. Everything works.
This trolled when i first saw it.

Anyway you can lock this. I was mistaken. Everything is fine.
User avatar (0020661)
Pol M (reporter)
2019-05-14 23:29

No problem then :P
This ticket can be resolved.
User avatar (0020670)
Dusk (developer)
2019-05-19 19:11

This has nothing to do with Doomseeker. Some hostnames show the IP address within the hostname in reverse order.

$ host static.116.2.251.148.clients.your-server.de
static.116.2.251.148.clients.your-server.de has address 148.251.2.116

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2019-02-16 19:19 Filystea New Issue
2019-05-13 21:39 Pol M Note Added: 0020654
2019-05-14 15:50 Filystea File Added: 2019-05-14-174911_1920x1080_scrot.png
2019-05-14 15:50 Filystea Note Added: 0020657
2019-05-14 15:51 Filystea Note Edited: 0020657 View Revisions
2019-05-14 17:44 Pol M Note Added: 0020659
2019-05-14 17:54 Pol M Note Edited: 0020659 View Revisions
2019-05-14 21:19 Filystea Note Added: 0020660
2019-05-14 23:29 Pol M Note Added: 0020661
2019-05-19 19:11 Dusk Note Added: 0020670
2019-05-19 19:11 Dusk Status new => resolved
2019-05-19 19:11 Dusk Resolution open => no change required
2019-05-19 19:11 Dusk Assigned To => Dusk
2019-05-19 19:19 Dusk Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker