Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003547Doomseeker[All Projects] Bugpublic2018-10-08 11:332018-10-27 22:53
ReporterWubTheCaptain 
Assigned ToPol M 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003547: updateinstaller: URL with HTTP scheme in src/AppInfo.cpp
Descriptiondoomseeker.drdteam.org supports HTTPS these days.

Commit 6e4d1b8a6b7339a353619b3f740e972f57187068u (0003267) changed most URLs to HTTPS, but didn't with this one.
Steps To Reproducetools/updateinstaller/src/AppInfo.cpp

The error message with HTTP scheme will be also displayed if the update fails to install for whatever the reason.
Attached Files

- Relationships

-  Notes
User avatar (0020016)
WubTheCaptain (developer)
2018-10-08 11:45
edited on: 2018-10-08 11:50

Out of spite or my hatred toward Mendeley Updater, this will not get a patch from me personally. ๐Ÿ™…โ€โ™€๏ธ

User avatar (0020017)
Pol M (developer)
2018-10-08 19:41
edited on: 2018-10-08 19:58

Simply replace http for https? ๐Ÿคจ
if that's it, this should do:https://bitbucket.org/Doomseeker/doomseeker/pull-requests/35/updateinstaller-replace-http-with-https-in/diff [^]

User avatar (0020019)
Pol M (developer)
2018-10-08 20:27

Commit
I'm leaving as "needs tesing" since I can't test it myself. It's just a 1 character change, so it really could be simply set as resolved ๐Ÿ˜Š
User avatar (0020021)
Zalewa (developer)
2018-10-08 20:33

PR merged.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: WubTheCaptain

- Issue History
Date Modified Username Field Change
2018-10-08 11:33 WubTheCaptain New Issue
2018-10-08 11:45 WubTheCaptain Note Added: 0020016
2018-10-08 11:50 WubTheCaptain Note Edited: 0020016 View Revisions
2018-10-08 19:41 Pol M Note Added: 0020017
2018-10-08 19:41 Pol M Assigned To => Pol M
2018-10-08 19:41 Pol M Status new => assigned
2018-10-08 19:58 Pol M Note Edited: 0020017 View Revisions
2018-10-08 20:02 WubTheCaptain Status assigned => needs review
2018-10-08 20:02 WubTheCaptain Target Version => 1.2
2018-10-08 20:27 Pol M Note Added: 0020019
2018-10-08 20:27 Pol M Status needs review => needs testing
2018-10-08 20:33 Zalewa Note Added: 0020021
2018-10-08 20:33 Zalewa Status needs testing => resolved
2018-10-08 20:33 Zalewa Fixed in Version => 1.2
2018-10-08 20:33 Zalewa Resolution open => fixed
2018-10-27 22:53 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker