Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003514Doomseeker[All Projects] Epicpublic2018-09-23 00:012019-07-30 10:13
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.1 
Target Version1.3Fixed in Version1.3 
Summary0003514: Drop support for compiling with Qt4 (in favor of Qt5+)
DescriptionIn ticket 0003503 AOSP questioned why Doomseeker is still supporting Qt4, which hasn't received updates in many years. It's also not technically supported by Doomseeker since release 1.1.

A benefit of dropping Qt4 outright would be "better ability to use C++11/14", according to Blzut3.
Additional InformationCreating this ticket, so that discussion in ticket 0003503 doesn't get lost and this ticket becomes searchable for answers.

Qt4 is required to use Doomseeker on OpenBSD, until 0003494 is resolved.
Attached Files

- Relationships
related to 0003494closedPol M Master server connections timeout on OpenBSD (UDP packets not sent on Qt5) 
related to 0003542closedPol M No CXX_STANDARD defined in CMake build files 
related to 0003581closedPol M Version::operatingSystem() knows only about three operating systems (Windows, Linux & Mac) 
related to 0003595closedZalewa Contributor documentation is not yet available 

-  Notes
User avatar (0019676)
WubTheCaptain (developer)
2018-09-23 00:01

Closing for obvious reasons, this has been discussed. Reopen once more relevant.
User avatar (0020447)
Pol M (developer)
2019-03-19 17:08
edited on: 2019-03-19 17:47

(Reopening)
So, right now Doomseeker does not compile in qt4. While probably I could try to patch it, I'd honestly consider dropping support for qt4. I understand that unsupported platforms seem to rely on it (0003494 though I'd need to test it based on the last comment.), but considering that we're now working to bump the C++ standard and that also Windows is no longer an issue, I think it's the right time :)

User avatar (0020448)
WubTheCaptain (developer)
2019-03-19 18:59

Ok for me to drop Qt4.
User avatar (0020449)
WubTheCaptain (developer)
2019-03-19 19:01

Quote from Pol M
(0003494 though I'd need to test it based on the last comment.)


The author of that comment tested it to be working with Qt4, but said "nevermind" because the issue was reproducible with Qt5 only.
User avatar (0020683)
Pol M (developer)
2019-05-20 15:45

Just to keep the relevant information on this topic up-to-date: the unsupported platforms no longer need qt4 to use doomseeker, meaning that right now there is no longer a reason to still support compiling in qt4.
User avatar (0020684)
Zalewa (developer)
2019-05-21 15:11

Removing Qt4 is fine by me too.

Blzut?
User avatar (0020703)
WubTheCaptain (developer)
2019-05-30 05:50

(Wedging this issue back to Pol M for assignment, while subscribing Blzut3 to this ticket for an answer to get its status "confirmed" or rejected. The "feedback" status would be wrong, because it asks for feedback from the reporter inappropriately in this situation.)
User avatar (0020807)
Blzut3 (administrator)
2019-06-22 19:57

Go ahead! As noted in the ticket description I've said that Qt4 was unsupported since 1.1 was released, and that we just lacked an excuse to go out of our way to rip it out. We have that now.
User avatar (0020831)
Pol M (developer)
2019-06-25 10:51

I think that the best approach will be to remove the option from the cmake scripts. I could go on to remove the #ifdef conditions, but I don't think that's necessary. Of course, if you consider that removing them is needed, I'll do so.
User avatar (0020832)
Blzut3 (administrator)
2019-06-25 10:58

It would be a good idea to just rip the band aid off and get rid of the ifdefs as well. They should be easy to find by searching for QT_VERSION and there's only tens of them. Otherwise they'll just linger around forever.
User avatar (0020833)
Pol M (developer)
2019-06-25 10:59

Ok, will comply :)
User avatar (0020834)
Pol M (developer)
2019-06-25 14:11
edited on: 2019-06-25 14:24

Pr coming, what will be missing will be the mac scripts (I have no mac to test the scripts on, so I'll leave that to someone with easier access to one) and the docker image. The reason I have not changed the docker image is because Ubuntu 14.04 is no longer on support, and we should move to 16.04. This will probably allow us to bump even more the C++ standard and who knows what else, so I decided to create a ticket for this and consider my job on this ticket done :)

EDIT: PR

User avatar (0020835)
Zalewa (developer)
2019-06-25 16:00

Commits in red feel good.

There's also a tools/wadseekerapp/ that still links with Qt4. If you wish you can take care of that too, Pol. Otherwise reassign the ticket to me and I'll take care of the Docker image.
User avatar (0020836)
Pol M (developer)
2019-06-25 16:06

Ok :)
User avatar (0020853)
Zalewa (developer)
2019-06-30 10:47

WadseekerApp has been updated here, which makes this ticket done.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Zalewa WubTheCaptain
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-09-23 00:01 WubTheCaptain New Issue
2018-09-23 00:01 WubTheCaptain Note Added: 0019676
2018-09-23 00:01 WubTheCaptain Status new => closed
2018-09-23 00:01 WubTheCaptain Resolution open => denied
2018-09-29 16:19 WubTheCaptain Resolution denied => suspended
2018-12-17 04:39 WubTheCaptain Relationship added related to 0003581
2019-03-19 17:08 Pol M Note Added: 0020447
2019-03-19 17:08 Pol M Relationship added related to 0003494
2019-03-19 17:09 Pol M Relationship added related to 0003542
2019-03-19 17:10 Pol M Assigned To => Pol M
2019-03-19 17:10 Pol M Status closed => feedback
2019-03-19 17:10 Pol M Resolution suspended => reopened
2019-03-19 17:47 Pol M Note Edited: 0020447 View Revisions
2019-03-19 18:59 WubTheCaptain Note Added: 0020448
2019-03-19 18:59 WubTheCaptain Status feedback => assigned
2019-03-19 18:59 WubTheCaptain Status assigned => acknowledged
2019-03-19 19:01 WubTheCaptain Note Added: 0020449
2019-05-20 15:45 Pol M Note Added: 0020683
2019-05-21 15:11 Zalewa Note Added: 0020684
2019-05-27 16:53 Zalewa Assigned To Pol M => Blzut3
2019-05-27 16:53 Zalewa Status acknowledged => feedback
2019-05-30 05:50 WubTheCaptain Note Added: 0020703
2019-05-30 05:50 WubTheCaptain Status feedback => assigned
2019-05-30 05:50 WubTheCaptain Assigned To Blzut3 => Pol M
2019-05-30 05:50 WubTheCaptain Status assigned => acknowledged
2019-05-30 06:12 WubTheCaptain Target Version => 1.3
2019-06-22 19:57 Blzut3 Note Added: 0020807
2019-06-22 19:58 Blzut3 Status acknowledged => confirmed
2019-06-23 02:36 WubTheCaptain Relationship added related to 0003595
2019-06-25 10:51 Pol M Note Added: 0020831
2019-06-25 10:58 Blzut3 Note Added: 0020832
2019-06-25 10:59 Pol M Note Added: 0020833
2019-06-25 11:00 Pol M Status confirmed => assigned
2019-06-25 14:11 Pol M Note Added: 0020834
2019-06-25 14:24 Pol M Note Edited: 0020834 View Revisions
2019-06-25 14:24 Pol M Status assigned => needs review
2019-06-25 16:00 Zalewa Note Added: 0020835
2019-06-25 16:06 Pol M Note Added: 0020836
2019-06-25 16:06 Pol M Assigned To Pol M => Zalewa
2019-06-25 16:06 Pol M Status needs review => assigned
2019-06-30 10:47 Zalewa Note Added: 0020853
2019-06-30 10:47 Zalewa Status assigned => resolved
2019-06-30 10:47 Zalewa Fixed in Version => 1.3
2019-06-30 10:47 Zalewa Resolution reopened => fixed
2019-06-30 11:48 WubTheCaptain Category Suggestion => Epic
2019-07-30 10:13 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker