Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003505Doomseeker[All Projects] Suggestionpublic2018-09-22 13:112018-10-27 22:54
ReporterZalewa 
Assigned ToZalewa 
PrioritynormalSeveritytweakReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003505: Allow to create offline game that starts into the title screen
DescriptionCreate Game box allows to create an offline game already, however possibilities to limit what arguments are passed from the box to the game are rather... limited. It is impossible to start a game into the title screen - the game will always start directly into the map.

User should be able to disable certain settings, thus allowing the game to start with minimal initial setup. Various games may have different requirements here, however some settings should be made optional. This will allow the user to leave it up to the game to decide what these settings should be.

The settings that need to be optional (and currently aren't) are: "game mode" and "skill".
Additional InformationIt would be great if Doomseeker could serve as a PWAD launcher where one only picks the PWADs and launches the game without any particular configuration. Being able to start into the title screen is an important part of that.
Attached Files

- Relationships
related to 0003480confirmed Optional simplification of Create Game box 

-  Notes
User avatar (0019632)
Zalewa (developer)
2018-09-22 13:42

Resolved at least for Zandronum with these commits:

1.https://bitbucket.org/Doomseeker/doomseeker/commits/d98a26168bf74cd110251cc202e33fc3d4cffa4b [^]
2.https://bitbucket.org/Doomseeker/doomseeker/commits/d5437a9d8006b79738be14aba19bb8c248ac45a7 [^]
3.https://bitbucket.org/Doomseeker/doomseeker/commits/5b97492c75e92193445a21dccb492628414c5251 [^]
4.https://bitbucket.org/Doomseeker/doomseeker/commits/5b1b0ceebaaca850e72386f298216bb1b0db44aa [^]
User avatar (0019645)
WubTheCaptain (developer)
2018-09-22 17:44

Not related, but I would also nudge you towards an ancient ticket 0002204.
User avatar (0019786)
WubTheCaptain (developer)
2018-09-27 03:13

Not sure if I would've personally preferred there to be a checkbox or two radio buttons in "Doomseeker – Copy Text" (command line dialog) to switch between offline and online commands. The current approach takes more horizontal space in the Create Game dialog.

"Offline command line" and "Host command line" have the same tooltip. Is this intentional?

I don't really get it, though. The "Create Game" dialog only has one executable path, mostly independent of the Configuration menu. The default for Zandronum is /usr/bin/zandronum-server on my system, but obviously this won't work for offline play because that binary is headless. Clicking the button named "Default" next to the path also resets it to /usr/bin/zandronum-server.

In other words, I expected "offline command line" to use the client executable and "host command line" to use the server executable from configuration. That's not the case here, with additional mixed confusion what the purpose of "Executable" in Create Game now serves purpose for.

(Just as I wrote this, I noticed the "Executable" is a dropdown menu for both client and server executables from configuration. It's not user friendly though, after initial confusion.)

Besides that, Zandronum offline launches to title screen as you've wanted.
User avatar (0019794)
Zalewa (developer)
2018-09-28 19:03
edited on: 2018-09-28 19:33

Quote from Wub

Not sure if I would've personally preferred there to be a checkbox or two radio buttons in "Doomseeker – Copy Text" (command line dialog) to switch between offline and online commands. The current approach takes more horizontal space in the Create Game dialog.

[...]

I expected "offline command line" to use the client executable and "host command line" to use the server executable from configuration. That's not the case here, with additional mixed confusion what the purpose of "Executable" in Create Game now serves purpose for.


I was actually considering some radio button, check box or combo box that would switch between modes but couldn't think of anything that would fit the whole dialog box as it is in its current state. This further emphasizes the need to simplify this dialog box as described in 0003480 and more. I will add a point to that ticket about reworking the offline/server duality of the Create Game dialog.

Quote from Wub

"Offline command line" and "Host command line" have the same tooltip. Is this intentional?


No, that's certainly an oversight. Thanks. In the process of doing 0003480 this button may eventually be removed, but I've amended this tooltip regardless just in case:https://bitbucket.org/Doomseeker/doomseeker/commits/1a55359fed00d2c35d6fd2aba1c436663175cbe8 [^]

Quote from Wub

(Just as I wrote this, I noticed the "Executable" is a dropdown menu for both client and server executables from configuration. It's not user friendly though, after initial confusion.)


This is useful when you have Zandronum testing binaries installed as the drop down menu will list them too.

Quote from Wub

Besides that, Zandronum offline launches to title screen as you've wanted.


Since that's what this ticket was about, I'll mark it as resolved (I also checked Odamex and Chocolate Doom).


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-09-22 13:11 Zalewa New Issue
2018-09-22 13:11 Zalewa Status new => assigned
2018-09-22 13:11 Zalewa Assigned To => Zalewa
2018-09-22 13:12 Zalewa Relationship added related to 0003480
2018-09-22 13:13 Zalewa Relationship added related to 0003483
2018-09-22 13:17 Zalewa Description Updated View Revisions
2018-09-22 13:42 Zalewa Note Added: 0019632
2018-09-22 13:43 Zalewa Status assigned => needs review
2018-09-22 13:59 Zalewa Description Updated View Revisions
2018-09-22 15:39 WubTheCaptain Relationship replaced child of 0003480
2018-09-22 16:01 WubTheCaptain Relationship replaced related to 0003480
2018-09-22 17:44 WubTheCaptain Note Added: 0019645
2018-09-23 07:46 Zalewa Status needs review => needs testing
2018-09-27 03:13 WubTheCaptain Note Added: 0019786
2018-09-27 03:13 WubTheCaptain Status needs testing => needs review
2018-09-28 19:03 Zalewa Note Added: 0019794
2018-09-28 19:04 Zalewa Note Edited: 0019794 View Revisions
2018-09-28 19:05 Zalewa Status needs review => resolved
2018-09-28 19:05 Zalewa Fixed in Version => 1.2
2018-09-28 19:05 Zalewa Resolution open => fixed
2018-09-28 19:33 Zalewa Note Edited: 0019794 View Revisions
2018-10-01 04:03 WubTheCaptain Relationship deleted related to 0003483
2018-10-27 22:54 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker