Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003483Doomseeker[All Projects] Suggestionpublic2018-09-01 12:042018-10-27 22:51
ReporterZalewa 
Assigned ToBlzut3 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003483: Doomseeker 1.2 release
DescriptionLet's make a stable 1.2 release of Doomseeker.
Additional InformationChildren of this ticket should be resolved before the release happens.
Attached Files

- Relationships
related to 0003246confirmedWubTheCaptain Doomseeker Debian packaging. 
related to 0003486closedPol M Doomseeker Translate Doomseeker to Spanish 
related to 0003561resolvedBlzut3 Site debian.drdteam.org: Broken Doomseeker 1.2 package (missing libwadseeker 1.2 dependency) 
parent of 0003237closedWubTheCaptain Doomseeker Non-free files and copyright issues in source archive 
parent of 0003275closedBlzut3 Doomseeker Sign tarball releases with OpenPGP keys 
parent of 0003517resolvedWubTheCaptain Doomseeker Doomseeker 1.2 changelog (meta) 

-  Notes
User avatar (0019473)
WubTheCaptain (developer)
2018-09-01 12:04
edited on: 2018-09-01 12:10

Is it a good time to release a new version now or soon? I'll add blocking tickets as children.

User avatar (0019475)
Zalewa (developer)
2018-09-01 12:44

The changelog is full of nice things already, so I'd err on saying "probably yes" to the release. I'll probably work some more during the upcoming week on other tickets so that they can get into the release too.
User avatar (0019513)
Pol M (developer)
2018-09-12 00:32

I'm getting close to finishing the translation to Spanish of core. Maybe we could consider marking the ticket as related to this one, as it would be nice to ship the next release with the new language.
User avatar (0019519)
AOSP (reporter)
2018-09-13 18:11

Any chance of 0003369 being implemented in Doomseeker for 1.2? It's still a wanted feature.
User avatar (0019538)
WubTheCaptain (developer)
2018-09-18 11:44

I don't like tickets such as 0003482, 0003480, 0003479, 0003486 and 0003369 being marked as "related" to this ticket. I'd opt to use "Target version" in MantisBT instead, which adds them to roadmap.

0003246 has a legitimate reason to be "related" to this ticket; While not blocking, a release would help the packaging process. That ticket also has no target version, for more or less obvious reasons.
User avatar (0019595)
WubTheCaptain (developer)
2018-09-21 14:24

0003267#c18962, 2017-10-02

Quote from Blzut3
My plan was to propose a 1.2 release after most of WubTheCaptain's tickets were resolved. Although I don't know how many weeks that will take.


😂 (oh, and new tickets keep flooding in.)
User avatar (0019633)
WubTheCaptain (developer)
2018-09-22 15:45

Please, stop adding more related tickets. Remove them all. Remove 0003481. Use the roadmap / target version in MantisBT. I'm losing it. 😠

Remove or close this ticket even.
User avatar (0019634)
WubTheCaptain (developer)
2018-09-22 15:45

Reopen once 1.2 really makes sense.
User avatar (0019635)
WubTheCaptain (developer)
2018-09-22 15:51
edited on: 2018-09-22 15:52

And please: Give some estimate for 1.2 code freeze. I have an opinion that too many features and bugs are going in to a too big of a 1.2 release.

Go to the roadmap, designate something unresolved for a later release.

User avatar (0019637)
WubTheCaptain (developer)
2018-09-22 15:58

Quote from WubTheCaptain
Go to the roadmap, designate something unresolved for a later release.


I liberally removed 0003295, 0003503, 0003246 and 0003247 from the 1.2 roadmap.
User avatar (0019638)
Zalewa (developer)
2018-09-22 15:59

Very well then, we should not try to cram everything that's possible into 1.2. I will however try to put into that release all the tickets that are currently in relation, plus any fixes for bugs that are currently known, affect currently supported platforms and can be fixed without too much hassle.

That said, I'm altering the "Additional Information" section of this ticket to reflect its new purpose. To relieve you of receiving emails each time something is altered in this ticket, I'm also changing the reporter to myself.
User avatar (0019639)
Zalewa (developer)
2018-09-22 16:03

Blzut, we normally discuss releases through PMs, but since this ticket is already here, what's your view on the release? Considering that 1.1 was released over a year ago and changelog has substantial amount of items, I think the time is about right.
User avatar (0019640)
WubTheCaptain (developer)
2018-09-22 16:43

Quote from Zalewa
That said, I'm altering the "Additional Information" section of this ticket to reflect its new purpose.


Okay, off-topic noise here.

I slightly disagree with its new purpose of tickets which "should be resolved before the release happens". My interpretations of using MantisBT are as follows:

For wishlist features such as 0003481, status to "confirmed" or higher, target version to "1.2" in MantisBT. Find it from the roadmap page. I've done this now, but I've not yet removed the child from this ticket to not offend you or engage in an editwar.

For other wishlist features, such as those "related": They have no apparent priority to be fixed or included at this time. They have a "product version", since when the bug has existed. Change the priority, or assign them to a person with a target release such as 1.2. If there's no estimate, acknowledge, confirm or assign the issue and remove the target release. "Known issues".

I find 0003294 and 0003237 to be release-critical; they're children of this ticket, severity "blocking", target version "1.2", status any.

0003246 is a special case of a "related" ticket: If it aimed for 1.2 release, it actually makes most sense to do from a tarball release, not from Mercurial source. So, it actually has to be done post-release. Therefore it's "related", not a "child". It also gives the reporter of 0003246 and monitoring users a notification of a new release.

Maybe this ticket should be a "child" of 0003246 then, you ask? Nevermind that may look a bit silly on the roadmap. Problems with this is that 0003246 has no target version (yet). It could be that Doomseeker 1.2.1 or 1.3+ gets released and this ticket will... not make much sense for a "child"? (Maybe it does, I'm losing it.)

0003246, 0003247 and 0003295: Those are assigned to me, and I have no motivation to fix them right now. It sucks. So, I've removed them from the 1.2 roadmap. They're known issues. (Such known issues can also be noted in release notes for 1.2.) Anyone can take assignment over them though, if that person or group of people is so motivated to get it into 1.2.

Now I'm losing coherency in my typing, so I'll stop.
User avatar (0019659)
Blzut3 (administrator)
2018-09-22 21:40

Since I don't know when I'll have enough time to fix 0003294 given everything else I'm trying to do these days, I think it's worth considering doing a 1.2 release without the auto updater for Mac. That way you're not all held back by me, and we can always reintroduce it later.

If that sounds like a good plan then lets give Pol M time to finish his Spanish translation and focus on getting our distribution cleaned up and ready to go. WubTheCaptain, do you have time to determine if there's actually anything left in 0003237 that needs to be finished? The new 0003509 aside of course.
User avatar (0019661)
WubTheCaptain (developer)
2018-09-22 21:46
edited on: 2018-09-22 21:47

Quote from Blzut3
WubTheCaptain, do you have time to determine if there's actually anything left in 0003237 that needs to be finished?


I've sent Zalewa an email today about feeling burnt out in past few days. Right now I'd honestly prefer someone else to do the hard work, and let me confirm their results. We'll see how I'll do...

User avatar (0019663)
Blzut3 (administrator)
2018-09-22 21:53

At this point the ticket honestly looks like it's in the "you tell me if it's done" state. From what I can tell it looks like everything that we can do at this point is done, so perhaps the best course of action is to close out that ticket and open a new one if you discover more issues when your motivation returns.
User avatar (0019665)
WubTheCaptain (developer)
2018-09-22 21:57

Quote from Blzut3
perhaps the best course of action is to close out that ticket and open a new one if you discover more issues when your motivation return


I'll do a this right now, after skimming through it quickly for any apparent issues.
User avatar (0019666)
Zalewa (developer)
2018-09-22 21:57

Blzut's proposition sounds sensible to me.
User avatar (0019680)
Pol M (developer)
2018-09-23 00:43
edited on: 2018-09-23 00:43

Quote from Blzut3
If that sounds like a good plan then lets give Pol M time to finish his Spanish translation and focus on getting our distribution cleaned up and ready to go.


I'll focus for the moment in the translation to get that out of the way. :)

User avatar (0019800)
WubTheCaptain (developer)
2018-09-29 02:06

Even though I'm creating new issue tickets almost everyday, I think not all known issues should be resolved in 1.2 but acknowledged in release notes as known issues. I'd propose releasing 1.2-rc1 first, or 1.2, then fix known issues in a smaller patch release such as 1.2.1 with no new features.
User avatar (0019801)
WubTheCaptain (developer)
2018-09-29 02:11

Quote from AOSP
Any chance of 0003369 being implemented in Doomseeker for 1.2? It's still a wanted feature.


I'm also opposed to implementing this in 1.2 to keep the scope of release and possible bugs smaller. For version 1.3, maybe. (Hopefully with more frequent releases between Doomseeker versions, which don't take over a year.)
User avatar (0019802)
Blzut3 (administrator)
2018-09-29 04:49

0003369 is definitely too complicated to implement into 1.2 with the current release plan.
User avatar (0020101)
WubTheCaptain (developer)
2018-10-13 16:41
edited on: 2018-10-13 16:45

If 0003247 is not a child and resolved, it will create a Lintian warning binary-without-manpage due to missing man page.

User avatar (0020115)
Zalewa (developer)
2018-10-13 19:40

I've looked through the list of issues and unless I missed something I think all that we currently have falls into the general category of "can be done later", with possible exception of 0003548 as it directly affects the release process (though the IpToCountry.dat can just be bundled in manually for the 1.2 release).

Is everything ready for the release? Can we start doing it?
User avatar (0020117)
Pol M (developer)
2018-10-13 20:05

I have no objections. Most stuff is ready, the translations are up-to-date and apart from 3548 the 3 remaining tickets are in "needs review", looking good and not being essential for the release per se.
User avatar (0020119)
Blzut3 (administrator)
2018-10-13 21:25

Yeah I think we're just about done here. Targeting the 27th for release. Would do next week, but I won't be available that weekend.
User avatar (0020157)
WubTheCaptain (developer)
2018-10-27 22:13

Debian packages, see Site project issue 0003561.
User avatar (0020164)
WubTheCaptain (developer)
2018-10-27 22:51

Dunno what else there is to do, so I guess this is resolved. Thanks, all.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Zalewa WubTheCaptain Pol M
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2018-09-01 12:04 WubTheCaptain New Issue
2018-09-01 12:04 WubTheCaptain Note Added: 0019473
2018-09-01 12:05 WubTheCaptain Relationship added parent of 0003237
2018-09-01 12:05 WubTheCaptain Relationship added parent of 0003294
2018-09-01 12:08 WubTheCaptain Relationship added related to 0003246
2018-09-01 12:10 WubTheCaptain Note Edited: 0019473 View Revisions
2018-09-01 12:13 WubTheCaptain Additional Information Updated View Revisions
2018-09-01 12:44 Zalewa Note Added: 0019475
2018-09-10 05:29 Zalewa Relationship added parent of 0003481
2018-09-10 05:29 Zalewa Relationship added related to 0003482
2018-09-10 05:30 Zalewa Relationship added related to 0003480
2018-09-10 05:30 Zalewa Relationship added related to 0003479
2018-09-12 00:32 Pol M Note Added: 0019513
2018-09-12 15:29 Zalewa Relationship added related to 0003486
2018-09-13 18:11 AOSP Note Added: 0019519
2018-09-13 20:08 Zalewa Relationship added related to 0003369
2018-09-18 11:41 WubTheCaptain Status new => acknowledged
2018-09-18 11:44 WubTheCaptain Note Added: 0019538
2018-09-21 14:24 WubTheCaptain Note Added: 0019595
2018-09-22 13:13 Zalewa Relationship added related to 0003505
2018-09-22 15:45 WubTheCaptain Note Added: 0019633
2018-09-22 15:45 WubTheCaptain Note Added: 0019634
2018-09-22 15:45 WubTheCaptain Status acknowledged => closed
2018-09-22 15:45 WubTheCaptain Resolution open => suspended
2018-09-22 15:51 WubTheCaptain Note Added: 0019635
2018-09-22 15:52 WubTheCaptain Note Edited: 0019635 View Revisions
2018-09-22 15:52 WubTheCaptain Note Edited: 0019635 View Revisions
2018-09-22 15:58 WubTheCaptain Note Added: 0019637
2018-09-22 15:59 Zalewa Note Added: 0019638
2018-09-22 15:59 Zalewa Reporter WubTheCaptain => Zalewa
2018-09-22 15:59 Zalewa Status closed => assigned
2018-09-22 15:59 Zalewa Additional Information Updated View Revisions
2018-09-22 16:03 Zalewa Note Added: 0019639
2018-09-22 16:12 WubTheCaptain Resolution suspended => reopened
2018-09-22 16:43 WubTheCaptain Note Added: 0019640
2018-09-22 21:40 Blzut3 Note Added: 0019659
2018-09-22 21:46 WubTheCaptain Note Added: 0019661
2018-09-22 21:47 WubTheCaptain Note Edited: 0019661 View Revisions
2018-09-22 21:53 Blzut3 Note Added: 0019663
2018-09-22 21:57 WubTheCaptain Note Added: 0019665
2018-09-22 21:57 Zalewa Note Added: 0019666
2018-09-22 22:57 Blzut3 Relationship deleted parent of 0003294
2018-09-23 00:43 Pol M Note Added: 0019680
2018-09-23 00:43 Pol M Note Edited: 0019680 View Revisions
2018-09-24 01:15 Blzut3 Relationship added related to 0003275
2018-09-24 18:20 WubTheCaptain Relationship added parent of 0003517
2018-09-29 02:06 WubTheCaptain Note Added: 0019800
2018-09-29 02:11 WubTheCaptain Note Added: 0019801
2018-09-29 04:49 Blzut3 Note Added: 0019802
2018-09-29 04:51 Blzut3 Relationship deleted related to 0003369
2018-09-30 13:06 Zalewa Relationship deleted related to 0003480
2018-10-01 03:40 WubTheCaptain Relationship replaced related to 0003481
2018-10-01 03:56 WubTheCaptain Relationship deleted related to 0003479
2018-10-01 03:59 WubTheCaptain Relationship deleted related to 0003482
2018-10-01 04:01 WubTheCaptain Relationship deleted related to 0003505
2018-10-01 04:05 WubTheCaptain Relationship replaced parent of 0003275
2018-10-01 05:30 WubTheCaptain Severity minor => feature
2018-10-13 16:39 WubTheCaptain Relationship deleted related to 0003481
2018-10-13 16:41 WubTheCaptain Note Added: 0020101
2018-10-13 16:45 WubTheCaptain Note Edited: 0020101 View Revisions
2018-10-13 19:40 Zalewa Note Added: 0020115
2018-10-13 19:40 Zalewa Status assigned => feedback
2018-10-13 20:05 Pol M Note Added: 0020117
2018-10-13 21:25 Blzut3 Note Added: 0020119
2018-10-14 13:04 WubTheCaptain Assigned To => Blzut3
2018-10-14 13:04 WubTheCaptain Status feedback => assigned
2018-10-27 21:57 WubTheCaptain Status assigned => needs review
2018-10-27 22:12 WubTheCaptain Relationship added related to 0003561
2018-10-27 22:13 WubTheCaptain Note Added: 0020157
2018-10-27 22:51 WubTheCaptain Note Added: 0020164
2018-10-27 22:51 WubTheCaptain Status needs review => resolved
2018-10-27 22:51 WubTheCaptain Fixed in Version => 1.2
2018-10-27 22:51 WubTheCaptain Resolution reopened => fixed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker