Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003299Doomseeker[All Projects] Suggestionpublic2017-10-10 09:382017-10-14 05:30
ReporterWubTheCaptain 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionnot fixable 
PlatformOSOS Version
Product Version1.1 
Target VersionFixed in Version 
Summary0003299: Wadseeker: Hook into CMake's FindLibLZMA module
DescriptionIt'd be nice (and also required for Debian) if Wadseeker could be built using system libraries instead of the LZMA SDK convenience copy located at src/wadseeker/lzma.

CMake's FindLibLZMA should be able to do this. We already use FindBZip2 and FindZLIB.
Additional InformationI hope they're compatible. There's two different libraries for lzma in Debian: lzma-dev and liblzma5/liblzma-dev.

https://cmake.org/cmake/help/latest/module/FindLibLZMA.html [^]
Attached Files

- Relationships
child of 0003246assignedWubTheCaptain Debian packaging. 

-  Notes
User avatar (0018523)
Blzut3 (administrator)
2017-10-10 23:11

liblzma and the LZMA SDK are two different things. The LZMA SDK also implements the 7z file format which we use.
User avatar (0018526)
WubTheCaptain (developer)
2017-10-11 04:04

lzma-dev package (depending on zlib1g-dev for some reason) is "experimental" and to be replaced by the library, but it seems to be the LZMA SDK headers. lzma package is the command line utility.

Could this be used for 7z?
User avatar (0018548)
Blzut3 (administrator)
2017-10-12 23:44

That is a strange package. Without the library the header files are useless. It's also apparently abandoned as it hasn't been updated in a long time. No LZMA2 support for example.
User avatar (0018549)
WubTheCaptain (developer)
2017-10-13 05:57
edited on: 2017-10-13 06:02

Blzut3, thank you for the information.

I would quickly guess this is for PK7 format (ZDoom game data, renamed .7z extension), and as such invalid or not fixable at the moment? This ticket can be closed, if so.

User avatar (0018550)
Blzut3 (administrator)
2017-10-14 05:29

No it's for extracting mods out of regular 7z archives. Wadseeker also supports zip, tar, tar.gz, and tar.bz2. (Suppose we could also support tar.xz, but the reason we have the tar file support is to piggy back off it for the Zandronum testing binary download and extract. Really we expect mods to be in zip or 7z files.)

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-10-10 09:38 WubTheCaptain New Issue
2017-10-10 09:38 WubTheCaptain Relationship added child of 0003246
2017-10-10 23:11 Blzut3 Note Added: 0018523
2017-10-11 04:04 WubTheCaptain Note Added: 0018526
2017-10-12 23:44 Blzut3 Note Added: 0018548
2017-10-13 05:57 WubTheCaptain Note Added: 0018549
2017-10-13 05:58 WubTheCaptain Status new => feedback
2017-10-13 06:02 WubTheCaptain Note Edited: 0018549 View Revisions
2017-10-14 05:29 Blzut3 Note Added: 0018550
2017-10-14 05:29 Blzut3 Status feedback => closed
2017-10-14 05:30 Blzut3 Resolution open => not fixable






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker