Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003284Doomseeker[All Projects] Bugpublic2017-10-03 18:252017-11-04 14:32
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003284: IRC: Defining an empty IRC network address results in that defined IRC network becoming uneditable from connect dialog
DescriptionDoomseeker includes a small IRC client. If a server is created from its connect dialog with an unique description but no IRC network address and this IRC network is selected, it cannot be subsequently edited due to the following error: "Cannot edit as no valid network is selected." This server cannot be deleted or edited.
Steps To Reproduce

  1. If IRC is not already visible, to view it press Ctrl + I or access it via top crates (View → IRC) or the button (IRC).

  2. On the left side of IRC panel, click the "Connect button".

  3. Add a new or edit any current server. Make sure it has any unique description.

  4. Make sure to leave the address field empty.

  5. Press "OK".

  6. Make sure your server with a no address is selected in the dropdown menu in IRC dialog.

  7. Try to edit the server again.

  8. The error is displayed.


Attached Files

- Relationships
related to 0003285resolvedZalewa IRC: Add a button to remove defined IRC networks from connect dialog 

-  Notes
User avatar (0018422)
WubTheCaptain (developer)
2017-10-03 19:58

It can be deleted or edited from "IRC Options → Networks".
User avatar (0018744)
WubTheCaptain (developer)
2017-11-03 22:47

Zalewa patched (undocumented change):https://bitbucket.org/Doomseeker/doomseeker/commits/19a22b7503158b4cafaef6d708a628a2189c534a [^]

Works for me, at least.
User avatar (0018748)
WubTheCaptain (developer)
2017-11-03 23:03

This was not yet mentioned in the CHANGELOG.md update:https://bitbucket.org/Doomseeker/doomseeker/commits/3013b512d0538c7c65ff72a464793958be307f30 [^]
User avatar (0018759)
Zalewa (developer)
2017-11-04 09:05

Indeed, this should be fixed now. I added the notice to CHANGELOG.md inhttps://bitbucket.org/Doomseeker/doomseeker/commits/46c40dfceb726d4b9ff21473cfd2d8826a61b585 [^]

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-10-03 18:25 WubTheCaptain New Issue
2017-10-03 19:58 WubTheCaptain Note Added: 0018422
2017-10-03 20:00 WubTheCaptain Summary IRC: Defining an empty IRC network address results in that defined IRC network becoming uneditable from Doomseeker => IRC: Defining an empty IRC network address results in that defined IRC network becoming uneditable from connect dialog
2017-11-03 22:47 WubTheCaptain Note Added: 0018744
2017-11-03 22:47 WubTheCaptain Status new => resolved
2017-11-03 22:47 WubTheCaptain Fixed in Version => 1.2
2017-11-03 22:47 WubTheCaptain Target Version => 1.2
2017-11-03 22:47 WubTheCaptain Assigned To => Zalewa
2017-11-03 23:03 WubTheCaptain Note Added: 0018748
2017-11-03 23:03 WubTheCaptain Status resolved => assigned
2017-11-03 23:11 WubTheCaptain Relationship added related to 0003285
2017-11-04 09:05 Zalewa Note Added: 0018759
2017-11-04 09:05 Zalewa Status assigned => needs review
2017-11-04 14:32 WubTheCaptain Status needs review => resolved
2017-11-04 14:32 WubTheCaptain Resolution open => fixed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker