Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003283Doomseeker[All Projects] Bugpublic2017-10-03 18:152018-10-27 22:55
ReporterWubTheCaptain 
Assigned ToZalewa 
PrioritynormalSeveritytextReproducibilityrandom
StatusclosedResolutionfixed 
Platformx86_64OSDebian GNU/LinuxOS Versionbuster/sid
Product Version1.1 
Target Version1.2Fixed in Version1.2 
Summary0003283: IRC: Connect dialog shows incorrect port number in port field when not default
DescriptionDoomseeker includes a small IRC client. Its connect dialog displays an incorrect port number for the selected server (for anything not the default port "6667" configured).
Steps To Reproduce

  1. If IRC is not already visible, to view it press Ctrl + I or access it via top crates (View → IRC) or the button (IRC).

  2. On the left side of IRC panel, click the "Connect button".

  3. Add a new or edit any current server. Make sure it has any unique description.

  4. Change the port to anything else than default 6667. (e.g. 6665)

  5. Press "OK".

  6. Make sure your server with a non-default port is selected in the dropdown menu in IRC dialog.

  7. Notice the port to be correct in the dropdown menu, but incorrect in the server details below it (above the password).

Attached Files? file icon doomseeker-irc.broken.ini [^] (1,572 bytes) 2017-11-03 23:26
? file icon doomseeker-irc.working.ini [^] (1,515 bytes) 2017-11-03 23:28

- Relationships

-  Notes
User avatar (0018745)
WubTheCaptain (developer)
2017-11-03 22:52

Zalewa: This issue still happens when the server address is not empty. If the server address is empty, the correct port is displayed.
User avatar (0018746)
WubTheCaptain (developer)
2017-11-03 22:56

Now I'm also confused why this happens with random servers and differently with both 1.1 and 1.2.

I have added a server with pure IPv6-only address (2600:3c00::f03c:91ff:fe24:cdcc), and the port below it shows up incorrectly in both 1.1 and 1.2.

I can no longer reproduce in 1.1 nor 1.2 for regular hostnames like irc.zandronum.com.
User avatar (0018747)
WubTheCaptain (developer)
2017-11-03 22:59

Setting the address to

[2600:3c00::f03c:91ff:fe24:cdcc]


will instead fix the port display in the connect dialog for this one, but then Doomseeker thinks it's a hostname on connect and fails to DNS lookup. (I admit I have no IPv6 connectivity right at this moment, though.)
User avatar (0018749)
WubTheCaptain (developer)
2017-11-03 23:17

Happens with IPv4-addresses too, such as "127.0.0.1".
User avatar (0018750)
WubTheCaptain (developer)
2017-11-03 23:22
edited on: 2017-11-03 23:29

I tested with a new configuration and this changed again.


  1. Created new 1.1 config.

  2. Added an empty server in 1.1.

  3. Tested changing port numbers.

  4. Ran Doomseeker 1.2.

  5. Tested changing port numbers. Broken for hostnames and IPs.

  6. Went back to my long-lasting 1.2 config.

  7. Tested changing port numbers. It works there for hostnames, IPs and whatnot.



I don't even know anymore.

1.2~beta-171103-1810, 8aee070cd126, revision 1509732653.

User avatar (0018751)
WubTheCaptain (developer)
2017-11-03 23:35
edited on: 2017-11-03 23:36

Wtf? I see what might be happening.

Both doomseeker-irc.ini config files display the correct port above 6667 (e.g. 6668), but not for below it (e.g. 6666). This happens with both 1.1 and 1.2.

User avatar (0018760)
Zalewa (developer)
2017-11-04 09:15

Fixed:https://bitbucket.org/Doomseeker/doomseeker/commits/a8ea2a12c2238f6d147412e4f7c105b33fa6fda5 [^]
User avatar (0018765)
WubTheCaptain (developer)
2017-11-04 14:53

Works for me, thank you for the contribution.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-10-03 18:15 WubTheCaptain New Issue
2017-11-03 22:52 WubTheCaptain Note Added: 0018745
2017-11-03 22:56 WubTheCaptain Note Added: 0018746
2017-11-03 22:56 WubTheCaptain Reproducibility always => sometimes
2017-11-03 22:59 WubTheCaptain Note Added: 0018747
2017-11-03 23:17 WubTheCaptain Note Added: 0018749
2017-11-03 23:22 WubTheCaptain Note Added: 0018750
2017-11-03 23:22 WubTheCaptain Reproducibility sometimes => random
2017-11-03 23:26 WubTheCaptain File Added: doomseeker-irc.broken.ini
2017-11-03 23:28 WubTheCaptain File Added: doomseeker-irc.working.ini
2017-11-03 23:29 WubTheCaptain Note Edited: 0018750 View Revisions
2017-11-03 23:35 WubTheCaptain Note Added: 0018751
2017-11-03 23:36 WubTheCaptain Note Edited: 0018751 View Revisions
2017-11-04 09:09 Zalewa Assigned To => Zalewa
2017-11-04 09:09 Zalewa Status new => confirmed
2017-11-04 09:15 Zalewa Note Added: 0018760
2017-11-04 09:15 Zalewa Status confirmed => needs review
2017-11-04 14:34 WubTheCaptain Status needs review => needs testing
2017-11-04 14:53 WubTheCaptain Note Added: 0018765
2017-11-04 14:53 WubTheCaptain Status needs testing => resolved
2017-11-04 14:53 WubTheCaptain Fixed in Version => 1.2
2017-11-04 14:53 WubTheCaptain Resolution open => fixed
2017-11-04 14:54 WubTheCaptain Target Version => 1.2
2018-10-27 22:55 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker