Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003116Zandronum[All Projects] Bugpublic2017-04-30 16:252017-10-30 01:12
Reporteribm5155 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformWindows 10 creators updateOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target VersionFixed in Version 
Summary0003116: Huge lag on intel hd 4000 when I turn the player camera left,right up or down
Description-Game runs well if I do nothing ingame.
-Game runs well if I walk forward,backyard,strafe left and strafe right.
-If using a mod that wiggle the câmera angle when in pain state, the game fps will go to 0 for about 2 - 4 seconds.
-If I move left, move right or look up and look down, the fps will go to 0 for all the moment the fps will go to 0 (plus gpu and cpu usage from zandronum will go to 0%)

-I also have a huge lag if I open the customize control,joystick options and vídeo options (When I open these menus, both gpu and cpu goes to 0% of use) and if I press esc and wait like 4 - 10 seconds it goes back to the previous menu and the cpu/gpu/fps goes normal.

===============================================================================
NOTES:
-The same gpu Works fine with the latest gzdoom and qzdoom in opengl using the intel gpu.
-The zandronum 3.0 Works fine if used with the amd hd8870m
Attached Files

- Relationships
has duplicate 0003143closed vid_fps 1 "bug" I think in OGL 
related to 0003074assignedTorr Samaho Major FPS drops (unplayable) in OpenGL 

-  Notes
User avatar (0017451)
Torr Samaho (administrator)
2017-04-30 17:02

Is GZDoom 1.8.6 behaving differently?
User avatar (0017456)
ibm5155 (reporter)
2017-04-30 17:39
edited on: 2017-05-01 15:01

if i have vid_fps 1 fixes this problem, but idk why
EDIT: the same happens with gzdoom 1.8.6

...
Also, I found that even zandronum 2.0 is suffering from the same effect but worse

EDIT: Since I can now compile zandronum, I'm gonna comiple it and try to see where things are breaking.

User avatar (0017480)
ibm5155 (reporter)
2017-05-01 17:12

Tried to compile in visual studio 2017:
-Debug mode: the game took 5 seconds to show something on screen when I start a new map, but it Works without any kind of problem.
-Release mode: triggers the weird error that causes 0fps

I'm kinda lost about what's triggering this error so I may ask the gzdoom devs about some tips
User avatar (0017730)
ibm5155 (reporter)
2017-05-21 14:10
edited on: 2017-05-21 14:33

in case this helps, here's a cpu/gpu log while running zandronum, til 11 seconds i was on menu, the rest i was in game:https://1drv.ms/u/s!AurELTq1jbljkbkGB-2yyHL0KBV8ew [^]

EDIT: vid_showpalette 1 also fixes the lag

EDIT 2: game start in 11 second, before that I was on menu and as you can see it's working.

ingame info:
total cpu time: external code 99% zandronum 1%
about this 99%:
46% of it is KernelBase.dll
10% of it is igdusc32.dll
4% of it is ig7icd32.dll
3% of it is ntdll.dll
3% of it is d3d11.dll

EDIT3: this problem only happens in release mode.

another log with more debug info:https://1drv.ms/u/s!AurELTq1jbljkbkHAzRdXdsbYCyxnA [^]

User avatar (0017803)
ibm5155 (reporter)
2017-06-06 12:06

UPDATE: this huge lag also happens with gzdoom only in 64bits builds (all the new releases suffer from that)
User avatar (0018163)
ibm5155 (reporter)
2017-08-12 12:20

UPDATE: intel has released a "new" driver to the intel hd4000.
The good part is now I can play the latest gzdoom builds just fine.
The bad is that it doesn't fix the zandronum lag iuse :(
User avatar (0018672)
ibm5155 (reporter)
2017-10-30 01:12

UPDATE: I don't have the intel hd 4000 setup and I replaced it by the intel hd graphics (its even worse than the hd4000).

-> The worse about this gpu is that the latest driver for it came in 2015 and no Win10 support.
BUT, the Windows 8.1 drivers install just fine and somehow, zandronum 3.0 is playable on it.
It may be due to the last big Windows update but at any case here's the link from the driver that I'm using:
https://downloadcenter.intel.com/download/24971/Intel-HD-Graphics-Driver-for-Windows-7-8-64-bit?product=81500 [^]
This driver Works with older intel hd graphics, HD2000 and HD3000.

At any case, if you guys have this fps problem and want to play zandronum you could try installing some older drivers

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-04-30 16:25 ibm5155 New Issue
2017-04-30 17:02 Torr Samaho Note Added: 0017451
2017-04-30 17:39 ibm5155 Note Added: 0017456
2017-04-30 17:48 ibm5155 Note Edited: 0017456 View Revisions
2017-05-01 15:01 ibm5155 Note Edited: 0017456 View Revisions
2017-05-01 17:12 ibm5155 Note Added: 0017480
2017-05-01 21:17 Torr Samaho Relationship added related to 0003074
2017-05-21 13:53 Torr Samaho Relationship added has duplicate 0003143
2017-05-21 14:10 ibm5155 Note Added: 0017730
2017-05-21 14:12 ibm5155 Note Edited: 0017730 View Revisions
2017-05-21 14:24 ibm5155 Note Edited: 0017730 View Revisions
2017-05-21 14:33 ibm5155 Note Edited: 0017730 View Revisions
2017-06-06 12:06 ibm5155 Note Added: 0017803
2017-08-12 12:20 ibm5155 Note Added: 0018163
2017-10-30 01:12 ibm5155 Note Added: 0018672






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker