Zandronum Chat @
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003071Zandronum[All Projects] Bugpublic2017-04-17 21:322017-05-07 14:51
Assigned To 
PlatformPCOSWindowsOS Version10
Product Version 
Target VersionFixed in Version 
Summary0003071: Screen resolution bugged when higher than 1280x720
DescriptionThe only problem I have now with 3.0 is that: whenever I try to set my video resolution higher than 1280x720, the screen gets all weird, half zoomed in and is across 2 screens at the same time.

Do note, in reality; the screen is zoomed in as well, which (for some reason) doesn't display in the screenshot. I'd have to take a photo with a camera to show you the exact result.

Funny thing is, in singleplayer/offline mode; I can pick any resolution I want. I already talked with jdagenet/jason about this, tried the vid_adapter thing in console (resulting in: vid adapter is 1). I also checked the appdata for doom explorer and the files are exactly the same as in my zandronum directory folder, so... I have no idea what's going on.

In 2.1.2, it works fine and I've always used 2 screens. Well, not always, but for a while now (during 2.1.2) and that worked just fine. I get the same result (as in, the good result) in singleplayer with 3.0. Not to mention, if I unplug my second screen, it's still all zoomed in until I go back to the 1280x720 resolution.
Steps To ReproduceI don't know if the same issue appears in different OS' or platforms, but here's the one that I have for Windows 10:

* Open Doom Explorer, try to join any server with 3.0. For example; TSPG
* Go to video mode
* Change your resolution to any resolution higher than 1280x720

Again, for some reason; it does not bug out in single player.
Attached Filespng file icon Naamloos12.png [^] (1,514,535 bytes) 2017-04-17 21:32
jpg file icon 20170418_211452.jpg [^] (1,110,819 bytes) 2017-04-18 19:19
png file icon Naamloos4.png [^] (163,781 bytes) 2017-05-07 14:35

- Relationships
has duplicate 0003070closed Screen resolution bugged when higher than 1280x720 

-  Notes
User avatar (0017192)
Torr Samaho (administrator)
2017-04-18 06:14

Does it only happen if you change the resolution while in the game or also if you already start the game with a resolution higher than 1280x720?

How are you starting Zandronum in single player? Also with Doomseeker?

What happens if you join a server as usual with Doomseeker, type disconnect in the console and change the resolution?
User avatar (0017198)
SpoopyErma (reporter)
2017-04-18 19:16

I use Doom Explorer.

When I run Zandronum.exe or .wad or .pk3, whatever it is in my zandronum folder; it works just fine.

When I join a server and change the resolution higher than 1280x720, it goes all weird as mentioned earlier. I also tried to change the resolution in the .ini file being "zandronum-username" and changed those to 1980x1020. Ending with the same result.

When I join a server, type "disconnect" in the console and change the resolution, I get the same wacky result. I'll upload a picture of the result, so that you can see what my screen is like when changing the resolution.
User avatar (0017550)
SpoopyErma (reporter)
2017-05-05 09:13

I'd like to add that I've tried running Zandro on a different multiplayer/server client. So instead of using Doom Explorer, I used Doomseeker.

Weirdly enough, I haven't thought about using a different server browser. What's even more weird: I do not have any of these issues when I run Doomseeker.

Yes, I have checked all the settings in Doom Explorer and they're all perfectly fine. It's as if the two server explorers use two different kinds of Zandronum or run them differently.

TL;DR: DoomSeeker doesn't have this issue.
User avatar (0017555)
Torr Samaho (administrator)
2017-05-06 17:01

That is a very interesting finding. Do you know if Doomseeker and Doom Explorer use different command line options to start Zandronum in your case?
User avatar (0017581)
SpoopyErma (reporter)
2017-05-07 14:34
edited on: 2017-05-07 14:51

I've joined my own TSPG server and logged the console in these pastebins: [^] [^]

I'm not exactly noticing any difference aside from this " adding C:/Users/Kuvira/AppData/Roaming/Doom Explorer/ZandronumTesting/zandronum.pk3, 689 lumps"

If I remove or replace the files in this directory, the Doom Explorer tells me "this server requires a special version of Zandronum...", even though the directory is still exactly the same (as in, leading to the same "Zandronum.exe" file"). For now, I cannot run Zandronum 3.0 anymore without those files in that directory.

Both program directories (for Doom Explorer and DoomSeeker) lead to: D/Zandronum/Zandronum.exe. They still run as if they're different programs, along with different settings in resolution, sound and controls. Weird thing is; there's only one .ini file for Zandronum, meaning the settings shouldn't change at all.

I will also provide a picture that clearly shows a difference in size/font when starting Zandro 3.0 in different ways.

I'll just run with Doomseeker and get used to that. At least that works :)

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2017-04-17 21:32 SpoopyErma New Issue
2017-04-17 21:32 SpoopyErma File Added: Naamloos12.png
2017-04-18 06:11 Torr Samaho OS => Windows
2017-04-18 06:11 Torr Samaho OS Version => 10
2017-04-18 06:11 Torr Samaho Platform => PC
2017-04-18 06:11 Torr Samaho Relationship added has duplicate 0003070
2017-04-18 06:14 Torr Samaho Note Added: 0017192
2017-04-18 06:15 Torr Samaho Status new => feedback
2017-04-18 19:16 SpoopyErma Note Added: 0017198
2017-04-18 19:16 SpoopyErma Status feedback => new
2017-04-18 19:19 SpoopyErma File Added: 20170418_211452.jpg
2017-05-05 09:13 SpoopyErma Note Added: 0017550
2017-05-06 17:01 Torr Samaho Note Added: 0017555
2017-05-06 17:02 Torr Samaho Status new => feedback
2017-05-07 14:34 SpoopyErma Note Added: 0017581
2017-05-07 14:34 SpoopyErma Status feedback => new
2017-05-07 14:35 SpoopyErma File Added: Naamloos4.png
2017-05-07 14:37 SpoopyErma Note Added: 0017582
2017-05-07 14:38 SpoopyErma Note Edited: 0017582 View Revisions
2017-05-07 14:42 SpoopyErma Note Edited: 0017581 View Revisions
2017-05-07 14:45 SpoopyErma Note Edited: 0017581 View Revisions
2017-05-07 14:46 SpoopyErma Note Deleted: 0017582
2017-05-07 14:49 SpoopyErma Note Edited: 0017581 View Revisions
2017-05-07 14:51 SpoopyErma Note Edited: 0017581 View Revisions

Questions or other issues? Contact Us.


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker