Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002861Zandronum[All Projects] Bugpublic2016-10-06 23:372020-04-20 19:53
Reporterunknownna 
Assigned ToEdward-san 
PrioritynormalSeverityfeatureReproducibilityalways
Statusneeds testingResolutionreopened 
PlatformOSOS Version
Product Version3.0 
Target VersionFixed in Version 
Summary0002861: smooth mouse movement option no longer toggles m_filter in 3.0
DescriptionI recall that Torr told me that smooth_mouse does nothing in Skulltag/Zandronum, so we decided to have the menu option toggle m_filter instead since that's what ZDaemon did at the time. With the recent menu change, it naturally toggles smooth_mouse instead. So the question is whether we want it to toggle m_filter or do something else about it.
Attached Filespng file icon menu.png [^] (66,159 bytes) 2016-10-06 23:37

- Relationships
related to 0002875resolvedLeonard "smooth_mouse 1" potentially hard-coded into Zandronum's mouse behavior 

-  Notes
User avatar (0015782)
Edward-san (developer)
2016-10-07 09:21
edited on: 2016-10-07 09:41

Oh well, unless there's time to track down the original problem with smooth_mouse, we have to fix the menu for the time being.

[edit] Done.

User avatar (0015809)
Edward-san (developer)
2016-10-08 17:11

Merged to 3.0 upstream:https://bitbucket.org/Torr_Samaho/zandronum/commits/61a8c6efc099 [^]
User avatar (0015859)
unknownna (updater)
2016-10-09 19:32

Yes, it toggles m_filter now. Nice to see you work so fast, Edward-san. Keep it up!
User avatar (0015866)
unknownna (updater)
2016-10-09 21:56
edited on: 2016-10-09 22:02

Quote from Edward-san
Oh well, unless there's time to track down the original problem with smooth_mouse, we have to fix the menu for the time being.

Edward-san, I noticed one difference between ZDoom and Zandronum with cl_capfps 0: The view is jittery in ZDoom and smooth in Zandronum when aiming and moving around at the same time. In ZDoom, you have to use "smooth_mouse 1" to make the view as smooth as Zandronum. Could it be that Carnevil hard-coded "smooth_mouse 1" into Skulltag's default mouse behavior and thus disabled smooth_mouse altogether?

User avatar (0015867)
Edward-san (developer)
2016-10-09 22:27

Sounds plausible. Anyways, this discussion can continue on another ticket.
User avatar (0021257)
Ru5tK1ng (updater)
2020-04-11 00:16

Since 2875 restored actual smooth_mouse functionality, I would suggest committed 61a8c6e be undone and restore the smooth_mouse option and possibly add an m_filter option as well.
User avatar (0021269)
Torr Samaho (administrator)
2020-04-19 20:27

I agree.
User avatar (0021273)
Edward-san (developer)
2020-04-19 23:31

PR is ready. Regarding the option 'm_filter', as discussed in the dev meeting, no action is taken, unless there is enough support for it.
User avatar (0021275)
Torr Samaho (administrator)
2020-04-20 19:52

I added your patch.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-10-06 23:37 unknownna New Issue
2016-10-06 23:37 unknownna File Added: menu.png
2016-10-07 09:21 Edward-san Note Added: 0015782
2016-10-07 09:21 Edward-san Assigned To => Edward-san
2016-10-07 09:21 Edward-san Status new => assigned
2016-10-07 09:41 Edward-san Note Edited: 0015782 View Revisions
2016-10-07 09:41 Edward-san Status assigned => needs review
2016-10-08 17:11 Edward-san Note Added: 0015809
2016-10-08 17:11 Edward-san Status needs review => needs testing
2016-10-09 17:56 Torr Samaho Target Version => 3.0
2016-10-09 19:32 unknownna Note Added: 0015859
2016-10-09 21:08 unknownna Status needs testing => resolved
2016-10-09 21:08 unknownna Fixed in Version => 3.0
2016-10-09 21:08 unknownna Resolution open => fixed
2016-10-09 21:56 unknownna Note Added: 0015866
2016-10-09 21:56 unknownna Status resolved => feedback
2016-10-09 21:56 unknownna Resolution fixed => reopened
2016-10-09 22:02 unknownna Note Edited: 0015866 View Revisions
2016-10-09 22:27 Edward-san Note Added: 0015867
2016-10-09 22:27 Edward-san Status feedback => resolved
2016-10-09 22:27 Edward-san Resolution reopened => fixed
2018-09-30 21:59 Blzut3 Status resolved => closed
2020-04-11 00:12 Ru5tK1ng Relationship added related to 0002875
2020-04-11 00:16 Ru5tK1ng Note Added: 0021257
2020-04-11 00:16 Ru5tK1ng Status closed => feedback
2020-04-11 00:16 Ru5tK1ng Resolution fixed => reopened
2020-04-11 00:17 Ru5tK1ng Product Version 3.0-beta => 3.0
2020-04-11 00:17 Ru5tK1ng Target Version 3.0 => 3.1
2020-04-19 20:27 Torr Samaho Note Added: 0021269
2020-04-19 23:31 Edward-san Note Added: 0021273
2020-04-19 23:32 Edward-san Status feedback => needs review
2020-04-19 23:32 Edward-san Fixed in Version 3.0 =>
2020-04-19 23:32 Edward-san Target Version 3.1 =>
2020-04-20 19:52 Torr Samaho Note Added: 0021275
2020-04-20 19:53 Torr Samaho Status needs review => needs testing






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker