Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002785Zandronum[All Projects] Bugpublic2016-07-15 05:282018-09-30 21:56
ReporterTiger 
Assigned ToDusk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMicrosoft WindowsOSWindows 10OS Version6.3
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002785: UDMF Scaling Incorrect NetGames
DescriptionHaving a UDMF map that contains flats being scaled less than '1.0' (for example, 0.9 or less), the flat will not render correctly on a NetGame (Server\Client) while Single Player environment works perfectly fine.


Using: Zandronum 3.0-alpha-r160703-1614 (NOTE: This also occurs in 4.0 too)
File Attached: 7Zip using PPMd algorithm
Steps To ReproduceI have attached a test file which can be used to see the effect. Making a similar test map is simple: Create a parent sector, edit the flat scaling to '0.6' or anything less than '1.0' then:

* Invoke the zandronum binary with the '-host' switch via CLI
* With the game server started, join said game server.
* Look for the sector references that contains the scaling properties.

Single player does not contain this odd behavior.
Attached Files7z file icon UDMF_Scaling.7z [^] (1,455 bytes) 2016-07-15 05:28
png file icon UDMF_Scaling.png [^] (1,665,260 bytes) 2016-07-15 05:28

- Relationships

-  Notes
User avatar (0015319)
Dusk (developer)
2016-07-15 20:20

This is because the scale is only transmitted at integer precision, without the fractional part.
User avatar (0015321)
Dusk (developer)
2016-07-15 22:29

The example WAD appears to be broken.


$ 7zr x UDMF_Scaling.7z

7-Zip (A) [64] 9.20 Copyright (c) 1999-2010 Igor Pavlov 2010-11-18
p7zip Version 9.20 (locale=fi_FI.UTF-8,Utf16=on,HugeFiles=on,2 CPUs)

Processing archive: UDMF_Scaling.7z

Extracting UDMF_Scaling.wad Unsupported Method

Sub items Errors: 1
User avatar (0015322)
Tiger (reporter)
2016-07-15 22:51

I used 7zip version 16.00 [http://www.7-zip.org/ [^] ] to generate that archive file.

Note: I hope this uses BBCode?

[Fri.15.Jul.2016 17:48:02.48] [C:\Users\Nicholas]
$ "C:\Program Files\7-Zip\7z.exe" t .\Desktop\UDMF_Scaling.7z

7-Zip [64] 16.00 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-10

Scanning the drive for archives:
1 file, 1455 bytes (2 KiB)

Testing archive: .\Desktop\UDMF_Scaling.7z
--
Path = .\Desktop\UDMF_Scaling.7z
Type = 7z
Physical Size = 1455
Headers Size = 138
Method = PPMD
Solid = -
Blocks = 1

Everything is Ok

Size: 6685
Compressed: 1455
User avatar (0015323)
Dusk (developer)
2016-07-15 22:58

Ah. I had to use 7za, not 7zr, which does not support the PPMD method. Let's see hereā€¦
User avatar (0015324)
Dusk (developer)
2016-07-15 23:07

https://bitbucket.org/Torr_Samaho/zandronum/pull-requests/125 [^]

I also needed to change the SetSectorPanning message similarly to have the textures align correctly.
User avatar (0016053)
Ru5tK1ng (updater)
2016-10-18 20:54

Code was merged:https://bitbucket.org/Torr_Samaho/zandronum/commits/1a57bf607bd47617425d88c647717dadb7b7623f [^]
User avatar (0016440)
Ru5tK1ng (updater)
2016-12-08 02:56

The water now seems to scale properly offline and online.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-07-15 05:28 Tiger New Issue
2016-07-15 05:28 Tiger File Added: UDMF_Scaling.7z
2016-07-15 05:28 Tiger File Added: UDMF_Scaling.png
2016-07-15 20:20 Dusk Note Added: 0015319
2016-07-15 22:29 Dusk Note Added: 0015321
2016-07-15 22:51 Tiger Note Added: 0015322
2016-07-15 22:58 Dusk Note Added: 0015323
2016-07-15 22:59 Dusk Assigned To => Dusk
2016-07-15 22:59 Dusk Status new => assigned
2016-07-15 23:07 Dusk Note Added: 0015324
2016-07-15 23:07 Dusk Status assigned => needs review
2016-10-18 20:54 Ru5tK1ng Note Added: 0016053
2016-10-18 20:54 Ru5tK1ng Status needs review => needs testing
2016-10-18 20:54 Ru5tK1ng Target Version => 3.0
2016-12-08 02:56 Ru5tK1ng Note Added: 0016440
2016-12-08 02:56 Ru5tK1ng Status needs testing => resolved
2016-12-08 02:56 Ru5tK1ng Resolution open => fixed
2016-12-08 02:56 Ru5tK1ng Fixed in Version => 3.0
2018-09-30 21:56 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker