Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002775Zandronum[All Projects] Bugpublic2016-07-10 08:422017-10-11 17:05
ReporterWaTaKiD 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version2.1 
Target VersionFixed in Version 
Summary0002775: duplicate lumps with same extension cause auth fail when hosted on linux
Descriptionas mentioned in the first part ofhttps://zandronum.com/forum/viewtopic.php?f=55&t=7387&p=99418#p99413 [^]

the provided example wad has 2 DECORATE lumps with the same extension

you will get an auth fail when trying to connect to a linux server hosting this wad, but itll work fine if hosted on windows

to fix this within the wad itself, just add an extension to one of the DECORATE lumps
Steps To Reproducehost the provided example wad on a linux server
try connecting to it
auth fail

repeat with a windows server, itll work fine
Additional Informationfwiw, while making the example wad, i forgot that it needed to be .pk3, as i couldnt reproduce the issue with it as .wad

issue can also be reproduced in zan 3.0
Attached Files? file icon ticket2775.pk3 [^] (272 bytes) 2016-07-10 08:42

- Relationships

-  Notes
User avatar (0018525)
Marcaek (reporter)
2017-10-11 02:04

I guess this was just completely missed?
User avatar (0018528)
Edward-san (developer)
2017-10-11 07:44

Quote

I guess this was just completely missed?


Since it happens also in 2.1, there was no reason to urgently fix it for 3.0.
User avatar (0018529)
Dusk (developer)
2017-10-11 15:14

I don't think that this is something that can or needs to be fixed. The WAD file is broken, you're not supposed to have files with the same name inside zip archives, so of course it is loaded differently under different platforms.

Perhaps the correct way would be to respond to this case with a fatal error or with the wad ignored.
User avatar (0018530)
AOSP (reporter)
2017-10-11 17:05

Fatal error seems best, wouldn't want people confused as to why a WAD isn't being loaded with seemingly no reason.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: Marcaek
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-07-10 08:42 WaTaKiD New Issue
2016-07-10 08:42 WaTaKiD File Added: ticket2775.pk3
2017-10-11 02:04 Marcaek Note Added: 0018525
2017-10-11 07:44 Edward-san Note Added: 0018528
2017-10-11 15:14 Dusk Note Added: 0018529
2017-10-11 17:05 AOSP Note Added: 0018530






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker