Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002691Zandronum[All Projects] Bugpublic2016-03-30 20:322017-12-03 12:33
ReporterWaTaKiD 
Assigned ToEdward-san 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target VersionFixed in Version3.0 
Summary0002691: items visually sink in swimmable sector
Descriptiondoes not happen in singleplayer, zan 2.1.2, or gzdoom 1.8.6
Steps To Reproducestart a server with the attached wad
notice the health bonuses slowly sink (in order to pick them up, u have to go where they spawned, not where u see them)

now go offline and notice the health bonuses stay put
Attached Files? file icon test-swim.wad [^] (9,332 bytes) 2016-03-30 20:32

- Relationships
has duplicate 0003350closed Sinking items in deep water desync 

-  Notes
User avatar (0014625)
WaTaKiD (updater)
2016-03-30 21:57

ive narrowed it down to this commit as the cause:https://bitbucket.org/Torr_Samaho/zandronum/commits/f4f639847b4609f3cc3c6cb8d57d7855682d8d5c [^]
User avatar (0014627)
Edward-san (developer)
2016-03-30 23:45
edited on: 2016-03-30 23:48

The new code checks for the 'DROPPED' flag to determine if the actor can sink or not. Sadly, for some reason the client thinks the items have the DROPPED flag, hence making them 'sink'. I don't know why, though.

User avatar (0014629)
Edward-san (developer)
2016-03-31 10:08
edited on: 2016-03-31 10:49

Should be fixed with this changeset + this one (handles also the survival resets, doesn't change the behavior if an item is summoned or dropped).

Since this change involves quite a good part of the client gameplay, please test it thoroughly (a testing build with this would be nice).

User avatar (0014632)
WaTaKiD (updater)
2016-04-01 00:57

this build contains both of the above mentioned commits:https://www.dropbox.com/s/e587acmjtso7xv6/zandronum-3.0-r160331-1046-708bb7a-windows.zip?dl=0 [^]

with a quick test, it seems the issue is fixed, but i will give it a more thorough test another time
User avatar (0014641)
Edward-san (developer)
2016-04-02 15:52

Keep in mind that this affects ALL the actor things, hence I would recommend testing this with any mod which relies on the item inventories behavior.
User avatar (0014672)
Edward-san (developer)
2016-04-03 21:06

this patch needs some adjustments, so the testing is not needed for now.
User avatar (0014721)
Edward-san (developer)
2016-04-17 20:26

Pull request ready:https://bitbucket.org/Torr_Samaho/zandronum/pull-requests/83/fixed-the-server-didnt-inform-the-clients/diff [^] .
User avatar (0014842)
Edward-san (developer)
2016-05-08 20:58

Added with changeset:https://bitbucket.org/Torr_Samaho/zandronum/commits/44214c3791c1ff50d1301a914e6db4a4dc25cbf3 [^] .
User avatar (0015470)
Combinebobnt (reporter)
2016-08-18 01:41

tested online in 160814-2010 and they didn't sink
User avatar (0015477)
Edward-san (developer)
2016-08-18 09:09

Thanks for checking!
User avatar (0018933)
Edward-san (developer)
2017-12-03 11:53
edited on: 2017-12-03 12:33

Reopening this because I could reproduce this again in 3.0.

[edit] Should be fixed by this commit, though now I wonder if there are other 'fixed' issues which aren't fixed at all.

I didn't investigate the broken changeset, but I think it happened since this change.


Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-03-30 20:32 WaTaKiD New Issue
2016-03-30 20:32 WaTaKiD File Added: test-swim.wad
2016-03-30 21:57 WaTaKiD Note Added: 0014625
2016-03-30 23:45 Edward-san Note Added: 0014627
2016-03-30 23:45 Edward-san Status new => confirmed
2016-03-30 23:48 Edward-san Note Edited: 0014627 View Revisions
2016-03-31 09:11 Edward-san Assigned To => Edward-san
2016-03-31 09:11 Edward-san Status confirmed => assigned
2016-03-31 10:08 Edward-san Note Added: 0014629
2016-03-31 10:08 Edward-san Status assigned => feedback
2016-03-31 10:09 Edward-san Note Edited: 0014629 View Revisions
2016-03-31 10:49 Edward-san Note Edited: 0014629 View Revisions
2016-04-01 00:57 WaTaKiD Note Added: 0014632
2016-04-01 00:57 WaTaKiD Status feedback => assigned
2016-04-02 15:52 Edward-san Note Added: 0014641
2016-04-02 15:53 Edward-san Status assigned => feedback
2016-04-03 21:06 Edward-san Note Added: 0014672
2016-04-03 21:06 Edward-san Status feedback => assigned
2016-04-17 20:26 Edward-san Note Added: 0014721
2016-04-17 20:26 Edward-san Status assigned => needs review
2016-05-08 20:58 Edward-san Note Added: 0014842
2016-05-08 20:58 Edward-san Status needs review => needs testing
2016-08-18 01:41 Combinebobnt Note Added: 0015470
2016-08-18 09:09 Edward-san Note Added: 0015477
2016-08-18 09:09 Edward-san Status needs testing => resolved
2016-08-18 09:09 Edward-san Fixed in Version => 3.0
2016-08-18 09:09 Edward-san Resolution open => fixed
2017-12-03 11:51 Edward-san Relationship added has duplicate 0003350
2017-12-03 11:53 Edward-san Note Added: 0018933
2017-12-03 11:53 Edward-san Status resolved => feedback
2017-12-03 11:53 Edward-san Resolution fixed => reopened
2017-12-03 11:53 Edward-san Status feedback => confirmed
2017-12-03 12:33 Edward-san Note Edited: 0018933 View Revisions
2017-12-03 12:33 Edward-san Status confirmed => feedback






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker