Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002688Zandronum[All Projects] Bugpublic2016-03-30 18:252018-09-30 22:05
ReporterTiger 
Assigned ToTorr Samaho 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform(x86_64)OSWindowsOS Version6.3
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002688: HiRes HUD Font not Scaled
DescriptionUsing the HiRes asset from Dancso [http://forum.zdoom.org/viewtopic.php?p=428998#p428998 [^] ], Zandronum seems incapable of scaling the numbers in the HUD. In the attached PWAD, you will see the HUD statusbar cover the mugshot and leak everywhere else in the status bar.

I am not exactly sure if this is specifically a Zandronum issue or if it is just because the fix has not yet been ported over yet from (G)ZDoom's recent developments. This works perfectly fine using GZDoom 2.1 (x64), so I assume this is merely a bug that wasn't ported over yet? (I really don't know)

I have attached a demonstration PWAD for this issue.
Attached Filespng file icon HiRestFont_IMG.png [^] (35,311 bytes) 2016-03-30 18:29


? file icon HiResFont.pk7 [^] (522,255 bytes) 2016-03-30 19:09
? file icon hirestextzan3fix.pk3 [^] (206 bytes) 2016-04-03 17:43

- Relationships

-  Notes
User avatar (0014620)
Edward-san (developer)
2016-03-30 19:02

Can you try gzdoom 1.8.6?
User avatar (0014622)
Tiger (reporter)
2016-03-30 21:18

Can you please provide the build?
User avatar (0014623)
WaTaKiD (updater)
2016-03-30 21:23

gzdoom 1.8.6 can be found here:http://zandronum.com/tracker/plugin.php?page=Rules/rules [^]
User avatar (0014624)
Tiger (reporter)
2016-03-30 21:38

Thank you for the build. It seems that this issue does not occur in GZDoom 1.8.6, so it looks like a bug with Zandronum 3.0 by itself.
User avatar (0014648)
cobalt (updater)
2016-04-03 11:00

Issue addressed by commit b2eec9bd05c8: Fixed problems of the Doom status bar with high res font replacements (addresses 2688).
Committed by Benjamin Berkels [Torr Samaho] on Wednesday 31 December 1969 23:59:57

Changes in files:

 docs/zandronum-history.txt | 1 +
 src/g_doom/doom_sbar.cpp | 19 +++++++++----------
 src/g_shared/shared_sbar.cpp | 3 ++-
 3 files changed, 12 insertions(+), 11 deletions(-)

User avatar (0014651)
Torr Samaho (administrator)
2016-04-03 11:36
edited on: 2016-04-03 11:37

The scaling should be working correctly now, there is still some discrepancy of Zandronum's behavior compared to ZDoom though. In Zandronum you need to replace STTNUM0-STTNUM9 to alter the font of Doom's status bar. In your example wad you'll need to add

    remap STTNUM0 HIDOF048
    remap STTNUM1 HIDOF049
    remap STTNUM2 HIDOF050
    remap STTNUM3 HIDOF051
    remap STTNUM4 HIDOF052
    remap STTNUM5 HIDOF053
    remap STTNUM6 HIDOF054
    remap STTNUM7 HIDOF055
    remap STTNUM8 HIDOF056
    remap STTNUM9 HIDOF057

to HIRESTEX.txt and it should work in combination with the fixes I made today.

User avatar (0014655)
Tiger (reporter)
2016-04-03 12:19

Thank you kindly.
User avatar (0014659)
Empyre (reporter)
2016-04-03 15:50

What if I add a pk3 with only HIRESTEX.txt with only those line in it in my skins folder with the hires font I already have?
User avatar (0014660)
Torr Samaho (administrator)
2016-04-03 15:53

That should work, if you have a 3.0 build that includes today's fixes.
User avatar (0014667)
Empyre (reporter)
2016-04-03 17:42

I went ahead and did it now so that later when Zandronum 3.0 is released, the fix will already be in place. Thanks for this and for all you do.
To save others the trouble of making it, I'll attach the pk3.
User avatar (0014674)
Tiger (reporter)
2016-04-07 03:17

Using build 3.0-alpha @ 160403-1900 - Commit 96e0e5e40e46, (credit to WaTaKiD), this seems to be fixed for me. I was only able to test in coop and DM, I am not sure if other game modes should also be looked at with the recent changes.

Thanks for the fix!

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-03-30 18:25 Tiger New Issue
2016-03-30 18:25 Tiger File Added: HiResFont.7z
2016-03-30 18:29 Tiger File Added: HiRestFont_IMG.png
2016-03-30 18:35 Tiger Note Added: 0014619
2016-03-30 19:02 Edward-san Note Added: 0014620
2016-03-30 19:03 Edward-san Status new => feedback
2016-03-30 19:09 Dusk File Added: HiResFont.pk7
2016-03-30 19:09 Dusk File Deleted: HiResFont.7z
2016-03-30 19:10 Dusk Note Deleted: 0014619
2016-03-30 21:18 Tiger Note Added: 0014622
2016-03-30 21:18 Tiger Status feedback => new
2016-03-30 21:23 WaTaKiD Note Added: 0014623
2016-03-30 21:38 Tiger Note Added: 0014624
2016-04-03 11:00 cobalt Assigned To => Torr Samaho
2016-04-03 11:00 cobalt Status new => needs testing
2016-04-03 11:00 cobalt Target Version => 3.0
2016-04-03 11:00 cobalt Description Updated View Revisions
2016-04-03 11:00 cobalt Note Added: 0014648
2016-04-03 11:36 Torr Samaho Note Added: 0014651
2016-04-03 11:37 Torr Samaho Note Edited: 0014651 View Revisions
2016-04-03 11:37 Torr Samaho Note Revision Dropped: 14651: 0008878
2016-04-03 12:19 Tiger Note Added: 0014655
2016-04-03 15:50 Empyre Note Added: 0014659
2016-04-03 15:53 Torr Samaho Note Added: 0014660
2016-04-03 17:42 Empyre Note Added: 0014667
2016-04-03 17:43 Empyre File Added: hirestextzan3fix.pk3
2016-04-07 03:17 Tiger Note Added: 0014674
2016-04-08 19:13 Dusk Status needs testing => resolved
2016-04-08 19:13 Dusk Fixed in Version => 3.0
2016-04-08 19:13 Dusk Resolution open => fixed
2018-09-30 22:05 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker