Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002685Zandronum[All Projects] Bugpublic2016-03-30 17:302018-09-30 22:01
ReporterTiger 
Assigned ToTorr Samaho 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDesktop (x86_64)OSWindowsOS Version6.3
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002685: Desync Z-axis 3D Sloped Floors
DescriptionWhen clients connect to a gameserver where 3D sloped floors exist, they will visually see the THINGs that are on top of the 3D sloped floor - fall or simply have incorrect Z-height values. However, this desync issue occurs only to the clients but not the gameserver itself. The gameserver still has the correct z-height values of the THINGs, but the clients do not - visually.

This looks like a bug that was introduced in Zandronum 3.0 (160229-1221), as it seems Zandronum 2.1.2 works as expected.

Attached to this ticket is a demonstration PWAD for this issue.
Attached Files7z file icon CandlesHateLogic.7z [^] (2,092 bytes) 2016-03-30 17:30

- Relationships
related to 0002787closedTorr Samaho Puffs are acting weird whenever shot at ledges 

-  Notes
User avatar (0014657)
Torr Samaho (administrator)
2016-04-03 15:41

Can somebody check in which 3.0 revision this broke?
User avatar (0014662)
Tiger (reporter)
2016-04-03 16:13

Do you have any builds that are older than 2015-08-24? I tried using the oldest build "ZandroDev3.0-150819-2351windows.zip" [http://zandronum.com/downloads/testing/3.0/?C=M;O=A [^] ], but the issue still occurs.
User avatar (0014666)
WaTaKiD (updater)
2016-04-03 17:31

ive narrowed it down to this commit as the cause:https://bitbucket.org/Torr_Samaho/zandronum/commits/d96bc66f5ec7c4d86e0f83e6e8b47d156063fa65 [^]
User avatar (0014668)
Torr Samaho (administrator)
2016-04-03 17:52

Thanks a lot! This should make fixing this much easier.
User avatar (0014670)
Torr Samaho (administrator)
2016-04-03 19:27
edited on: 2016-04-03 20:04

This should fix the issue, but I'm not sure whether it has any side effects. Needs to be tested thoroughly.

The current version of the fix can be found here.

User avatar (0014671)
Tiger (reporter)
2016-04-03 19:57

I just did a quick test using TGRDM3, I have not encountered anything abnormal -- issue seems to be correct as far as I can tell.
User avatar (0014679)
cobalt (updater)
2016-04-09 11:36

Issue addressed by commit 81559c96f5dc: Fixed: Items on sloped 3D floors could fall through the floor on the clients (addresses 2685).
Committed by Benjamin Berkels [Torr Samaho] on Wednesday 31 December 1969 23:59:57

Changes in files:

 src/cl_main.cpp | 4 ++++
 1 files changed, 4 insertions(+), 0 deletions(-)

User avatar (0014714)
Ru5tK1ng (updater)
2016-04-15 02:48

Tested with r160410-1037 and the THINGS in the testmap appeared correctly on the 3D slope.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-03-30 17:30 Tiger New Issue
2016-03-30 17:30 Tiger File Added: CandlesHateLogic.7z
2016-04-03 15:41 Torr Samaho Note Added: 0014657
2016-04-03 15:41 Torr Samaho Target Version => 3.0
2016-04-03 15:43 Torr Samaho Assigned To => Torr Samaho
2016-04-03 15:43 Torr Samaho Status new => feedback
2016-04-03 16:13 Tiger Note Added: 0014662
2016-04-03 16:13 Tiger Status feedback => assigned
2016-04-03 17:31 WaTaKiD Note Added: 0014666
2016-04-03 17:52 Torr Samaho Note Added: 0014668
2016-04-03 19:27 Torr Samaho Note Added: 0014670
2016-04-03 19:57 Tiger Note Added: 0014671
2016-04-03 20:04 Torr Samaho Note Edited: 0014670 View Revisions
2016-04-03 20:04 Torr Samaho Note Edited: 0014670 View Revisions
2016-04-09 11:36 cobalt Status assigned => needs testing
2016-04-09 11:36 cobalt Description Updated View Revisions
2016-04-09 11:36 cobalt Note Added: 0014679
2016-04-15 02:48 Ru5tK1ng Note Added: 0014714
2016-04-15 02:48 Ru5tK1ng Status needs testing => resolved
2016-04-15 02:48 Ru5tK1ng Resolution open => fixed
2016-04-15 02:48 Ru5tK1ng Fixed in Version => 3.0
2016-04-15 02:48 Ru5tK1ng Description Updated View Revisions
2016-07-21 11:00 Edward-san Relationship added related to 0002787
2018-09-30 22:01 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker