Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002553Zandronum[All Projects] Bugpublic2015-12-21 21:302018-09-30 21:52
ReporterDusk 
Assigned ToTorr Samaho 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002553: Gamemode F1 screens don't work
DescriptionLoad up skulltag_actors.pk3 and skulltag_data.pk3 and fire up any game in offline skirmish. Press F1 and notice that the default help screen is used instead.

This is because with MENUDEF came a rewritten F1 screen and it hasn't been adapted for these help screens yet.
Additional InformationI fixed this in the gamemode branch but the fix needs to be adapted, unless the gamemode branch gets merged before 3.0 takes off.
Attached Files

- Relationships
child of 0001091closedTorr Samaho Introduction of MENUDEF LUMP 

-  Notes
User avatar (0016224)
Torr Samaho (administrator)
2016-11-20 20:56

Should be fixed now. I just added back the corresponding code from before the menu rewrite.
User avatar (0016500)
Ru5tK1ng (updater)
2016-12-16 07:31

The custom help screens still don't seem to work when I tested with the st wads.
User avatar (0016518)
Torr Samaho (administrator)
2016-12-17 16:17

Can you elaborate how to reproduce the problem? The screens seem to work just fine for me.
User avatar (0016519)
Ru5tK1ng (updater)
2016-12-17 16:47
edited on: 2016-12-17 17:44

Turns out it was just the invasion maps/mode that was causing issues. Picking a stock ST invasion map from offline skirmish and setting the mode to either coop, survival or invasion wouldn't show the F1 screen when the game started. Setting the mode to something like deathmatch and starting the game would show the correct F1 screen. It's weird and doesn't make sense but that's how it also works in 2.1.2.

Since all the help screens actually come up, this can be considered then.


Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2015-12-21 21:30 Dusk New Issue
2015-12-21 21:31 Dusk Additional Information Updated View Revisions
2015-12-21 21:32 Dusk Relationship added child of 0001091
2016-11-20 20:43 Torr Samaho Additional Information Updated View Revisions
2016-11-20 20:56 Torr Samaho Note Added: 0016224
2016-11-20 20:56 Torr Samaho Assigned To => Torr Samaho
2016-11-20 20:56 Torr Samaho Status new => needs testing
2016-12-16 07:31 Ru5tK1ng Note Added: 0016500
2016-12-16 07:31 Ru5tK1ng Status needs testing => feedback
2016-12-17 16:17 Torr Samaho Note Added: 0016518
2016-12-17 16:47 Ru5tK1ng Note Added: 0016519
2016-12-17 17:44 Ru5tK1ng Note Edited: 0016519 View Revisions
2016-12-17 17:45 Ru5tK1ng Status feedback => resolved
2016-12-17 17:45 Ru5tK1ng Resolution open => fixed
2016-12-17 17:45 Ru5tK1ng Fixed in Version => 3.0
2018-09-30 21:52 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker