Zandronum Chat on our Discord Server Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001772Doomseeker[All Projects] Bugpublic2014-04-06 14:532018-09-29 14:45
ReporterZalewa 
Assigned ToBlzut3 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04 x86
Product Version0.12 Beta 
Target Version0.12 BetaFixed in Version0.12 Beta 
Summary0001772: Linux: 'zandronum-server' not terminated when standard server console is closed
Descriptionzandronum-server is started by a bash script. Bash instance that executes the script is terminated properly, but the 'zandronum-server' process that it started gets orphaned but remains running with no indication to the user.
Steps To Reproduce1. `watch -n 1 'ps afx | grep zandronum'`
2. Start /usr/bin/zandronum-server from Doomseeker "Create Server" dialog box. Standard Server Console will pop up, new zandronum-server process will start.
3. Close the Standard Server Console.
4. Pay attention to 'watch' from point 1.
Additional InformationTested in Lubuntu 12.04 with Zandronum binaries installed from debian.drdteam.org repository.
Attached Files

- Relationships

-  Notes
User avatar (0008592)
Blzut3 (administrator)
2014-04-17 01:30

Should be fixed. A proper fix will come when a new Zandronum version is released though since I should just be using exec in the wrapper script.
User avatar (0008656)
Zalewa (developer)
2014-05-01 09:40

Seems to work now.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2014-04-06 14:53 Zalewa New Issue
2014-04-06 14:53 Zalewa Status new => assigned
2014-04-06 14:53 Zalewa Assigned To => Blzut3
2014-04-06 14:54 Zalewa Additional Information Updated View Revisions
2014-04-17 01:30 Blzut3 Note Added: 0008592
2014-04-17 01:30 Blzut3 Status assigned => needs review
2014-04-17 01:30 Blzut3 Fixed in Version => 0.12 Beta
2014-04-17 01:30 Blzut3 Target Version => 0.12 Beta
2014-05-01 09:40 Zalewa Note Added: 0008656
2014-05-01 09:40 Zalewa Status needs review => resolved
2014-05-01 09:40 Zalewa Resolution open => fixed
2018-09-29 14:45 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker