Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001173Zandronum[All Projects] Suggestionpublic2012-11-06 14:352018-09-30 23:07
Reportersomeoneelse 
Assigned ToDusk 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.0 
Target Version1.3Fixed in Version2.0 
Summary0001173: New dmflag- shared keys for multiplayer
DescriptionIn vanilla coop, when one player picks up a key, every player gets it. Since it's a pretty vanilla thing, which encourages cooperation, I think it would make a very usefull option.
Attached Filesdiff file icon keys.diff [^] (4,799 bytes) 2013-09-13 05:52 [Show Content]

- Relationships

-  Notes
User avatar (0005361)
Balrog (reporter)
2012-11-11 15:59

I agree that this is a good thing to have around, perhaps even as a default. Maybe have a second CVAR to enable/disable "%PLAYER% has picked up the %KEY%" messages? I'm not sure everyone would want them, and I don't think it would be difficult to implement.
User avatar (0005379)
someoneelse (reporter)
2012-11-12 04:34

Well, maybe they should look like normal pick-up messages and have the same priority?
User avatar (0005395)
Qent (updater)
2012-11-14 18:10
edited on: 2012-11-14 18:11

Is there some reason that the shared keys mod that Synert gave you is insufficient? Loading that would be practically as easy as setting a DMFlag.

User avatar (0005396)
ZzZombo (reporter)
2012-11-15 04:58

Because it's Vanilla Doom feature so it should be built in Zandronum itself but until that you can use mods to simulate the behavior, of course. It like the old Vanilla RANG, until Zandronum got it we used PWADs for that.
User avatar (0005400)
Qent (updater)
2012-11-15 18:15

No we didn't. It is impossible to replicate the vanilla RNG with a PWAD. If you're talking about oldweps, that did not replicate vanilla, nor was it intended to. But are you saying that the shared keys mod already works the way you would like?
User avatar (0005403)
ZzZombo (reporter)
2012-11-16 01:15

No, I didn't try it.
User avatar (0005404)
someoneelse (reporter)
2012-11-16 17:12

My bad, it isn't a vanilla feature indeed. I just found this in a very, very old (but one of the best) speedrun demo. Still, I think such an early appearance of such feature makes it relevant...
User avatar (0006112)
Watermelon (developer)
2013-03-13 19:18

Would this be for only vanilla or be extended into non vanilla games that have keys?
User avatar (0006114)
Dusk (developer)
2013-03-13 23:55

I have an implementation of this around that manages all AKeys. I've just been unsure of whether it would be a good idea to add it considering a mod already implements the feature. However a mod cannot do it for all AKeys while an engine feature could.
User avatar (0006275)
someoneelse (reporter)
2013-04-09 15:13

Water, standard IWADs, I think?
Well, using it as a mod has many disadvantages: it can't be changed while in game, it's not convenient enough to be widely used, also additional mods in vanilla servers may make server look like it isn't vanilla.
User avatar (0006288)
Marcaek (reporter)
2013-04-16 19:24

Considering that this could apply to all games with keys, and reduce dependency on PWADs, I'm very much for it.
User avatar (0007135)
someoneelse (reporter)
2013-09-07 21:09

20 to 1 is a pretty good score, maybe it could be reconsidered? What if I could find someone who can write the code from ijon's wad into a ready patch?
User avatar (0007136)
Qent (updater)
2013-09-07 21:33

Dusk has already written it. It's just a question of whether to add it in.
User avatar (0007137)
Arco (updater)
2013-09-07 22:06

Quote from someoneelse
20 to 1 is a pretty good score, maybe it could be reconsidered? What if I could find someone who can write the code from ijon's wad into a ready patch?


Just because this feature has a high number of supporters does not imply that it will be added any time sooner. That's the developer's decision. And DECORATE and C+ rely on a completely different codebase, both of which are not compatible.
User avatar (0007141)
Dusk (developer)
2013-09-08 10:14

Guess I'll make a patch then...
User avatar (0007163)
someoneelse (reporter)
2013-09-11 15:54

I'd love to check its effect thoroughly, doing servers and testing with friends... I am unable to produce binaries currently though. If someone would be able to make win binaries, I would do the solid testing.
User avatar (0007194)
Dusk (developer)
2013-09-15 20:58

This has been added
User avatar (0007461)
Qent (updater)
2013-10-24 22:45

This works in 131012. I tested in Doom, Hexen, and Heretic. Strife co-op was too broken to tell, but worked with cheat-summoned keys. I also tested KDiZD, which has custom keys.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: ZzZombo Balrog Qent someoneelse Combinebobnt Dusk QuadrumpusGuy HexaDoken DevilHunter Marcaek Lego_CS jwaffe katZune Esum Tux Syn2rt lollipop Toxicity Wirtualnosc wario IceDragon Monsterovich TheMightyHeracross
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2012-11-06 14:35 someoneelse New Issue
2012-11-11 15:59 Balrog Note Added: 0005361
2012-11-12 04:34 someoneelse Note Added: 0005379
2012-11-14 18:10 Qent Note Added: 0005395
2012-11-14 18:11 Qent Note Edited: 0005395 View Revisions
2012-11-14 22:23 Dusk Status new => feedback
2012-11-15 04:58 ZzZombo Note Added: 0005396
2012-11-15 18:15 Qent Note Added: 0005400
2012-11-16 01:15 ZzZombo Note Added: 0005403
2012-11-16 17:12 someoneelse Note Added: 0005404
2012-11-16 17:12 someoneelse Status feedback => new
2013-03-13 19:18 Watermelon Note Added: 0006112
2013-03-13 23:55 Dusk Note Added: 0006114
2013-04-09 15:13 someoneelse Note Added: 0006275
2013-04-16 19:24 Marcaek Note Added: 0006288
2013-09-07 21:09 someoneelse Note Added: 0007135
2013-09-07 21:33 Qent Note Added: 0007136
2013-09-07 22:06 Arco Note Added: 0007137
2013-09-08 10:14 Dusk Assigned To => Dusk
2013-09-08 10:14 Dusk Status new => assigned
2013-09-08 10:14 Dusk Note Added: 0007141
2013-09-08 10:53 Dusk Target Version => 1.3
2013-09-08 11:20 Dusk File Added: stuff.diff
2013-09-08 11:20 Dusk Status assigned => needs review
2013-09-08 11:20 Dusk File Deleted: stuff.diff
2013-09-08 11:21 Dusk File Added: keys.diff
2013-09-08 11:22 Dusk File Deleted: keys.diff
2013-09-08 11:22 Dusk File Added: keys.diff
2013-09-08 12:09 Dusk File Deleted: keys.diff
2013-09-08 12:10 Dusk File Added: keys.diff
2013-09-11 15:54 someoneelse Note Added: 0007163
2013-09-13 05:51 Dusk File Deleted: keys.diff
2013-09-13 05:52 Dusk File Added: keys.diff
2013-09-15 20:58 Dusk Note Added: 0007194
2013-09-15 20:58 Dusk Status needs review => needs testing
2013-09-15 23:00 Toxicity Note Added: 0007195
2013-09-16 07:21 Dusk Note Deleted: 0007195
2013-10-24 22:45 Qent Note Added: 0007461
2013-10-24 22:45 Qent Status needs testing => resolved
2013-10-24 22:45 Qent Fixed in Version => 2.0-beta
2013-10-24 22:45 Qent Resolution open => fixed
2015-01-23 04:56 Blzut3 Fixed in Version 2.0-beta => 2.0
2018-09-30 23:07 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker