Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001160Zandronum[All Projects] Suggestionpublic2012-11-02 21:132018-09-30 23:20
ReporterToxicity 
Assigned ToTorr Samaho 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.0 
Target Version2.0Fixed in Version2.0 
Summary0001160: Requesting out-of-sequence backport of the GAMEINFO lump
Descriptionhttp://zdoom.org/wiki/GAMEINFO [^]

I think that backporting support for this lump will be immensely beneficial to Zandronum modders, specifically because skulltag_actors.pk3 and skulltag_data.pk3 can now be autoloaded for wads which require their use.

This should eliminate the hundreds of threads that we constantly see on the forums. You know, the ones where newbie players ask "HELP brutal doom gives me the error 'actor minigun not found in blahblahblahblah'" and all recieve the same answer ("you need to load skulltag_actors and skulltag_data").

Included is an example of a wad which makes use of this feature.
Attached Files? file icon ST_resources_autoload_example.wad [^] (135 bytes) 2012-11-02 21:13

- Relationships
child of 0001490closedTorr Samaho Backport ZDoom 2.5.0 

-  Notes
User avatar (0005284)
Balrog (reporter)
2012-11-02 23:21

Seconding. GAMEINFO also has a lot of cool stuff for custom games - autoloading supporting PWADs, for one, and I believe that custom IWADs with GAMEINFO don't need to have lumps to fake being a retail IWAD.
User avatar (0007332)
Arco (updater)
2013-10-06 17:59

Works as intended in v2.0.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: Toxicity Balrog ZzZombo bluewizard katZune kudo HexaDoken Lego_CS Esum
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2012-11-02 21:13 Toxicity New Issue
2012-11-02 21:13 Toxicity File Added: ST_resources_autoload_example.wad
2012-11-02 23:21 Balrog Note Added: 0005284
2013-09-09 10:48 Dusk Relationship added child of 0001490
2013-09-09 10:48 Dusk Target Version => 2.0
2013-10-06 17:59 Arco Note Added: 0007332
2013-10-08 20:03 Arco Status new => resolved
2013-10-08 20:03 Arco Fixed in Version => 2.0-beta
2013-10-08 20:03 Arco Resolution open => fixed
2013-10-08 20:03 Arco Assigned To => Arco
2013-10-08 20:19 Blzut3 Assigned To Arco =>
2013-10-08 20:19 Blzut3 Fixed in Version 2.0-beta => 2.0
2013-10-22 17:01 Dusk Status resolved => assigned
2013-10-22 17:01 Dusk Assigned To => Torr Samaho
2013-10-22 17:02 Dusk Status assigned => resolved
2018-09-30 23:20 Blzut3 Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker