Zandronum Chat on our Discord Server Get the latest version: 3.0
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001087Doomseeker[All Projects] Suggestionpublic2012-09-29 17:502018-09-29 14:46
ReporterSlenderShy 
Assigned ToZalewa 
PrioritylowSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.11.1 BetaFixed in Version0.11.1 Beta 
Summary0001087: IRC script on join?
DescriptionWhen I log on to IRC I have 30 seconds to type my password, it would be nice if the Doomseeker built in IRC had a script that gets ran when you join the Zandronum server. Like in mIRC and just about every other client.
Attached Filesjpg file icon doomseeker_irc_autojoin_script.jpg [^] (51,636 bytes) 2013-11-17 17:31

- Relationships

-  Notes
User avatar (0004871)
Konar6 (reporter)
2012-09-30 09:38

It already lets you specify your NickServ login, and join channels. Go to Options -> IRC Options -> Networks -> [double click on one].
User avatar (0004879)
SlenderShy (reporter)
2012-09-30 13:00

@Konar6 It would be nice if the saved password was at least hashed instead of just plain text.
User avatar (0004883)
Blzut3 (administrator)
2012-09-30 16:54

@SlenderShy please read this:https://developer.pidgin.im/wiki/PlainTextPasswords [^]
User avatar (0004931)
Zalewa (developer)
2012-10-03 16:50
edited on: 2012-10-03 16:51

The exact reason that you need this is already implemented but I agree that Doomseeker IRC client could use automatic scripting feature. Moreover, I believe that this client needs some other improvements. They will be added... eventually...

User avatar (0007564)
Zalewa (developer)
2013-11-17 17:32

I've attached a screenshot with proposed solution. Is that satisfying or do you have any other suggestions?
User avatar (0007575)
Blzut3 (administrator)
2013-11-19 21:40

I've set the target version to 0.11.1 since it's committed to the default branch and I don't see this feature causing much harm.
User avatar (0007580)
Zalewa (developer)
2013-11-20 20:54

Please anyone test with following build:
doomseeker 0.11 Beta-131119-2132

You can also update from "Beta" channel.

User avatar (0007632)
DevilHunter (reporter)
2013-11-29 02:19

Works as Expected. Nice job on this one.
User avatar (0007633)
Zalewa (developer)
2013-11-29 16:26

Resolving then.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2012-09-29 17:50 SlenderShy New Issue
2012-09-30 09:38 Konar6 Note Added: 0004871
2012-09-30 12:57 SlenderShy Note Added: 0004878
2012-09-30 13:00 SlenderShy Note Added: 0004879
2012-09-30 13:00 SlenderShy Note Deleted: 0004878
2012-09-30 16:54 Blzut3 Note Added: 0004883
2012-10-03 16:50 Zalewa Note Added: 0004931
2012-10-03 16:51 Zalewa Note Edited: 0004931 View Revisions
2013-11-15 23:23 Zalewa Assigned To => Zalewa
2013-11-15 23:23 Zalewa Status new => assigned
2013-11-17 17:31 Zalewa File Added: doomseeker_irc_autojoin_script.jpg
2013-11-17 17:32 Zalewa Note Added: 0007564
2013-11-17 17:34 Zalewa Status assigned => needs review
2013-11-19 21:38 Blzut3 Target Version => 0.11.1 Beta
2013-11-19 21:40 Blzut3 Note Added: 0007575
2013-11-20 20:54 Zalewa Note Added: 0007580
2013-11-20 20:54 Zalewa Status needs review => needs testing
2013-11-29 02:19 DevilHunter Note Added: 0007632
2013-11-29 16:26 Zalewa Note Added: 0007633
2013-11-29 16:26 Zalewa Status needs testing => resolved
2013-11-29 16:26 Zalewa Fixed in Version => 0.11.1 Beta
2013-11-29 16:26 Zalewa Resolution open => fixed
2018-09-29 14:46 WubTheCaptain Status resolved => closed






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker