MantisBT - Zandronum
View Issue Details
0003876Zandronum[All Projects] Bugpublic2021-01-30 19:052021-07-23 21:09
Recurracy 
 
normalminoralways
closedduplicate 
MicrosoftWindows 10
3.1-beta 
3.1 
0003876: ACS function SetActorProperty APROP_ScaleX nun-functional in MP
I'm using SetActorProperty(0, APROP_ScaleX, 4.0) in an ACS library to widen enemies a certain projectile hits. However, it simply refused to work when I made a server to test my mod, so I tried to make a quick map using Ultimate Doombuilder to replicate it. It worked in the map. Then I decided to run my mod in singleplayer and then it suddenly worked. From this I can deduce the function doesn't work in multiplayer.
Start Doomseeker with the included, and make a server. Use the plasma rifle to shoot an enemy. In multiplayer, the enemy shouldn't become wide, while if you start the game with this wad in singleplayer, they will become wide.
No tags attached.
duplicate of 0003847resolved Torr Samaho SetActorProperty with APROP_ScaleX or APROP_ScaleY does not work online 
? xscaleglitch.pk3 (1,017) 2021-01-30 19:05
https://zandronum.com/tracker/file_download.php?file_id=2639&type=bug
Issue History
2021-01-30 19:05RecurracyNew Issue
2021-01-30 19:05RecurracyFile Added: xscaleglitch.pk3
2021-02-10 04:49IvanNote Added: 0021596
2021-07-23 21:09KaminskyRelationship addedduplicate of 0003847
2021-07-23 21:09KaminskyStatusnew => closed
2021-07-23 21:09KaminskyResolutionopen => duplicate
2021-07-23 21:09KaminskyFixed in Version => 3.1

Notes
(0021596)
Ivan   
2021-02-10 04:49   
Already reported by me here:https://zandronum.com/tracker/view.php?id=3867 [^]