MantisBT - Zandronum
View Issue Details
0003725Zandronum[All Projects] Bugpublic2019-10-18 19:142019-10-18 19:14
Raspberry Pi 3BRaspbian10 Linux 4.19.66
0003725: Raspbian Buster crash when connecting to specific server.
I have multiple servers hosted on my Pi 3, of which 4 are Zandronum Servers.
I wanted to get a fifth server online with QCDE with AeonDM, so I got the files from moddb and transferred them to the pi, created another config and launch script and tried it out.
At first it seems fine, getting to a level as it seems, but when I connect to it with my PC I get on the client side a repeated "Authenticating level..." message, which keeps going until I force close the zandronum client.
On my Pi's console I see a connection (my pc), but then a "Unable to spawn bot Die Apotheke" message just before a "Fatal Error Address not mapped to object (signal 11) Address: 0x58" message and then the crash log getting written before going back to the console shell. Connecting to the other servers goes smoothly as it should and gives no errors at all.
I compiled this version of zandronum on this same exact Raspberry Pi btw.
1) Compile Zandronum 3.0 on a Pi 3B with Raspbian 10 Buster.
2) Launch zandronum with Doom2 as IWAD, and QCDEv2.5.1.pk3, QCDE_PvPvisibility.pk3 and AeonQCDE.pk3 as PWADs, give it the -host switch and set it to port 10670 (have also tried with port 10680 but I dont think this is the issue here).
3) Wait for it to load a level and be accessible via the server browser or otherwise reachable from another PC.
4) Connect to it and see the things I described earlier.
I have put the latest crash log I got from this as a file.
No tags attached.
log zandronum-crash-10_18_2019-21_10_41.2824.log (17,227) 2019-10-18 19:14
Issue History
2019-10-18 19:14lorecast162New Issue
2019-10-18 19:14lorecast162File Added: zandronum-crash-10_18_2019-21_10_41.2824.log

There are no notes attached to this issue.